Last Comment Bug 535528 - Mail Compose - address autocomplete causes application freeze (OE Contacts / Windows Address Book related)
: Mail Compose - address autocomplete causes application freeze (OE Contacts / ...
Status: RESOLVED FIXED
: fixed-seamonkey2.0.2, fixed-seamonkey2.0.3, hang
Product: MailNews Core
Classification: Components
Component: Address Book (show other bugs)
: unspecified
: x86 Windows XP
: -- critical with 8 votes (vote)
: Thunderbird 3
Assigned To: neil@parkwaycc.co.uk
:
:
Mentors:
: 535605 535776 535864 536738 536995 537554 538857 (view as bug list)
Depends on:
Blocks: 537598 447927
  Show dependency treegraph
 
Reported: 2009-12-17 02:19 PST by hhgygy
Modified: 2010-01-24 12:19 PST (History)
24 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
.1-fixed


Attachments
Workaround - disable autocomplete for outlook (checked in trunk and branch) (1.26 KB, patch)
2009-12-31 08:31 PST, neil@parkwaycc.co.uk
standard8: review+
standard8: superreview+
standard8: approval‑thunderbird3.0.1+
standard8: approval‑seamonkey2.0.3+
Details | Diff | Splinter Review

Description hhgygy 2009-12-17 02:19:28 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091017 SeaMonkey/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091017 SeaMonkey/2.0

When I compose a new mail and enter the first letter of the addressee, the autocomplete freezes the entire application suite
This has been reported in Bug 509996 

Reproducible: Always

Steps to Reproduce:
1.Open Compose New Mail
2.Insert any letter in the addressee field
3.
Actual Results:  
The whole application freezes,, can be closed with Ctrl-Alt-Del only

Expected Results:  
Should autocomplete the addressee (first matching name)

It is in the newest release 2.0.1. 
I restored Seamonkey 2.0 version which works fine in this respect.
Comment 1 Tobias Fischer 2009-12-17 03:18:05 PST
I can confirm this Bug using:
Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7pre) Gecko/20091216 Mnenhy/0.8.0pre2 SeaMonkey/2.0.2pre

and some previous 1.9.1.x-Nightly-Builds later than the SeaMonkey 2.0-Release-Builds. 

Unfortunately I can not provide better Steps to reproduce. Sometimes I was able to add Recipients via Autocomplete, but mostly SeaMonkey hangs and must be killed using the Task-Manager. First I have suspected something in my old Addressbooks, so I have exported them as csv, and reimported them. Seems, that it has helped for some days, but now I get the hang again. Especially when I try to edit an added E-Mail Address (Change Name or part of Address), SeaMonkey hangs. 

I have seen the hang only on WinXP SP3, but not on Win2k, neither on Windows 7.
Comment 2 hhgygy 2009-12-17 03:22:27 PST
(In reply to comment #1)
Yeah I also restored my Address Book believing that it might be the problem
Comment 3 hhgygy 2009-12-17 04:52:41 PST
Update.
Now, Seamonkey has updated itself to 2.0.1. and the same bug occurred.
BUT
I exported and then deleted all my e-mail addresses and then reimported them and now it seems to work.
Comment 4 hhgygy 2009-12-17 05:06:42 PST
Update.
Same bug happened in the other user profile we use on my computer.
I exported and deleted all e-mail addresses and then reimported them as above.
It also seems to work now.
Comment 5 Jens Hatlak (:InvisibleSmiley) 2009-12-17 13:16:13 PST
Chances are the regression has been introduced by the fix for bug 447927.

Setting Version to 2.0 branch until someone can verify with 2.1a1pre nightlies (which are probably affected as well).

To all commenters: Please tell how many address books and mailing lists you have. I don't know whether it's important, but maybe it helps.
Comment 6 Albert Fong 2009-12-17 13:22:32 PST
Encountered same problem in Seamonkey 2.0.1. Only had contacts in Address Book's "Personal Address Book". Export these contacts and deleted. On restarting Seamonkey, problem persisted. Finally deleted the empty "OE Contacts" address book, and Seamonkey started working again.
Comment 7 Albert Fong 2009-12-17 13:25:19 PST
My observation occurred on a PC running Windows XP Pro SP3. Only one address book had any contacts, the "Personal Address Book" which contained a total of 57 contacts.
Comment 8 Jens Hatlak (:InvisibleSmiley) 2009-12-17 13:28:24 PST
(In reply to comment #6)
> Finally deleted the empty "OE Contacts" address book, and Seamonkey
> started working again.

Ah! Does anyone else here have such an AB? I don't (I never used OE).

Warning: I'm not absolutely sure but I remember the OE Contacts AB is actually OE's AB so deleting its contents might delete the original contacts!
Comment 9 Jens Hatlak (:InvisibleSmiley) 2009-12-17 13:44:11 PST
A user in the German newsgroups, Peter Müller, just confirmed that he also sees this problem in connection with the OE AB. hhgygy, Tobias, can you confirm this also applies to you?
Comment 10 Michael Graubart 2009-12-17 15:18:10 PST
I used the automatic update to 2.0.1 from 2.0 without touching my address books or anything else in my profile, and I have experienced no crashes when using autocomplete.

My address book was created in an earlier version of SM and dragged into the 2.0 profile. I do not collect addresses in the Collected Addresses AB.

My computer is a Mac G4 (PPC) with OS X 10.4.11.
Comment 11 Albert Fong 2009-12-17 20:42:38 PST
Some details I forgot to mention:  when Seamonkey hangs, in Task Manager the seamonkey.exe process is apparently idle, using 0% CPU Time.  In fact, the CPU is basically idle as well.  In the Application tab, all the Seamonkey windows are listed as "Not Responding".
Comment 12 Leon 2009-12-17 21:47:08 PST
I am using Win XP SP2 with Seamonkey 2.0.1, my email composing windows will freeze during any ldap lookup, event I disable the network, it still freeze. When I revert back to v. 2.0. Everything back to normal.
Comment 13 :Hb 2009-12-18 01:43:47 PST
*** Bug 535605 has been marked as a duplicate of this bug. ***
Comment 14 Tobias Fischer 2009-12-18 02:03:47 PST
(In reply to comment #9)
> A user in the German newsgroups, Peter Müller, just confirmed that he also sees
> this problem in connection with the OE AB. hhgygy, Tobias, can you confirm this
> also applies to you?

Indeed. I have never used Outlook or OE, but I have got also an empty OE Contacts Addressbook in my current SM-Profile. The MS-Win Address Book File [User-Profile\Appdata\Microsoft\Username\username.wab] has no entries, and a Size of 173 KB. After deleting the (empty) OE Contacts Addressbook from SeaMonkey, I can not reproduce the hang anymore, so I don't try to rename/delete the username.wab-File. Thx for the hint to delete the OE Contacts ABook.
Comment 15 Couvert 2009-12-18 02:09:36 PST
leon how to revert back to v 2.0 ?
Comment 16 Jens Hatlak (:InvisibleSmiley) 2009-12-18 03:02:01 PST
Adjusting summary (feedback from hhgygy pending but assuming it's the same).
Comment 17 hhgygy 2009-12-18 04:23:55 PST
I think I have also deleted the OE contacts AB when I tried to reimport my addresses. In both of my profiles there is only Personal and Collected
Comment 18 Tobias Fischer 2009-12-18 06:00:00 PST
*** Bug 535776 has been marked as a duplicate of this bug. ***
Comment 19 Robert Kaiser 2009-12-18 06:58:15 PST
Mark, any idea about this one?
Comment 20 Mark Banner (:standard8, limited time in Dec) 2009-12-18 07:15:15 PST
(In reply to comment #19)
> Mark, any idea about this one?

I don't know much at all about the Outlook interfaces. Neil was the last one to touch them ;-)
Comment 21 Leon 2009-12-18 11:36:43 PST
(In reply to comment #15)
> leon how to revert back to v 2.0 ?

I uninstalled the entire 2.0.1, then reinstalled back the earlier version 2.0. The new Seamonkey keep all the user profile & setting outside so reinstalling with older or newer version is relatively easy.
Comment 22 Couvert 2009-12-18 12:40:14 PST
Thank leon bu where i can found the v2.0. ?
Comment 23 neil@parkwaycc.co.uk 2009-12-18 12:44:25 PST
I managed to reproduce this. There seems to be some sort of deadlock between the addressbook and the main thread, but I'm not sure why it's happening yet.
Comment 24 Robert Kaiser 2009-12-19 17:25:02 PST
I added a stance about this bug to the relnotes at http://www.seamonkey-project.org/releases/seamonkey2.0.1/#issues
Comment 25 :Hb 2009-12-20 04:06:49 PST
*** Bug 535864 has been marked as a duplicate of this bug. ***
Comment 26 neil@parkwaycc.co.uk 2009-12-20 14:28:07 PST
I don't think that the outlook express address book likes being searched, as the address book tries to generate the results asynchronously but the autocomplete component only tries to read the results synchronously and discards the address book presumably while the query is still in progress, which then could conceivably confuse things further.
Comment 27 Couvert 2009-12-21 01:44:39 PST
The bug appened if one of the adress books is empty. In my case the OE directory was empty I delete it and and Seamonkey started working again.
Comment 28 styfle123 2009-12-23 16:47:16 PST
I can confirm this bug on 2.0.1 when entering a contacts name. It also happens when clicking compose and then the address button to open the address book. Seamonkey freezes and only ctrl + alt + del can close it. I am using WinXP SP3.
Comment 29 :Hb 2009-12-25 12:59:46 PST
*** Bug 536738 has been marked as a duplicate of this bug. ***
Comment 30 Bob 2009-12-26 09:03:24 PST
I've tried a work-around technique that appears to work. After the Mail program is up and running, I open the address book and click on the Personal Address Book.

I haven't done extensive testing, but when I do that, the address completion works and Seamonkey hasn't crashed, yet.
Comment 31 Robert Kaiser 2009-12-28 07:17:31 PST
Neil, any chance you can investigate and hopefully find a patch soon? It would be good to ship an update with that as soon as we can, with us installing OE Contacts support by default, this affects a lot of our users...
Comment 32 Tobias Fischer 2009-12-28 13:05:55 PST
*** Bug 536995 has been marked as a duplicate of this bug. ***
Comment 33 neil@parkwaycc.co.uk 2009-12-28 14:48:05 PST
Well, the hang shows that the MAPI session is being initiated on the async query thread, but as native events don't get processed on that thread, the MAPI session can't then be synchronised back to the main thread.
Comment 34 neil@parkwaycc.co.uk 2009-12-28 15:16:34 PST
It's just dawned on me that this is partly a regression from bug 447927.

I think that the 1.x code manually filters the entire address book, which happens synchronously for the outlook express address book.

The 2.0.0 code only searched the primary email. It tried to enumerate a directory query. This never worked with the outlook express address book, because the query executed asynchronously.

The 2.0.1 code searches both primary and secondary emails. To do this it issues two queries in quick succession. Unfortunately the address book interface has been instantiated on the query thread, and the main thread cannot communicate with it, thus causing the application to deadlock when the query thread tries to synchronously return its results.
Comment 35 neil@parkwaycc.co.uk 2009-12-28 15:20:16 PST
Hmm, the OE express address book doesn't seem to query properly at all :-(
Comment 36 Robert Kaiser 2009-12-29 04:24:34 PST
(In reply to comment #35)
> Hmm, the OE express address book doesn't seem to query properly at all :-(

Hmm, can we paper over that for a 2.0.x update by just excluding the OE Contacts from being queried (even if that removes some of the wanted functionality of including it) and see for a more conclusive solution on trunk later?
Comment 37 jdh27 2009-12-29 11:56:51 PST
Also confirming exactly as hhgygy originally stated. In 2.0.1 on WinXP SP3.

Seems to be just the autocomplete when try to type in addressee. Fills in OK when Reply or when composing from address book listing. Have about 6 contact lists now. I see that OE thing. Ignored it as - do not care. Guess I cannot. Maybe I'll try the delete suggestion till fix is in.
Comment 38 Uli Link (:ul-mcamafia) 2009-12-31 05:51:56 PST
Alternate workaround:
For me the complete hang did not appeared using the UI in en-US language instead of de-DE.
Comment 39 Robert Kaiser 2009-12-31 07:16:17 PST
Uli:
That can only be happening by chance, as multiple people have seen this in en-US builds (and it's "de", not "de-DE").
Comment 40 neil@parkwaycc.co.uk 2009-12-31 08:31:28 PST
Created attachment 419685 [details] [diff] [review]
Workaround - disable autocomplete for outlook (checked in trunk and branch)
Comment 41 Mark Banner (:standard8, limited time in Dec) 2010-01-02 14:07:34 PST
As this is effectively mailnews core, I'm moving across to the mailnews product. Although TB doesn't have outlook AB enabled by default, the capability is still included in the code if the prefs are altered.
Comment 42 Mark Banner (:standard8, limited time in Dec) 2010-01-02 14:10:27 PST
Comment on attachment 419685 [details] [diff] [review]
Workaround - disable autocomplete for outlook (checked in trunk and branch)

r/sr/a=Standard8

Just to note I'm happy this doesn't have tests as it would be too difficult as we'd need interfaces to outlook etc, and also approving straight away, as I know SM wants to do a 2.0.2 build soon and the outlook part shouldn't affect Thunderbird by any significant amount.
Comment 43 neil@parkwaycc.co.uk 2010-01-02 16:30:17 PST
Comment on attachment 419685 [details] [diff] [review]
Workaround - disable autocomplete for outlook (checked in trunk and branch)

Pushed changeset 2254e41e8a20 to comm-central.

Pushed changeset 9751f5dc45a4 to releases/comm-1.9.1
Comment 44 Mark Banner (:standard8, limited time in Dec) 2010-01-03 04:32:47 PST
As this is a branch bug, can we mark this as fixed and spin off a new bug for fixing the main issue and removing the workaround? This will enable better tracking.
Comment 45 Robert Kaiser 2010-01-04 10:21:49 PST
Pushed the fix to COMM1916_20091204_RELBRANCH as well for the actual short-cycled 2.0.2 release of SeaMonkey, will mark for that as well once bug 537731 corrects flags/keywords for the fact that we short-cycle.
Comment 46 :Hb 2010-01-05 08:27:46 PST
*** Bug 537554 has been marked as a duplicate of this bug. ***
Comment 47 Robert Kaiser 2010-01-10 15:51:28 PST
*** Bug 538857 has been marked as a duplicate of this bug. ***
Comment 48 jesse 2010-01-11 09:18:27 PST
why is this marked as resolved fixed?  Can someone post a link to an open discussion about this problem?
Comment 49 neil@parkwaycc.co.uk 2010-01-11 09:25:00 PST
(In reply to comment #48)
> why is this marked as resolved fixed?
Because it is fixed in SeaMonkey 2.1a1pre comm-central nightlies, which is where fixes first get tested. It was then marked as fixed-seamonkey2.0.3 for comm-1.9.1, which is where it got approval, and then fixed-seamonkey2.0.2, because the build engineer specifically included it in the 2.0.2 release tag.

> Can someone post a link to an open discussion about this problem?
What sort of discussion? This bug already has some discussion in it.

Note You need to log in before you can comment on or make changes to this bug.