If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Consider adding autocompletion of add-on names

VERIFIED DUPLICATE of bug 546826

Status

addons.mozilla.org Graveyard
Search
VERIFIED DUPLICATE of bug 546826
8 years ago
2 years ago

People

(Reporter: stephend, Unassigned)

Tracking

unspecified
4.x (triaged)

Details

(Whiteboard: [z][clearleft], URL)

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

8 years ago
(I've been wanting to file a bug on this since, like, forever.)

Summary: Auto-complete add-on names in the "search for add-ons" textfield

STR:

1. Load https://addons.mozilla.org/en-US/firefox/
2. In the "search for add-ons" textfield, type something you know has results -- e.g. "cooli"

AR:

No auto-completion

ER:

A simple dropdown autocompletion would suffice, a la Google.com

So very Web 2.0! ;-)
Don't we already have something similar on the Create a Collection page (https://addons.mozilla.org/en-US/firefox/collections/add)? Go down to the last section (Choose Your First Add-Ons) and start typing add-on names in the text box. Transplantable? ;)

This could also work for category names, tags, and (if we have the data) popular search terms. Not sure how they'd be prioritized or interleaved off the top of my head, but would make the feature a bit more interesting.
Yeah, that's scattered around.  We'll add it to all add-on boxes eventually, but the current code needs to be tweaked a bit.  Right now it's just a single function that everyone calls, but we need to adjust it for different users.  E.g. admins should see disabled add-ons but normal users shouldn't.
(Reporter)

Updated

8 years ago
Summary: Consider adding autocompletion of add-ons names → Consider adding autocompletion of add-on names
Whiteboard: [z][clearleft]
Target Milestone: --- → 4.x (triaged)
Created attachment 426587 [details]
proposal 1, no groups
Created attachment 426588 [details]
proposal 2, groups
So, one change that will definitely be made is reducing the size of the text and icons. The other changes I'm a bit torn on.

Clearleft thinks we should have a search box that searches everything and we should get rid of the dropdown or more likely move it to the Advanced criteria. I agree with this, but I think it might need to wait until after [z].

So I think option 1 should probably be used until that happens and the suggestions are filtered based on the option selected in the dropdown. If we move to a MAGIC SEARCH later on, we can break it down into categories with option 2.

Thoughts? Dissent?
I like everything in comment 5

*rabble rabble*
and fyi... I think a lot of magic search is implemented already (on remora and zamboni)... depending on your definition of magic.
Created attachment 427018 [details]
search suggestions mock
Attachment #426587 - Attachment is obsolete: true
Attachment #426588 - Attachment is obsolete: true
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 546826
(Reporter)

Comment 10

8 years ago
Verified duplicate, though I don't know why work wasn't done in this bug.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.