Closed Bug 538174 Opened 10 years ago Closed 10 years ago

n900: App Manager only picks up xulrunner as an update option going from 12/5 nightly to rc2

Categories

(Firefox for Android Graveyard :: General, defect)

Fennec 1.1
ARM
Maemo
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
fennec1.0

People

(Reporter: aakashd, Assigned: mfinkle)

References

Details

Attachments

(4 files, 3 obsolete files)

Steps to Reproduce:
1. Download 12/5 nightly 1.9.2 build
2. Go to http://ftp.mozilla.org/pub/mozilla.org/mobile/candidates/1.0rc2-candidates/repos/1.9.2_multi/
3. Download and Open the install
4. After adding the catalog in the app manager, go to "Update"

Actual Results:
Only the xulrunner package 1.9.2pre-20100106010507 shows up as an update option and I receive a message that "fennec is already installed".

Expected Results:
I would expect both builds to be available to update.
Heh, I'm going to guess that 1.0(string) is considered "newer" than 1.0
Guessing that apt is basically doing the same as RPM that's indeed the case.
Severity: blocker → normal
Attached patch patch (obsolete) — Splinter Review
* Make MOZ_APP_VERSION become branding dependent (move into branding/configure.sh)
* Update package strings and maintainer
* Include a buildid (date string) in the nightly deb package version

depends on bug 469202
Assignee: nobody → mark.finkle
Attached patch patch 2 (obsolete) — Splinter Review
Same as previous patch but fixed the debhelper version
Attachment #420461 - Attachment is obsolete: true
Attachment #420464 - Flags: review?(bugmail)
Attachment #420464 - Flags: review?(bugmail) → review+
Bumped the version
Talked this over with mark on IRC - really don't like that we made the version depend on branding here. I think we should revert to setting in confvars.sh and instead just have the version bumps happen manually on the relbranch. I'll put up a patch.
Attachment #420478 - Attachment description: patch for relbranch → followup for relbranch
Attachment #420477 - Flags: review+
think we can call this fixed...
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → RC
Ok, this broke my repo update automation... I basically source confvars.sh and figure out the fennec deb name from that, then figure out the xulrunner deb name by downloading fennec + extracting the files.

The renames with dates will complicate this.  They will also fill up the latest-nightly directories with fennecs and xulrunners since they won't overwrite each other.

I can figure out workarounds for the above, but:

- weren't we updating from 1.0b6pre -> 1.0b6pre ?
- if so, couldn't we update from 1.1a1pre -> 1.1a1pre without the date string?

Also, won't updating from fennec_1.1a1pre~20100106202533_armel.deb -> fennec_1.1a1 be an issue?
(In reply to comment #11)

> I can figure out workarounds for the above, but:
> 
> - weren't we updating from 1.0b6pre -> 1.0b6pre ?
> - if so, couldn't we update from 1.1a1pre -> 1.1a1pre without the date string?
> 
> Also, won't updating from fennec_1.1a1pre~20100106202533_armel.deb ->
> fennec_1.1a1 be an issue?

From what I learned yesterday:
fennec_1.1a1pre > fennec_1.1a1pre~20100106202533

and:

fennec_1.1.0 > fennec_1.1a1pre

However:

fennec_1.1a1pre > fennec_1.1a1

So I don't know how we plan to release alphas and betas
(In reply to comment #12)
> However:
> 
> fennec_1.1a1pre > fennec_1.1a1
> 
> So I don't know how we plan to release alphas and betas

We need our debian package version to not include 'pre', unless it is after the ~
but at the same time, we want pre in our actual firefox version...
1.1a1~pre~2009 ?

We could make the app version be 1.1a1~pre in Firefox and the "~2009" would be tacked on for the debian version.
1.1a1 > 1.1a1~pre~2009
(In reply to comment #15)
> We could make the app version be 1.1a1~pre in Firefox

That would be cool.

> and the "~2009" would be
> tacked on for the debian version.

Is the ~2009 necessary? (It would be easier to guess than down to the second, but if it's not necessary let's drop it.)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This patch moves the deb package version creation into the installer/Makefile and strips the "pre" from nightly deb package versions.
Attachment #420603 - Flags: review?(pavlov)
Attachment #420603 - Flags: review?(gavin.sharp)
Now with better "pre" stripping
Attachment #420603 - Attachment is obsolete: true
Attachment #420611 - Flags: review?(pavlov)
Attachment #420603 - Flags: review?(pavlov)
Attachment #420603 - Flags: review?(gavin.sharp)
Attachment #420611 - Flags: review?(gavin.sharp)
Comment on attachment 420611 [details] [diff] [review]
followup for default with version tweak 2

lets land this on default, but not on relbranch
Attachment #420611 - Flags: review?(pavlov) → review+
Comment on attachment 420611 [details] [diff] [review]
followup for default with version tweak 2

I added gavin's changes in already
Attachment #420611 - Flags: review?(gavin.sharp)
pushed to default:
https://hg.mozilla.org/mobile-browser/rev/ba7bf70f98aa

bug 538455 covers the repo push breakage
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Component: Linux/Maemo → General
QA Contact: maemo-linux → general
You need to log in before you can comment on or make changes to this bug.