JS errors on page loading: reference to undefined property window._content.HTTPIndex

RESOLVED DUPLICATE of bug 55798

Status

SeaMonkey
General
P3
normal
RESOLVED DUPLICATE of bug 55798
18 years ago
13 years ago

People

(Reporter: rubydoo123, Assigned: nhottanscp)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Loading web pages (e.g. http://news.bbc.co.uk), I see lots of these errors:

JavaScript strict warning:
chrome://navigator/content/navigator.js line 1970: reference to undefined proper
ty window._content.HTTPIndex
I think ben can handle this better. I let you decide.
Assignee: radha → don

Comment 2

18 years ago
Yep.  More correctness fun for Ben.

Ben, do we really need to fix this stuff before RTM?
Assignee: don → ben

Comment 3

18 years ago
The culprit here is the checkForDirectoryListing() function, which nhotta added. 
CCing him.
(Assignee)

Comment 4

18 years ago
There is another bug filed for this. The bug 53470 which was resolved as a dup 
of 51211.

Comment 5

18 years ago
This is really really annoying since it totally floods the console with errors!
OS: Windows NT → All

Comment 6

18 years ago
Reassign to nhotta. nhotta: i looked at the other bugs, and none of them 
addressed the JS error specifically, so this should stay open for that.

I'm also worried about the amount of times we're calling a JS function that is 
only there to detect directory listings. Can't this be optimized?
Assignee: ben → nhotta
(Assignee)

Comment 7

18 years ago
The amount of times this to be called to be fixed by bug 51211. I applied the 
patch of 51211 then I only saw one warning per page load.
And here is a patch for the warning.

Index: browser/resources/content/navigator.js
===================================================================
RCS file: /cvsroot/mozilla/xpfe/browser/resources/content/navigator.js,v
retrieving revision 1.233
diff -c -r1.233 navigator.js
*** navigator.js	2000/09/20 12:23:49	1.233
--- navigator.js	2000/09/27 20:39:04
***************
*** 1967,1973 ****
  }
  
  function checkForDirectoryListing() {
!     if ( window._content.HTTPIndex == "[xpconnect wrapped nsIHTTPIndex]"
           &&
           typeof window._content.HTTPIndex == "object"
           &&
--- 1967,1974 ----
  }
  
  function checkForDirectoryListing() {
!     if ( "HTTPIndex" in window._content && 
!          window._content.HTTPIndex == "[xpconnect wrapped nsIHTTPIndex]"
           &&
           typeof window._content.HTTPIndex == "object"
           &&
Status: NEW → ASSIGNED

Comment 8

18 years ago
adding "approval" keyword, bug has a potential patch.
Keywords: approval
*** Bug 55381 has been marked as a duplicate of this bug. ***

Comment 10

18 years ago
r=sfraser on the patch.
(Assignee)

Comment 11

18 years ago
*** Bug 55381 has been marked as a duplicate of this bug. ***

Comment 12

18 years ago
Ftang - Doesn't this need to be marked as [RTM Need Info]?

Adding FTang to cc: list.
(Assignee)

Updated

18 years ago
Target Milestone: --- → M22
nominating for mozilla0.9, if you think this should go into rtm, please nominate.
Keywords: mozilla0.9, patch

Comment 14

18 years ago

*** This bug has been marked as a duplicate of 55798 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.