Last Comment Bug 538738 - need keyboard accelerator to select the quick search filter from the dropdown menu
: need keyboard accelerator to select the quick search filter from the dropdown...
Status: RESOLVED DUPLICATE of bug 538821
:
Product: Thunderbird
Classification: Client Software
Component: Search (show other bugs)
: unspecified
: x86 All
-- enhancement with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 551810 (view as bug list)
Depends on: 573496
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-08 23:28 PST by Vinay Y S
Modified: 2011-04-12 23:15 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Vinay Y S 2010-01-08 23:28:52 PST
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.0.249.49 Safari/532.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

When we are trying to find a particular e-mail thread of interest, we typically try different search criteria one after another until we get the message. This typically involves selecting different options from the quick search drop down menu and entering the appropriate keyword.

Today, to select a different option from the quick search drop-down menu, we have to use mouse as there is no keyboard shortcut or any other mechanism. This slows down the user's search and is a annoying usability issue.

A simple enhancement to provide a keyboard accelerator to select different options from the drop-down would easily solve this.

A better enhancement would be to support search operators (special keywords that map to the already existing drop-down menus) as gmail search does.
http://mail.google.com/support/bin/answer.py?hl=en&answer=7190

I'm not asking for new search operators, just mapping of keyboard shortcuts or special keywords in the search text to the existing search filters in the drop-down menu. This would improve the user experience significantly.



Reproducible: Always

Steps to Reproduce:
1. Try to find a message. Select From filter. Assume you failed to locate the message you wanted.
2. Now, try to find the message using To filter. For this you have use your mouse to select the To filter from the drop-down.
3. Assume you failed to locate the message again, and want to select a different search filter.
Actual Results:  
Not having a keyboard shortcut to select a different search filter is slowing your search experience.

Expected Results:  
A keyboard based mechanism, like keyboard shortcut or a special search keyword, to select the search filter you wish to use would speed up your search experience significantly.

Please provide a keyboard shortcut or a special keyword search operator that maps to the existing search filters.
Comment 1 User image zug_treno 2010-03-13 12:52:39 PST
*** Bug 551810 has been marked as a duplicate of this bug. ***
Comment 2 User image Thomas D. (currently busy elsewhere; needinfo?me) 2010-06-05 05:44:44 PDT
I'm afraid this will be "wontfix" or "invalid" when the new quick filter bar introduced by bug 545955 will turn the dropdown into a secondary filter modification bar. Which provides a convenient UI solution for the problem of this bug.
Comment 3 User image Ludovic Hirlimann [:Usul] 2010-06-15 01:36:42 PDT
(In reply to comment #2)
> I'm afraid this will be "wontfix" or "invalid" when the new quick filter bar
> introduced by bug 545955 will turn the dropdown into a secondary filter
> modification bar. Which provides a convenient UI solution for the problem of
> this bug.

That won't provide accelerators AFAIK.
Comment 4 User image Thomas D. (currently busy elsewhere; needinfo?me) 2010-06-15 02:51:32 PDT
(In reply to comment #3)
> That [secondary filter modification bar] won't provide accelerators AFAIK.

In fact, it's worse: Secondary filter modification bar is NOT keyboard-accessible at all (not even with tab and cursors). Which is a bad regression which should get its own bug. Keyboard folks including disabled have no way of modifying the filter criteria like subject, sender, recipient, body or tags.

Thx Ludo for correcting my comment 2 and pointing this out.
Comment 5 User image Thomas D. (currently busy elsewhere; needinfo?me) 2010-06-21 09:48:03 PDT
I posted followup with more specific and actionable suggestions based on the new quickfilter bar UI:

Bug 573496 - secondary quickfilter modification bar: Implement tab stop and/or keyboard accelerators for filter buttons (sender, recipients, subject, body currently inaccessible)

This bug here was based on old quickfilter dropdown UI and is somewhat vague when it comes to solutions. We might still want to keep this open as a more general bug for discussing respective ideas, there are some in comment 0 that are not covered in my followup bug (like search keywords a la google, e.g. [from:peter subject:holiday] - do we have a bug for that?).
Comment 6 User image Wayne Mery (:wsmwk, NI for questions) 2011-04-12 23:15:44 PDT
bug 538821 appears to cover most if not all of what remains.

*** This bug has been marked as a duplicate of bug 538821 ***

Note You need to log in before you can comment on or make changes to this bug.