When in Offline mode Reply To buttons either do not appear or do not work

VERIFIED FIXED in Thunderbird 3.1b1

Status

defect
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: david, Assigned: Bienvenu)

Tracking

unspecified
Thunderbird 3.1b1
x86
macOS

Thunderbird Tracking Flags

(thunderbird3.0 .2-fixed)

Details

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

When working in Offline mode Reply To buttons either do not work or do not appear. The only way to send a message is to right click on it and select reply to from the context menu that appears.

Reproducible: Always

Steps to Reproduce:
1. Go into Offline Mode
2. Select a message
3. Look at either the menu bar above the message, the "reply to" button is not there.
3b. if you have chose to display the "reply to" in the general menu bar it is grayed out. 
Actual Results:  
Could not select "reply to"

Expected Results:  
Should be able to respond to messages when offline and then be able to "send later" after composing.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This WFM on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1. Humph, what version were you using when you confirmed ?  Could this be 10.6 only ?
(Assignee)

Comment 3

9 years ago
It looks to me like reply is disabled on junk messages.
(Reporter)

Comment 4

9 years ago
The screen shot is of junk mail as I didn't want to show personal email. The same thing occurs with all mail I have.
(Assignee)

Comment 5

9 years ago
weird, it only happened to me with junk mail.
> confirmed ?  Could this be 10.6 only ?

I saw it in 10.6.2, yes.  So perhaps it's version specific, not sure.  Untested elsewhere.
CONFIRMED on OSX 10.6.2 with Tb 3.0.1, buttons disappear in non-JUNK folders too, and come right back as soon as I go back online. This is with IMAP hitting Exchange 2003. I have "Keep messages for this account on this computer" turned OFF in Account Setup if that makes a difference.
(Assignee)

Comment 8

9 years ago
reply is disabled if we don't have the contents of the message stored offline - do you have the messages store for offline use?
I can fully see the message as well as the TO/FROM fields, but REPLY button is gone.

All of the TO/FROM information shows up just fine. I do NOT have the Account Option "Keep messages for this account on this computer" turned on though, though I did click the "Download" when I switched to "Offline" mode.
(Reporter)

Comment 10

9 years ago
I tried checking "Keep messages for this account on this computer" and it didn't change anything. Reply buttons still do not appear.
Flags: blocking-thunderbird3.1?
(Assignee)

Comment 11

9 years ago
I did run into an instance of this - if you're in a saved search/smart folder, and the message is in a local folder, when offline, reply won't be enabled. I need to add a mozmill test for this.
Assignee: nobody → bienvenu
(Assignee)

Comment 12

9 years ago
sid0, thoughts about where to add this? I could add it to the test-smart-folder test (though it's really about cross-folder virtual folders in general); I could add it to test-message-commands, but then I'd need to make that test use smart folders (which I probably should do in general because we have a lot of smart folder-specific command handling issues). Or I could add a new test, e.g., test-smart-folder-commands.js
test-smart-folder-commands.js sounds good. In general I think it's a good idea to have lots of smaller test files, because they're generally easier to debug.
(Assignee)

Comment 14

9 years ago
Comment on attachment 423557 [details] [diff] [review]
fix for local mail in smart folders/saved search

I wasted most of the day writing a mozmill test for this only to discover that mozmill doesn't work if the ioservice is offline.
Attachment #423557 - Flags: superreview?(neil)
Attachment #423557 - Flags: review?(neil)
That kinda sounds like a bug in MozMill to me.  Clint, are you aware of this and/or any sort of fix/workaround on the horizon?
(Assignee)

Comment 16

9 years ago
I've already e-mailed Clint privately to ask about this.
(Assignee)

Comment 17

9 years ago
this is a simplified version of the test that doesn't work because offline is turned on.
Attachment #423557 - Flags: superreview?(neil)
Attachment #423557 - Flags: superreview+
Attachment #423557 - Flags: review?(neil)
Attachment #423557 - Flags: review+
(Assignee)

Comment 18

9 years ago
fixed on trunk.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Comment 19

9 years ago
Comment on attachment 423557 [details] [diff] [review]
fix for local mail in smart folders/saved search

nice simple fix for 3.02
Attachment #423557 - Flags: approval-thunderbird3.0.2?
Attachment #423557 - Flags: approval-thunderbird3.0.2? → approval-thunderbird3.0.2+
(Assignee)

Comment 20

9 years ago
fixed for 3.02 as well.
Target Milestone: --- → Thunderbird 3.1b1
Status: RESOLVED → VERIFIED
Flags: blocking-thunderbird3.1?
(Reporter)

Comment 21

9 years ago
Just wanted to say thank you to everyone who worked on this bug. Great learning process for me.
You need to log in before you can comment on or make changes to this bug.