If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

firefox doesnt quit when executing the quit application command from menu bar. can only execute a force quit through mac os

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
8 years ago
5 years ago

People

(Reporter: meinipod, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-1-30])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10_5_8; de-de) AppleWebKit/531.9 (KHTML, like Gecko) Version/4.0.3 Safari/531.9
Build Identifier: http://www.mozilla.com/en-US/products/download.html?product=firefox-3.5.7&os=osx&lang=de

maybe this can help to fix a problem that occurres after i installed the better privacy plug in. since then firefox will not close down when i execute the quit firefox command. in the mac os x application dock it will still show as active after closing all browser windows. only a force quit will shut down the application

Reproducible: Always

Steps to Reproduce:
1.install better privacy plugin and use browser
2.quit
3.confirm to delete all files with better privacy
4.application still active in dock although windows closed
5.open force quit manager with apple alt esc
6.force quit firefox
7.application closed

Comment 1

8 years ago
Having same problem - browser not quitting after deleting LSO cookies using Better Privacy
(Reporter)

Comment 2

8 years ago
the current update for better privacy seems to fix the problem....
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You can also try to reproduce in Firefox 4 Beta 8 or later, there are many improvements in the new version, http://www.mozilla.com/en-US/firefox/all-beta.html
Whiteboard: [CLOSEME 2011-1-30]
(Reporter)

Comment 4

7 years ago
since the mentioned update for better privacy the problem didnt occur again
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Resolution: FIXED → INVALID

Updated

5 years ago
Blocks: 800458
You need to log in before you can comment on or make changes to this bug.