Last Comment Bug 539133 - remove broken Opera profile migrator
: remove broken Opera profile migrator
Status: RESOLVED FIXED
[inbound]
:
Product: Firefox
Classification: Client Software
Component: Migration (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 11
Assigned To: Makoto Kato [:m_kato]
:
Mentors:
Depends on:
Blocks: 707601
  Show dependency treegraph
 
Reported: 2010-01-11 17:43 PST by Dietrich Ayala (:dietrich)
Modified: 2011-12-19 10:20 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (2.96 KB, patch)
2011-11-30 21:35 PST, Makoto Kato [:m_kato]
no flags Details | Diff | Splinter Review
fix (63.86 KB, patch)
2011-12-04 21:45 PST, Makoto Kato [:m_kato]
gavin.sharp: review+
Details | Diff | Splinter Review

Description Dietrich Ayala (:dietrich) 2010-01-11 17:43:50 PST
From File/Import, the only option available is "cookies".

When importing on "first run", the wizard shows the homepage import option, but only shows a single choice: the Firefox default homepage. Then the next page says migration complete, and the summary shows only cookies as being imported.
Comment 1 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2011-11-30 04:02:25 PST
By code inspection, the Opera profile migrator hard-codes Opera 6-specific file names. Chances are that Opera has renamed the files since then.
Comment 2 Makoto Kato [:m_kato] 2011-11-30 21:35:14 PST
Created attachment 578176 [details] [diff] [review]
fix
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-12-02 09:49:26 PST
Does this fix all of the issues on all platforms? I'm pretty tempted to just remove the Opera profile migrator, at least until we can rewrite it in JS and properly test it fully.
Comment 4 Makoto Kato [:m_kato] 2011-12-04 18:19:26 PST
(In reply to Gavin Sharp (use gavin@gavinsharp.com for email) from comment #3)
> Does this fix all of the issues on all platforms? I'm pretty tempted to just
> remove the Opera profile migrator, at least until we can rewrite it in JS
> and properly test it fully.

Yes.  Opera 11 uses same filename on all platform (Windows/MacOSX/Linux).  Current code seems to be for Opera 6 per comment #1.

Also, I agree that we remove opera migration until rewriting new JS based code.  (although we need ini parser for js components...)

Gavin, should I remove this migration?
Comment 5 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-12-04 18:59:19 PST
Yeah, let's just kill it, and file a followup to re-implement if needed.
Comment 6 Makoto Kato [:m_kato] 2011-12-04 21:45:31 PST
Created attachment 578981 [details] [diff] [review]
fix

kill opera migrator.
Comment 7 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-12-05 06:08:19 PST
(In reply to Makoto Kato from comment #4)
> (although we need ini parser for js components...)

What's wrong with nsIINIParser?
Comment 8 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-12-09 13:19:16 PST
Comment on attachment 578981 [details] [diff] [review]
fix

A couple of things you forgot to remove:
- NS_OPERAPROFILEMIGRATOR_CID #define in nsBrowserCompsCID.h, and a reference to it in nsModule.cpp
- importFromOpera strings in migration.dtd

r=me with those addressed, thanks!
Comment 10 Ed Morley [:emorley] 2011-12-16 05:56:51 PST
https://hg.mozilla.org/mozilla-central/rev/39f25929ceea

Note You need to log in before you can comment on or make changes to this bug.