bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

xforms.xpi not built any more

RESOLVED FIXED

Status

Core Graveyard
XForms
RESOLVED FIXED
9 years ago
2 years ago

People

(Reporter: imphil, Assigned: imphil)

Tracking

({regression})

1.9.2 Branch
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

9 years ago
The obj/dist/xpi-stage/xforms.xpi is not built any more since Gecko 1.9.2. Fix this or find another solution to get a XPI for release.

Updated

9 years ago
Blocks: 539184

Comment 1

9 years ago
It's worth to notice 

1) DOMi extension has an xpi
2) XForms is installed into chrome and components directory instead of extensions directory
(Assignee)

Comment 2

9 years ago
Created attachment 421317 [details] [diff] [review]
xforms patch

This has been caused by bug #451909. The attached patch fixes this and, while at it, removes the MINIMO defines from the Makefiles, as minimo is not developed any more.
Assignee: nobody → mail
Status: NEW → ASSIGNED
Attachment #421317 - Flags: review?(surkov.alexander)
(Assignee)

Comment 3

9 years ago
Created attachment 421318 [details] [diff] [review]
schema-validation patch (cleanup)
(Assignee)

Updated

9 years ago
Attachment #421318 - Flags: review?(surkov.alexander)

Updated

9 years ago
Attachment #421317 - Flags: review?(surkov.alexander)
Attachment #421317 - Flags: review?(aaronr)
Attachment #421317 - Flags: review+

Updated

9 years ago
Attachment #421318 - Flags: review?(surkov.alexander)
Attachment #421318 - Flags: review?(aaronr)
Attachment #421318 - Flags: review+

Updated

9 years ago
Attachment #421317 - Flags: review?(aaronr) → review+

Updated

9 years ago
Attachment #421318 - Flags: review?(aaronr) → review+

Updated

9 years ago
Blocks: 451909
Keywords: regression

Updated

9 years ago
OS: Linux → All
Hardware: x86 → All

Comment 4

9 years ago
landed http://hg.mozilla.org/xforms/rev/793dd7705b2d, http://hg.mozilla.org/schema-validation/rev/fc72c38dc393
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.