[meta] ship xforms extension for Firefox 3.6 (Gecko 1.9.2)

RESOLVED FIXED

Status

Core Graveyard
XForms
RESOLVED FIXED
9 years ago
2 years ago

People

(Reporter: surkov, Unassigned)

Tracking

({meta})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments, 1 obsolete attachment)

(Reporter)

Description

9 years ago
We need to build xforms extension for Firefox 3.7 (Gecko 1.9.2) which is targeted to Q1 and put an extension to admo. I hope Aaron will help to do this.

I think the primary goal of the new version should be getting an xforms extension working on 1.9.2. However this doesn't mean all regressions must be fixed, but any of them which can be fixed in Q1 timeframe should be fixed. In this light I suggest to bump the version number from 0.8.7pre to 0.8.7.

Please comment any bugs you think should be fixed and shipped within new version.

Comment 1

9 years ago
Philipp is doing all of the hard work (the builds).  Putting out a build isn't much more than updating the status page and pushing the builds to addons, which I can certainly help with.

Last I heard XForms wasn't building on Mac, though.  Is that true?  I don't know that we should put out a build until that is fixed.
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> Philipp is doing all of the hard work (the builds).  Putting out a build isn't
> much more than updating the status page and pushing the builds to addons, which
> I can certainly help with.

That's great. Thanks.

> Last I heard XForms wasn't building on Mac, though.  Is that true?  I don't
> know that we should put out a build until that is fixed.

This make sense I think.
(Reporter)

Updated

9 years ago
Depends on: 539275
(In reply to comment #1)
> Last I heard XForms wasn't building on Mac, though.  Is that true?  I don't
> know that we should put out a build until that is fixed.

I haven't heard that yet. But I cannot check either as I have no Mac hardware around.
The target for this release should be Firefox 3.6, not 3.7 btw (I guess developers always think one more release into the future) ;)
Summary: [meta] ship xforms extension for Firefox 3.7 (Gecko 1.9.2) → [meta] ship xforms extension for Firefox 3.6 (Gecko 1.9.2)
(Reporter)

Comment 5

9 years ago
(In reply to comment #4)
> The target for this release should be Firefox 3.6, not 3.7 btw (I guess
> developers always think one more release into the future) ;)

Yeah, you're right. 3.6 is something in the past for me :) Thank you for fixing this.
(Reporter)

Updated

9 years ago
Depends on: 539533
(Reporter)

Updated

9 years ago
Depends on: 539525
(Reporter)

Comment 6

8 years ago
I would like to get your opinion whether we should ship xforms extension right now and do not wait other bugs marked blocking. It sounds fixing these bugs might take long time so it's probably worth to drop them from release expectation list. What do you think?

Comment 7

8 years ago
Peter, could you look at the 469717? Is it XForms bug? This bug blocks new XForms release...
(In reply to comment #6)
> I would like to get your opinion whether we should ship xforms extension right
> now and do not wait other bugs marked blocking. It sounds fixing these bugs
> might take long time so it's probably worth to drop them from release
> expectation list. What do you think?

I have close to no time at the moment, I'd say ship it now as-is, which gives us at least a first release for Firefox 3.6 and do a follow-up release as soon as some of us have more time to get some of the most annoying bugs fixed (I hope by the end of April).

Comment 9

8 years ago
This is list of bugs that fixed after 2008-10-07.
Is it right list? :
487310, 488330, 556318, 384950, 399567, 466712, 467815, 494337, 494848, 497237, 326413, 455772, 478105, 485734, 490983, 501987, 506915, 515067, 526376, 539275, 
539525, 436866, 521246, 525730, 525735, 530488, 531297, 537881, 539533

Comment 10

8 years ago
I want you this list for changeset for XForms release 0.8.7ff36.

Comment 11

8 years ago
Do exist another patches (that put into repo) that not in this list but make XForms more suitable?

Comment 12

8 years ago
Created attachment 437277 [details] [diff] [review]
patch for version

Patch that changes version of XForms.
Attachment #437277 - Flags: review?(aaronr)

Updated

8 years ago
Attachment #437277 - Attachment is patch: true
Attachment #437277 - Attachment mime type: application/octet-stream → text/plain
Comment on attachment 437277 [details] [diff] [review]
patch for version

>diff --git a/version.txt b/version.txt
>--- a/version.txt
>+++ b/version.txt
>@@ -1,1 +1,1 @@
>-0.8.7pre
>+0.8.8ff363

version 0.8.7 was never released, so I'd suggest using this version. There is no need to append ff363 as we support only this Firefox version with this release.

Comment 14

8 years ago
Created attachment 437282 [details] [diff] [review]
patch for version
Attachment #437277 - Attachment is obsolete: true
Attachment #437282 - Flags: review?(aaronr)
Attachment #437277 - Flags: review?(aaronr)

Updated

8 years ago
Attachment #437282 - Flags: review?(aaronr) → review+

Comment 15

8 years ago
At some point before we release we should make sure that xforms installs just fine with Seamonkey, too.

Comment 16

8 years ago
I couldn't compile it for Seamonkey.
It breaks with error:
> e. .t/o. .b/odoils t'/tirnucel'u doer/ c'ofnatlesnet'\ >n(spIePrrfiovramtaenDcOeM Ewvaernnti.nhg()6
>4) : see declaration of 'nsIPrivateDOMEvent::SetCurrentTarget'
>        'nsresult nsIPrivateDOMEvent::SetOriginalTarget(nsIDOMEventTarget *)' >: is abstract
>        ../../dist/include/content\nsIPrivateDOMEvent.h(65) : see declaration >of 'nsIPrivateDOMEvent::SetOriginalTarget'
>
>        'PRBool nsIPrivateDOMEvent::HasOriginalTarget(void)' : is abstract
>        ../../dist/include/content\nsIPrivateDOMEvent.h(68) : see declaration >of 'nsIPrivateDOMEvent::HasOriginalTarget'
>
>nsXFormsOutputElement.cpp
>make[6]: *** [nsXFormsUtils.obj] Error 2

But I made xpi for Firefox 3.6.3 win32. Also I can make this for Linux.

Comment 17

8 years ago
Created attachment 437883 [details]
xpi for Firefox 3.6.3 on win32

Comment 18

8 years ago
(In reply to comment #16)
> I couldn't compile it for Seamonkey.
> It breaks with error:
> > e. .t/o. .b/odoils t'/tirnucel'u doer/ c'ofnatlesnet'\ >n(spIePrrfiovramtaenDcOeM Ewvaernnti.nhg()6
> >4) : see declaration of 'nsIPrivateDOMEvent::SetCurrentTarget'
> >        'nsresult nsIPrivateDOMEvent::SetOriginalTarget(nsIDOMEventTarget *)' >: is abstract
> >        ../../dist/include/content\nsIPrivateDOMEvent.h(65) : see declaration >of 'nsIPrivateDOMEvent::SetOriginalTarget'
> >
> >        'PRBool nsIPrivateDOMEvent::HasOriginalTarget(void)' : is abstract
> >        ../../dist/include/content\nsIPrivateDOMEvent.h(68) : see declaration >of 'nsIPrivateDOMEvent::HasOriginalTarget'
> >
> >nsXFormsOutputElement.cpp
> >make[6]: *** [nsXFormsUtils.obj] Error 2
> 
> But I made xpi for Firefox 3.6.3 win32. Also I can make this for Linux.

With which version of seamonkey you built XForms? Stable version of seamonkey is based on Gecko 1.9.1.

Comment 19

8 years ago
The current verion of xforms is for gecko 1.9.2. Seamonkey 2.1 is based on trunk as I figured out and there is no seamonkey with gecko 1.9.2. My propose is try to support next version of seamonkey in future releases of xforms.
(Reporter)

Updated

8 years ago
Attachment #437282 - Flags: review+
(Reporter)

Comment 20

8 years ago
bump version patch landed - http://hg.mozilla.org/xforms/rev/f21111260427
(Reporter)

Comment 21

8 years ago
So I'd suggest to wait for bug 457075 and ship the extension, move all blocking bugs to next version. Are we all on the same page?

Comment 22

8 years ago
Alex, can you check in the fix for bug 469717 before it ships?  Nice to have another crasher fixed.
(Reporter)

Comment 23

8 years ago
(In reply to comment #22)
> Alex, can you check in the fix for bug 469717 before it ships?  Nice to have
> another crasher fixed.

I could but bug 469717 patch is Gecko's patch and it doesn't affect on XForms release until it's landed on 1.9.2.x and proper Firefox version is shipped.
(Reporter)

Comment 24

8 years ago
(In reply to comment #21)
> So I'd suggest to wait for bug 457075 and ship the extension, move all blocking
> bugs to next version. Are we all on the same page?

I landed bug 457075. So, let's start shipping? Any objections?

Comment 25

8 years ago
ok with me
(Reporter)

Comment 26

8 years ago
Do we want to ship next xforms version for Firefox 3.6.x or Firefox 3.7? I wonder to know wether we need to deal with hg branches or we can just focus on trunk development?

Comment 27

8 years ago
I think that it's time to ship XForms for Firefox 3.6.x.

Comment 28

8 years ago
since we don't depend on any browser patches (except for the delete & send crash) I don't see a reason not to put this out for 3.6 first
(Reporter)

Comment 29

8 years ago
(In reply to comment #28)
> since we don't depend on any browser patches (except for the delete & send
> crash) I don't see a reason not to put this out for 3.6 first

Sure. Is next xforms version expected for Firefox 3.7 (or later)?

Comment 30

8 years ago
It can be whenever we need it to be if we've got patches that need to get out to people.  I haven't been following Firefox for a while, any changes expected in 3.7 such that the 3.6 xforms extension wouldn't work on it?

Comment 31

8 years ago
Last XForms doesn't compile on trunk FF.
(Reporter)

Comment 32

8 years ago
(In reply to comment #30)
> It can be whenever we need it to be if we've got patches that need to get out
> to people.  I haven't been following Firefox for a while, any changes expected
> in 3.7 such that the 3.6 xforms extension wouldn't work on it?

Current xforms version isn't compiled for Firefox 3.7. So if we're sure we want to keep an ability to ship xforms for 3.6 while the primary work happens on Firefox 3.7 then we need to try to get hg branches working or have separate hg repo for 3.6. Any way we should care about patches for two xforms versions which can't make happy anybody. On the other hand we could stay on Firefox 3.6 and don't try to get xforms working on 3.7 until it's shipped.

Comment 33

8 years ago
I'd say we don't branch and just support 3.6 until 3.7 reaches beta.  Then it'd be worth getting us compiling for 3.7 so that we are ready as quickly as we can after 3.7 goes out.  It might be worth branching if compiling for 3.7 looks to be a huge issue (involving multiple patches) or if we encounter a bug that will require a change in the base so that we can test and make sure the issue is resolved.  But if it looks like routine maintenance, I'd think we could just keep things on the trunk like we always did.
(Reporter)

Comment 34

8 years ago
Ok, fine with me.

Aaron, do you need a help to make xforms.xpi so that all you need is to publish them on amo?

Personally I could do a mac version.

Comment 35

8 years ago
If you can do that mac version and send it to me and if philipp can do the windows and linux versions (which he already does, right?) and send them to me, then I'll get them posted and update the documentation.
(Reporter)

Comment 36

8 years ago
Great. Probably philipp should rebuild because bug 457075 was landed. Also I think it's worth to set hg tag.
(Reporter)

Comment 37

8 years ago
(In reply to comment #36)
>  Also I
> think it's worth to set hg tag.

Is XFORMS_0_8_7_GECKO_1_9_2 ok as a tag name (both for xforms and schema-validation repos)?
fine with me. I'll do a manual rebuild (linux and windows) from the tag as soon as it's set.
(Reporter)

Comment 39

8 years ago
(In reply to comment #38)
> fine with me. I'll do a manual rebuild (linux and windows) from the tag as soon
> as it's set.

done:
http://hg.mozilla.org/xforms/rev/90618060e59f
http://hg.mozilla.org/schema-validation/rev/a4bc587332b5
(Reporter)

Comment 40

8 years ago
Could we consider to include crash fix from bug 556492 into release? It sounds very important.
let's include it. I need to redo the builds anyway as they're crashing for some reason.

Comment 42

8 years ago
I guess the bug is important and it's neccessary to include it into release.
(Reporter)

Comment 43

8 years ago
Bug 556492 was landed. Tag was added XFORMS_0_8_7_GECKO_1_9_2_3 - http://hg.mozilla.org/xforms/rev/f51a343e8228
(Reporter)

Comment 44

8 years ago
Created attachment 442294 [details]
os x xpi
Depends on: 563190

Comment 45

8 years ago
I guess bug 563190 is Gecko problem and it is not a reason to delay releasing XForms 0.8.7.

Comment 46

8 years ago
Does anybody have informatin about 0.8.7 shipping?

Comment 47

8 years ago
(In reply to comment #46)
> Does anybody have informatin about 0.8.7 shipping?

It has been submitted to addons.  Waiting for it to be approved.

Comment 48

8 years ago
(In reply to comment #47)
> (In reply to comment #46)
> > Does anybody have informatin about 0.8.7 shipping?
> 
> It has been submitted to addons.  Waiting for it to be approved.

I've found it

https://addons.mozilla.org/ru/firefox/addons/versions/824#version-0.8.7

Comment 49

8 years ago
(In reply to comment #9)
> This is list of bugs that fixed after 2008-10-07.
> Is it right list? :
> 487310, 488330, 556318, 384950, 399567, 466712, 467815, 494337, 494848, 497237,
> 326413, 455772, 478105, 485734, 490983, 501987, 506915, 515067, 526376, 539275, 
> 539525, 436866, 521246, 525730, 525735, 530488, 531297, 537881, 539533

+  457075, 556492, 556318
(Reporter)

Comment 50

8 years ago
Move bugs blocking 532963 563190 to next release (bug 567310). Since the extension is on amo expecting a review I think we can mark this bug fixed. Nothing is left to be done. Please reopen if you have objections.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
No longer depends on: 532963, 563190
Resolution: --- → FIXED

Comment 51

8 years ago
(In reply to comment #49)
> (In reply to comment #9)
> > This is list of bugs that fixed after 2008-10-07.
> > Is it right list? :
> > 487310, 488330, 556318, 384950, 399567, 466712, 467815, 494337, 494848, 497237,
> > 326413, 455772, 478105, 485734, 490983, 501987, 506915, 515067, 526376, 539275, 
> > 539525, 436866, 521246, 525730, 525735, 530488, 531297, 537881, 539533
> 
> +  457075, 556492, 556318

I'm also including 372127, 391926, 392645, 337428, 366886 in the list of bugs in the announcement since these bugs are no longer re-creatable since 0.8.6 went out (probably due to core changes in 3.5+).

Comment 52

8 years ago
XForms 0.8.7 has been approved in amo.

Comment 53

8 years ago
Is it possible to add release notes into page http://www.mozilla.org/projects/xforms/? 

Aaron could you do this?

Comment 54

8 years ago
Created attachment 449885 [details] [diff] [review]
documentation update

Here is a patch to update the documentation with.  I had cvs access to do it before but now that mozilla.org has switched to svn access I'm re-requesting permission to do documentation checkins using svn.  I'll check this in once I get access.

Alexey, please look at the patch and let me know if you had any other changes in mind.

Comment 55

8 years ago
I have no ideas about other changes of patch to update the documentation.

Comment 56

8 years ago
Created attachment 456652 [details] [diff] [review]
status detail xml patch
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.