Last Comment Bug 539282 - Blocklist the viewpoint plugin
: Blocklist the viewpoint plugin
Status: RESOLVED FIXED
[crashkill][crashkill-outreach] [cras...
:
Product: Toolkit
Classification: Components
Component: Blocklisting (show other bugs)
: unspecified
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Michael Morgan [:morgamic]
:
: Jorge Villalobos [:jorgev]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-12 11:46 PST by Robert Strong [:rstrong] (use needinfo to contact me)
Modified: 2016-03-07 15:30 PST (History)
15 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
?


Attachments

Description Robert Strong [:rstrong] (use needinfo to contact me) 2010-01-12 11:46:57 PST
Some of the work / investigation can be found in bug 501429.

plugin file name: npViewpoint.dll
plugin file version: 3.6.0.59

Should probably blocklist all version prior to and including 3.6.0.59.

The viewpoint website explicitly states the plugin only works with Firefox 2.0 and I have verified this.
http://www.viewpoint.com/technologies/viewpoint-media-player.shtml
Comment 1 Michael Morgan [:morgamic] 2010-01-12 11:48:19 PST
For which versions of Firefox?  Or just blocklist all versions of this just based on the extension version?
Comment 2 Robert Strong [:rstrong] (use needinfo to contact me) 2010-01-12 11:54:15 PST
(In reply to comment #1)
> For which versions of Firefox?  Or just blocklist all versions of this just
> based on the extension version?

(In reply to comment #0)
>...
> The viewpoint website explicitly states the plugin only works with Firefox 2.0
> and I have verified this.
> http://www.viewpoint.com/technologies/viewpoint-media-player.shtml

Firefox 3.0 and above... it works with Firefox 2.0
Comment 3 Robert Strong [:rstrong] (use needinfo to contact me) 2010-01-12 21:16:59 PST
I just noticed that PFS offers this plugin as well... it should prbably be removed.

btw: the Firefox 2.0 blocklist doesn't support plugins anyways so Firefox version shouldn't matter
Comment 4 Marcia Knous [:marcia - use ni] 2010-01-26 12:59:45 PST
http://tinyurl.com/yemo2r7 lists about 968 crashes. Would be good to get this assigned to someone since those that have the viewpoint plugin and use the plug in check page are crashing when they try to update.
Comment 5 Henrik Skupin (:whimboo) 2010-01-27 17:16:19 PST
Morgamic, can you help with blocklisting this plugin?
Comment 6 Michael Morgan [:morgamic] 2010-01-28 16:42:20 PST
SQL:

INSERT INTO blplugins (`guid`, `min`, `max`, `filename`) VALUES ('{ec8030f7-c20a-464f-9b0e-13a3a9e97384}', '3.0', '*', 'npViewpoint.dll')

XML:
  <pluginItem>
    <match name="filename" exp="npViewpoint.dll"/>
    <versionRange>
      <targetApplication id="{ec8030f7-c20a-464f-9b0e-13a3a9e97384}">
        <versionRange minVersion="3.0" maxVersion="*"/>
      </targetApplication>
    </versionRange>
  </pluginItem>

Filing an IT bug to get it pushed.
Comment 7 Michael Morgan [:morgamic] 2010-01-28 16:42:54 PST
I'd note that only fx 3.0+ supports plugin blocklisting so the version range for the targetApplication is pretty irrelevant in this case.  Adding it anyway though.
Comment 8 Michael Morgan [:morgamic] 2010-01-28 16:48:23 PST
Can someone tell me where the version string is stored in the plugin metadata?  Is it in the plugin name or the plugin description in about:plugins?
Comment 9 Michael Morgan [:morgamic] 2010-01-28 16:48:42 PST
Want to verify the version before we block it so I don't block anything but 3.6.0.59...
Comment 10 Robert Strong [:rstrong] (use needinfo to contact me) 2010-01-28 17:47:42 PST
I don't know for if there are other versions of the plugin out there but ideally 3.6.0.59 and below would be blocklisted. I'll reinstall the plugin and get back to you with whether it is in the name or description. btw: this is Windows only as well though it won't hurt anything if it applies to all os's.
Comment 11 Michael Morgan [:morgamic] 2010-01-28 18:30:37 PST
Yeah we're good to go then.  We can always update later if we have to. Filed IT bug.
Comment 12 chris hofmann 2010-01-28 19:32:59 PST
(In reply to comment #10)
> I don't know for if there are other versions of the plugin out there...

dbaron's module correlation reports show these version numbers for the .dll out there.  they all look older than 3.6.0.59 and I'm guessing those are incompat too.

      8% (12/151) vs.   0% (61/114064) npViewpoint.dll
          5% (8/151) vs.   0% (28/114064) 3.6.0.59
          2% (3/151) vs.   0% (16/114064) 3.5.0.36
          1% (1/151) vs.   0% (11/114064) 3.2.2.26
          0% (0/151) vs.   0% (2/114064)  3.0.15.12
          0% (0/151) vs.   0% (1/114064)  3.0.12.9
          0% (0/151) vs.   0% (3/114064)  3.0.11.13
Comment 13 Mike Connor [:mconnor] 2010-02-01 06:41:39 PST
There's been a number of questions about this (IRC and https://support.mozilla.com/en-US/forum/1/571763).   Can we get the "More Info" page updated with details as to the reason this is blocked?  Something like:

"This plugin is explicitly not supported by Firefox 3 and above by the vendor (Viewpoint) and has been found to cause crashes in Firefox due to this incompatibility.  For more information, please see http://www.viewpoint.com/technologies/viewpoint-media-player.shtml."
Comment 14 Stephen Donner [:stephend] 2010-02-01 17:51:13 PST
Are we going to update http://www.mozilla.com/en-US/blocklist/ to reflect this, too?
Comment 15 Michael Morgan [:morgamic] 2010-02-01 17:53:50 PST
Yeah, will do that this evening.
Comment 16 Matthias Versen [:Matti] 2010-02-01 18:14:23 PST
Can you please add the plugin to the Seamonbkey blocklist or should I file a new bug ?
Comment 17 Marcia Knous [:marcia - use ni] 2010-02-02 11:05:04 PST
morgamic: Is there any reason that on Windows Vista the plugin is not being blocklisted? I have a machine in the lab where the plugin is not being pluglisted after I installed it yesterday.
Comment 18 Robert Strong [:rstrong] (use needinfo to contact me) 2010-02-02 12:07:42 PST
This wfm with Windows 7. You probably haven't downloaded the updated blocklist file to your profile yet.
Comment 19 Robert Strong [:rstrong] (use needinfo to contact me) 2010-02-03 19:40:06 PST
Marcia, is it still not blocked and if so, have you opened the blocklist.xml in the profile and searched for viewpoint to see if it is there?
Comment 20 Marcia Knous [:marcia - use ni] 2010-02-04 11:25:14 PST
On the Windows Vista machine I ended up having to go into about:config and change the interval timing. Once I did that the extension was finally blocklisted.
Comment 21 david.b.cunningham 2012-07-19 10:43:09 PDT
So, how will I be able to read Kindle documents, if I need this plugin to do so? Is there another alternative?
Comment 22 devan hammonds 2013-01-12 04:47:18 PST
(In reply to Michael Morgan [:morgamic] from comment #6)
> SQL:
> 
> INSERT INTO blplugins (`guid`, `min`, `max`, `filename`) VALUES
> ('{ec8030f7-c20a-464f-9b0e-13a3a9e97384}', '3.0', '*', 'npViewpoint.dll')
> 
> XML:
>   <pluginItem>
>     <match name="filename" exp="npViewpoint.dll"/>
>     <versionRange>
>       <targetApplication id="{ec8030f7-c20a-464f-9b0e-13a3a9e97384}">
>         <versionRange minVersion="3.0" maxVersion="*"/>
>       </targetApplication>
>     </versionRange>
>   </pluginItem>
> 
> Filing an IT bug to get it pushed.

Note You need to log in before you can comment on or make changes to this bug.