Closed Bug 53932 Opened 20 years ago Closed 11 years ago

nsComponentManagerImpl leaks nsComponentManagerLog

Categories

(Core :: XPCOM, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: jonsmirl, Unassigned)

Details

(Keywords: memory-leak)

The nsComponentManagerLog variable is never deleted.
Setting Jon Smirl's bugs to New
Status: UNCONFIRMED → NEW
Ever confirmed: true
Transferring to default XPCOM owner.
Assignee: rayw → warren
I'm adopting all of warren's leaks.
Assignee: warren → dprice
-> cathleen for a new home
Assignee: dprice → asa
Component: XPCOM → Browser-General
QA Contact: rayw → doronr
Blocks: 92580
-> cathleen
Assignee: asa → cathleen
No longer blocks: 92580
I will take this.
Assignee: cathleen → dp
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
->dougt
Moving Netscape owned 0.9.9 and 1.0 bugs that don't have an nsbeta1, nsbeta1+,
topembed, topembed+, Mozilla0.9.9+ or Mozilla1.0+ keyword.  Please send any
questions or feedback about this to adt@netscape.com.  You can search for
"Moving bugs not scheduled for a project" to quickly delete this bugmail.
Target Milestone: mozilla1.0 → mozilla1.2
Product: Browser → Seamonkey
Assignee: dp → general
Status: ASSIGNED → NEW
Priority: P3 → --
QA Contact: doronr → general
Target Milestone: mozilla1.2alpha → ---
<http://mxr.mozilla.org/mozilla-central/search?string=nsComponentManagerLog&case=on&filter=%5E%5B%5E%5C0%5D*%24&tree=mozilla-central>
{{
/xpcom/obsolete/component/nsRegistry.cpp
    * line 75 -- extern NS_COM PRLogModuleInfo *nsComponentManagerLog;

/xpcom/components/nsComponentManager.cpp
    * line 99 -- NS_COM PRLogModuleInfo* nsComponentManagerLog = nsnull;
    * line 614 -- if (nsComponentManagerLog == nsnull)
    * line 616 -- nsComponentManagerLog = PR_NewLogModule("nsComponentManager");
}}
Assignee: general → nobody
Component: General → XPCOM
Product: Mozilla Application Suite → Core
QA Contact: general → xpcom
<http://mxr.mozilla.org/mozilla-central/source/nsprpub/pr/include/prlog.h#229>
<http://mxr.mozilla.org/mozilla-central/source/nsprpub/pr/src/io/prlog.c#366>
<http://mxr.mozilla.org/mozilla-central/source/nsprpub/pr/include/prmem.h#131>

As far as I can tell, |PR_NewLogModule()| is used in the same way everywhere,
and the returned |PRLogModuleInfo| variable is (never) freed nowhere.

Is this XPCOM bug valid ?
Is it (rather) a global NSPR issue ?
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
benjamin, why WontFix?
We leak PRlogs by design, and fixing that would be IMO too much trouble for little gain.
Summary: nsComponentManagerImpl leaks memory → nsComponentManagerImpl leaks nsComponentManagerLog
You need to log in before you can comment on or make changes to this bug.