Selected text of another / wrong message quoted after selecting text in message A, then right-click on message B > Reply

VERIFIED DUPLICATE of bug 507541

Status

VERIFIED DUPLICATE of bug 507541
9 years ago
5 years ago

People

(Reporter: jvddrift, Unassigned)

Tracking

x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; nl; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; nl; rv:1.9.1.5) Gecko/20091204 Lightning/1.0b2pre Thunderbird/3.0

When selecting text in message A and replying to message B, the selected text from message A is pasted into the reply on message B.

This only occurs when replying to to message B from the inbox.
It does not occur when message B is opened in a tab.

Reproducible: Always

Steps to Reproduce:
1. Open message A and select text
2. Close message A
3. Reply to message B from the inbox (do not open message B)
Actual Results:  
The selected text from message A are pasted into the reply

Expected Results:  
The reply should contain the complete text of the message replying to.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.0
This WFM on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1.

Can you try with launching thunderbird in -safe-mode (http://kb.mozillazine.org/Safe_mode) ?

If it still happens in -safe-mode, please details your reproduction steps a bit more  (Where does A opens ? Hwo do youd do the reply without opening etc ...)
Component: Message Compose Window → Mail Window Front End
QA Contact: message-compose → front-end
(Reporter)

Comment 2

9 years ago
Yes, this also happens in safemode
Hereby my steps

Open message A from the inbox in a tab
Select text in message A
Close (the tab of) message A (keep the text selected!)
Reply to message B WITHOUT opening message B by rightclicking on message B

The reply will show the selected text from message A

I will add some screenshots
(Reporter)

Comment 3

9 years ago
Created attachment 421784 [details]
Screenshot #1
(Reporter)

Comment 4

9 years ago
Created attachment 421785 [details]
Screenshot #2
(Reporter)

Comment 5

9 years ago
Created attachment 421787 [details]
Screenshot #3
(Reporter)

Comment 6

9 years ago
Created attachment 421788 [details]
Screenshot #4
Ok how do your sort your mailbox,  you use sort it by date and theh Group By G , right ?
(Reporter)

Comment 8

9 years ago
That is correct, date descending.

In reaction to your question, I have tested it in safemode with the inbox sorted on subject (ascending), not grouped. This has the same result
Aureliano can you test on XP/Win7 ?
I can confirm here

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.7) Gecko/20100113 Lightning/1.0b1 Shredder/3.0.2pre ID:20100113033347

but for reproduce the described behaviour is *necessary* that preview pane is off.
When I repeat the steps in comment #0, with previw pane displayed I can't reproduce the behaviour... could be a regression related to fixes of bug #521026?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 11

9 years ago
I disagree. With preview pane on, I can reproduce this bug.

It is *necessary* not to preview message B first
(In reply to comment #10)

> When I repeat the steps in comment #0, with previw pane displayed I can't
> reproduce the behaviour... could be a regression related to fixes of bug
> #521026?

Can we do a regression finding  and if the date matches than it's probably one.
(In reply to comment #11)
> I disagree. With preview pane on, I can reproduce this bug.
> 
> It is *necessary* not to preview message B first
I think this because in your release (3.0.0) bug #521026 was don't fixed. I make test with next 3.0.1pre.
(Reporter)

Comment 14

9 years ago
Hi,
I can reproduce this issue, following the steps in comment #0, in version 3.0.1

Mozilla/5.0 (Windows; U; Windows NT 6.1; nl; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1
(Reporter)

Comment 15

9 years ago
Hi,
this seems to be solved in 3.0.3
(Reporter)

Comment 16

9 years ago
(In reply to comment #15)
> Hi,
> this seems to be solved in 3.0.3

No, it's not....
TB17, winXP, I cannot reproduce JWJ's exact scenario of comment 0 using these steps:

1. Open message A in a tab and select text
2. Close message A (without deselecting text)
3. From inbox, *right-click* on msg B, pick "Reply" from context menu

Actual Results
(per my test)
full text of msg B correctly quoted
(per comment 0, but I can't reproduce)
The selected text from message A is wrongly pasted into the reply (instead of full text from msg B)

JWJ van der Drift (reporter), can you still reproduce exactly your old steps (involving tabs)?
If yes, can you provide more detailed steps?

However, it's simple to reproduce this bug in a slight variation, with much simpler STR:

1) select some text in 3 pane's msg preview of msg A
2) *right-click* on Msg B, then "Reply" from context menu

Actual result:
- selected text of Msg A wrongly quoted in reply to Msg B (and confusing mess because we actually keep the right subject of Msg B, only the quoted text is wrongly taken from Msg A).

Expected result:
- quote full text of Msg B

Morphing summary accordingly.
Flags: needinfo?(jvddrift)
Summary: Wrong quote in reply when selecting text in message → Selected text of another / wrong message quoted after selecting text in message A, then right-click on message B > Reply
For ease and speed of workflow, resolving this as duplicate of remaining problem, bug 507541 with better description.

JWJ, pls do comment here if you still see *your* issue with *your* original steps involving tabs.
If yes, we could consider
- reopening this bug
- or adding a comment in bug 507541 to cover this variant
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 507541
(Reporter)

Comment 19

5 years ago
Using TB 17.0.8, I can NOT reproduce the steps from  https://bugzilla.mozilla.org/show_bug.cgi?id=539648#c0.

I can confirm that bug https://bugzilla.mozilla.org/show_bug.cgi?id=507541 still is actual
Flags: needinfo?(jvddrift)
(In reply to JWJ van der Drift from comment #19)
> Using TB 17.0.8, I can NOT reproduce the steps from 
> https://bugzilla.mozilla.org/show_bug.cgi?id=539648#c0.
> 
> I can confirm that bug https://bugzilla.mozilla.org/show_bug.cgi?id=507541
> still is actual

JWJ, thanks for quick response, that's helpful and appreciated :)
So reporter's comment 19 verifies my analysis of comment 17 and comment 18 which resolved this duplicate of bug 507541.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.