Check user profile's "about myself" length in model

RESOLVED DUPLICATE of bug 502870

Status

P4
enhancement
RESOLVED DUPLICATE of bug 502870
9 years ago
3 years ago

People

(Reporter: the_herd_of_the_horses, Unassigned)

Tracking

Details

(Whiteboard: [z])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: 

I can update my profile without JS. The contradiction is that I can't update my add-ons properties and descriptions. Besides, in my profile, I can overcome character limit in the "about myself" section, like at https://addons.mozilla.org/en-US/firefox/user/4817791 And another contradiction is inability to edit screenshots.

This suggestion is about making a user be able to work without JavaScript. And to upload new add-ons without it, too.

JavaScript is uncomfortable because many sites use it to place advertisements at tops of pages. As Mozilla Firefox has an option of disabling it, AMO must be able to work without it, too.

Reproducible: Always

Steps to Reproduce:
1.Disable JS.
2.Log in at addons.mozilla.org
3.Try to upload anew add-on, or to edit an add-on's descriptions/properties/screenshots. It will fail.
4.Try to edit your profile. It will succeed.
Actual Results:  
When JavaScript was disabled, step 3 failed, and step 4 succeeded.

Expected Results:  
Steps 4 and 3 should both work even with JavaScript disabled.
JavaScript is required to use the Developer Tools. We require public-facing portions of the site to work without JavaScript, but we don't support non-support for developer tasks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

9 years ago
Why can profile be updated without JavaScript and addon's properties can't? What is the difference?
User profiles are part of the public facing portion of the site -- millions of users have accounts that they may need to update. Developers are a small, tech-savvy group using advanced functionality on the site. It would be too time consuming to develop and test for the extremely small portion of users who choose to disable JavaScript.

Fortunately, there's a workaround for this bug: enable JavaScript.
(Reporter)

Comment 4

9 years ago
(In reply to comment #3)
> User profiles are part of the public facing portion of the site -- millions of
> users have accounts that they may need to update. Developers are a small,
> tech-savvy group using advanced functionality on the site. It would be too time
> consuming to develop and test for the extremely small portion of users who
> choose to disable JavaScript.

OK, throw all developers away, give them no attention, as they are a minority: this whole site will shut down because add-ons will not be updated. No, developers are the core members of this site addons.mozilla.org. The focus should be on them, too.

> 
> Fortunately, there's a workaround for this bug: enable JavaScript.

Well, if JavaScript can be disabled in Mozilla Firefox Options, than that means that a user can have a PREFERENCE of disabling JavaScript. I have such preference. Why do I have such preference? Because many sites use JavaScript not for dynamic content of their sites, but to place advertisements of their sponsors.

Does this preference mean that I will be unable to improve browsing experience of millions of Firefox users by uploading an Add-on to AMO?
(In reply to comment #4)
> Does this preference mean that I will be unable to improve browsing experience
> of millions of Firefox users by uploading an Add-on to AMO?

Yes. Or, at least, you can't host your add-on on addons.mozilla.org to do so.
(Reporter)

Comment 6

9 years ago
[ironically] Thank you. 

[sadly] At last, can I know what is the technical difference between a profile update and an update of add-on's descriptions?
(Reporter)

Comment 7

9 years ago
I have set the importance of this bug to "enhancement".
Severity: major → enhancement
(Reporter)

Comment 8

9 years ago
Then, please fix the limit profile problem at least.

Description:
In user profile, with JavaScript disabled, you can enter as much information as you want in the "about myself" section, though the limit is 500.

Steps to reproduce:
1 log in at addons.mozilla.org
2 go to "edit your profile" link at the right top
3 enter a thousand of symbols in the "about myself" section
4 save

Actual result:
A successful profile update.

Expected result:
A warning about the 500 characters limit.

URL:https://addons.mozilla.org/en-US/firefox/user/4817791

Additional information:
I didn't register at addons.mozilla.org because I was unable to install a search provider without JavaScript. I had to install it manually. I asked the developer of the real-fox extension I use to explain this, and got these detailed descriptions of this bug, and the example URL. However, Gryllida didn't want to report this bug, and asked me to do so, because Gryllida also thinks this topic unimportant. Hopefully you understand at least the profile JavaScript problem.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
We should check that in the model in Zamboni.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Priority: -- → P4
Hardware: x86 → All
Summary: addons.mozilla.org works incorrectly with JavaScript disabled → Check user profile's "about myself" length in model
Whiteboard: [z]
By the way, Nick, there's an extension called NoScript which will allow you to switch off JavaScript by default, but enable it for certain sites only. I seem to remember it is even activated for AMO by default in NoScript. You might want to use that and get the best of both worlds.
(Reporter)

Comment 11

9 years ago
(In reply to comment #10)
> By the way, Nick, there's an extension called NoScript which will allow you to
> switch off JavaScript by default, but enable it for certain sites only. I seem
> to remember it is even activated for AMO by default in NoScript. You might want
> to use that and get the best of both worlds.

Thank you, but I think that a Firefox is a good browser all by itself. If there is a preference of having no JavaScript, it must be known by all website developers, and be taken into account. I support the philosophy of the server doing the dynamic work, and of the client doing only an output of the code it receives.
(Reporter)

Comment 12

9 years ago
(In reply to comment #9)
> We should check that in the model in Zamboni.

What is Zamboni? Why is this bug not assigned to somebody if Fred Wenzel knows where to check?
"Zamboni" is the development codename for the new version of AMO: http://micropipes.com/blog/2009/11/17/amo-development-changes-in-2010/

and it's not assigned to anyone because no-one has picked it up yet.
Status: NEW → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 502870
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.