Bug in saving mail with images after 'Edit as New'

RESOLVED DUPLICATE of bug 380372

Status

defect
--
major
RESOLVED DUPLICATE of bug 380372
10 years ago
10 years ago

People

(Reporter: laurent.combe, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.5) Gecko/20091204 Lightning/1.0b2pre Thunderbird/3.0

Take a message with an image incorporated
Edit as New
After a first saving (manually, or a automacally save) the mail
contain a bad reference to the image and cannot be saved or send anymore

Reproducible: Always

Steps to Reproduce:
1 - Select a mail in your inbox with a image inside. 
2 - Click on right button and "Edit as New"
3 - Now you are in the compose window
4 - Save your mail as a draft (first time)

At this point all is OK, but : 

5 - Save your mail as a draft a second time, 
and now you have a very nice error message :
"Unable to save ..."
Notice that you cannot send your message at this point.

But if you close your compose window, and reopen the saved Draft
you can send it normally.
Actual Results:  
The image's reference in the mail has been changed after saving and obviously
this new reference is not good.

Expected Results:  
Message can be saved many times without pb.
this might be a duplicate. please
a) cite the full text of the error message
b) can you search bugzilla to see if a like bug exists with words attachment, picture or image?

you didn't see this in veresion 2?
Version: unspecified → 3.0
Possible duplicate of bug 380372
laurent, do you agree ?
yes you're right, my report is a duplicate of bug 380372.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 380372
You need to log in before you can comment on or make changes to this bug.