Closed Bug 539943 Opened 11 years ago Closed 11 years ago

Set up builders for Lightning 1.0b2pre for Thunderbird 3.1

Categories

(Calendar :: Build Config, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Fallen, Assigned: gozer)

References

Details

Attachments

(1 file)

Now that we have released 1.0b1, we need to make sure the builders are doing the right thing w.r.t 1.0b2pre.

1.0b2pre should be released near Thunderbird 3.1 (mozilla 1.9.2). This means we need to change the current 1.9.1 builders to use 1.9.2. We also need to make sure we are cloning the right 1.9.2: we need to have the one that has the same mozstorage changes that Thunderbird has. This may be a non-issue though, in case 1.9.2 contains those fixes.

I'm not sure what all needs to be changed, gozer told me its a mozconfig issue, but then again the tinderbox should also report "comm-1.9.2", and we need to make sure the build land at ftp://..../latest-comm-1.9.2.

Please correct me if I am wrong, I haven't quite understood how the branching for Tb 3.1 will work.
Assignee: nobody → gozer
We should take care of this bug before further checkins to better identify possible regressions. Raising importance.
Severity: normal → blocker
Flags: blocking-calendar1.0+
Priority: -- → P2
Is this about Sunbird or Lightning or both? 

Do you really want to move the builders from 1.9.1 to 1.9.2? Or do you want to add new ones for 1.9.2? In the former case this means we would loose Lightning support for 1.9.1 based builds like Thunderbird 3.0?
Attachment #422230 - Flags: review?(philipp)
(In reply to comment #2)
> Is this about Sunbird or Lightning or both? 
> 
> Do you really want to move the builders from 1.9.1 to 1.9.2? Or do you want to
> add new ones for 1.9.2? In the former case this means we would loose Lightning
> support for 1.9.1 based builds like Thunderbird 3.0?

One problem with doing both 1.9.1 and 1.9.2 builds will be disk space, as the Linux and Windows build boxes are already pretty short on spare space.
Comment on attachment 422230 [details] [diff] [review]
move lightning 1.9.1 buildbot slaves to 1.9.2 

>+BRANCHES['comm-1.9.2-lightning']['mozilla_central_branch'] = 'releases/mozilla-1.9.2'
>+BRANCHES['comm-1.9.2-lightning']['branch_name'] = 'comm-1.9.2'
>+BRANCHES['comm-1.9.2-lightning']['hg_branch'] = 'releases/comm-1.9.1'
I'd appreciate some explaination on how the branching for Thunderbird 3.1 is going to work. Presumably we should do this the same. The above suggests that we need to pull releases/comm-1.9.1, but why 1.9.1?

If we pull from comm-1.9.1, this means we need to cross-commit all future checkins, which was annoying enough during release times. What other options do we have?

Given we are not supporting Sunbird after 1.0b1, I don't really care what branch Sunbird stays on. Maybe we should stay on 1.9.1 for Sunbird since its the last working branch.

Stefan, what do you think?
(In reply to comment #5)
> (From update of attachment 422230 [details] [diff] [review])
> >+BRANCHES['comm-1.9.2-lightning']['mozilla_central_branch'] = 'releases/mozilla-1.9.2'
> >+BRANCHES['comm-1.9.2-lightning']['branch_name'] = 'comm-1.9.2'
> >+BRANCHES['comm-1.9.2-lightning']['hg_branch'] = 'releases/comm-1.9.1'
> I'd appreciate some explaination on how the branching for Thunderbird 3.1 is
> going to work. Presumably we should do this the same. The above suggests that
> we need to pull releases/comm-1.9.1, but why 1.9.1?

That was a mistake on my part, it should have been comm-central.

> If we pull from comm-1.9.1, this means we need to cross-commit all future
> checkins, which was annoying enough during release times. What other options do
> we have?
> 
> Given we are not supporting Sunbird after 1.0b1, I don't really care what
> branch Sunbird stays on. Maybe we should stay on 1.9.1 for Sunbird since its
> the last working branch.

Sunbird is configured completely separately from Lightning, so it's not a problem at all to leave it on 1.9.1
Comment on attachment 422230 [details] [diff] [review]
move lightning 1.9.1 buildbot slaves to 1.9.2 


>+BRANCHES['comm-1.9.2-lightning']['hg_branch'] = 'releases/comm-1.9.1'
Change to comm-central as discussed, otherwise r=philipp
Attachment #422230 - Flags: review?(philipp) → review+
Comment on attachment 422230 [details] [diff] [review]
move lightning 1.9.1 buildbot slaves to 1.9.2 

>+++ b/thunderbird/config.py
>@@ -74,7 +74,8 @@
>-    'comm-1.9.1-lightning': {},
>+    'comm-1.9.2-lightning': {},
>+    'comm-1.9.2-lightning': {},

I guess 'comm-1.9.2-lightning' is only required once?
Stefan's and my comment taken into account and

Pushed to buildbot-configs <http://hg.mozilla.org/build/buildbot-configs/rev/af80143e25cf>

-> FIXED
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
The builds at /pub/mozilla.org/calendar/lightning/nightly/latest-comm-central/win32-xpi are not working for me with the Lanikai/3.1b1pre nightlies.
Unless there's a missing change in the configs, which I doubt, I very much suspect gozer hasn't reconfigured the buildbot master yet, if he has, then something doesn't look right as it is still listing lightning as building on 1.9.1.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Yes, thats probably it. I checked in this patch in hopes that everything would go automatically since I haven't heard from gozer for a while.
David, the latest-comm-central directory is for 3.2a1pre builds. When the changes from this patch actually show effect, there should be a latest-comm-1.9.2 directory.
Depends on: 543359
Lightning builds for Windows and Linux are now available. 
The builds for Mac OS X are failing with a postflight error.
Status: REOPENED → ASSIGNED
Summary: Set up builders for 1.0b2pre → Set up builders for Lightning 1.0b2pre for Thunderbird 3.1
Duplicate of this bug: 544118
Duplicate of this bug: 544118
(In reply to comment #15)
> Lightning builds for Windows and Linux are now available. 
> The builds for Mac OS X are failing with a postflight error.

Gozer:

Can you add:

http://hg.mozilla.org/build/buildbot-configs/file/a54f1d2d5d7e/thunderbird/config.py#l609 (i.e. DISABLE_LIGHTNING_INSTALL=1)

onto the Lightning 1.9.2 Mac builds please.
Target Milestone: 1.0 → 1.0b2
(In reply to comment #18)
> (In reply to comment #15)
> [...]
> 
> Gozer:
> Can you add:
> http://hg.mozilla.org/build/buildbot-configs/file/a54f1d2d5d7e/thunderbird/config.py#l609
> (i.e. DISABLE_LIGHTNING_INSTALL=1)
> 
> onto the Lightning 1.9.2 Mac builds please.

Done.
All builds are green and building, closing this bug. Thanks for taking care!
Status: ASSIGNED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.