Closed Bug 540094 Opened 11 years ago Closed 2 years ago

[OOPP] unhandled winless plugin events are improperly serialized, should be ignored altogether

Categories

(Core :: Plug-ins, defect, P3)

x86
Windows 7
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
blocking2.0 --- -

People

(Reporter: jimm, Unassigned)

References

Details

(Keywords: hang)

Crash Data

<jimm> *** npevent->event = 281
<jimm> ###!!! [Child][RPCChannel] Error: Payload error: message could not be deserialized
<jimm> *** npevent->event = 282
<jimm> ###!!! [Child][RPCChannel] Error: Payload error: message could not be deserialized
<jimm> those are WM_IME_SETCONTEXT, and WM_IME_NOTIFY

http://hg.mozilla.org/projects/electrolysis/file/6f003829a096/dom/plugins/NPEventWindows.h#l66
Summary: [oopp] winless plugin ime events not getting serialized → [OOPP] winless plugin ime events not getting serialized
Summary: [OOPP] winless plugin ime events not getting serialized → [OOPP] unknown winless plugin events are improperly serialized, should be ignored altogether
Summary: [OOPP] unknown winless plugin events are improperly serialized, should be ignored altogether → [OOPP] unhandled winless plugin events are improperly serialized, should be ignored altogether
Should this be fixed ASAP (3.6.6)?

/be
Blocks: 576007
Would it reduce crashing/hangs if it were fixed on 3.6+?
bug 567936 is listed in the top ten crashers for Firefox 3.6.8. That bug is marked as a duplicate of bug 567645, which is marked as a duplicate of this bug. It also occurred to me, a few times in just a few minutes even.
When will this be fixed?  Is there a possibility that this is responsible for the myriad responsiveness issues when running demanding flash videos and games?
blocking2.0: --- → ?
(In reply to comment #5)
> When will this be fixed?  Is there a possibility that this is responsible for
> the myriad responsiveness issues when running demanding flash videos and games?

No, not likely. These are windowing events we don't deliver to flash via handle event. The original spec was very limited in what we delivered. Over time we've expanded this a bit, but I don't believe much of that is documented.
I'd really like to turn on strict-aborting IPC error checking for plugins, but we need to fix this first. The obvious way to fix this is to avoid delivering these events at all.
blocking2.0: ? → -
Mafia Wars game on Facebook has 21 MILLION active monthly users and with the current Firefox m-c builds shows pretty terrible responsiveness on Flash heavy "Properties" page. IANAD but I think this bug is what's causing it, and if I'm right this should block the final release

21 million is a pretty large number of users.
This bug has nothing to do with responsiveness, there are other bugs which address those persistent issues.
I experienced this crash event:
Firefox 3.6.12 Crash Report [@ hang | mozilla::plugins::PPluginInstanceParent::CallNPP_HandleEvent(mozilla::plugins::NPRemoteEvent const&, short*) ] 
http://crash-stats.mozilla.com/report/index/bp-ca3ca0bd-2a53-4531-b69c-881372101205
( linked to
Firefox 3.6.12 Crash Report [@ hang | KiFastSystemCallRet ]
http://crash-stats.mozilla.com/report/index/bp-94b7cf58-64a4-49b1-928f-960972101205 )

The 1st crash page links to the bug https://bugzilla.mozilla.org/show_bug.cgi?id=567936 tha redirects to this bug.

I was browsing a Flash streaming when FF froze completely. I had to wait for 1 min then the Flash plugin crashed (FF sent a report).
[@ hang | mozilla::plugins::PPluginInstanceParent::CallNPP_HandleEvent(mozilla::plugins::NPRemoteEvent const&, short*) ] 

Please add above to crash signature, so it is picked up on crash-stats.mozilla.com

Came here the long way.

567936 (is duplicate - has crash signature) ==> 567645 (duplicate) ==> this bug
Crash Signature: [@ hang | mozilla::plugins::PPluginInstanceParent::CallNPP_HandleEvent(mozilla::plugins::NPRemoteEvent const&, short*) ]
reference: dd299209-46a3-41b2-8f84-214da2111011
Severity: normal → critical
Keywords: hang
Assignee: jmathies → nobody
Priority: -- → P3
Crash Signature: [@ hang | mozilla::plugins::PPluginInstanceParent::CallNPP_HandleEvent(mozilla::plugins::NPRemoteEvent const&, short*) ] → [@ hang | mozilla::plugins::PPluginInstanceParent::CallNPP_HandleEvent(mozilla::plugins::NPRemoteEvent const&, short*) ] [@ hang | mozilla::plugins::PPluginInstanceParent::CallNPP_HandleEvent ]
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.