Crash on printing a message on Macintosh

VERIFIED FIXED

Status

MailNews Core
Printing
P2
critical
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: nhottanscp, Assigned: dougt)

Tracking

({crash})

Trunk
PowerPC
Mac System 9.x
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm need info])

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Used 2000-09-22-12-M18 mac build on OS9.
When I tried to print a message, I got a crash, happened both local and imap.

 Call Stack:    (Signature = 0xd4eabc00 02437569)
     0xd4eabc00
     DOM_DLL + 0x23fa0 (0x1eaa3ff0)
     nsDocument::HandleDOMEvent()                      [nsDocument.cpp, line 
3038]
     nsGenericElement::HandleDOMEvent()                [nsGenericElement.cpp, 
line 1387]
     nsHTMLHtmlElement::HandleDOMEvent()               [nsHTMLHtmlElement.cpp, 
line 183]
     PresShell::HandlePostedDOMEvents()                [nsPresShell.cpp, line 
3523]
     PresShell::ProcessReflowCommands()                [nsPresShell.cpp, line 
4550]
     HandlePLEvent()                                   [nsPresShell.cpp, line 
4371]
     PL_HandleEvent()                                  [plevent.c, line 575]
     PL_ProcessPendingEvents()                         [plevent.c, line 508]
     nsEventQueueImpl::ProcessPendingEvents()          [nsEventQueue.cpp, line 
356]
     nsMacNSPREventQueueHandler::ProcessPLEventQueue() [nsToolkit.cpp, line 134]
     nsMacNSPREventQueueHandler::RepeatAction()        [nsToolkit.cpp, line 99]
     Repeater::DoRepeaters()                           [nsRepeater.cpp, line 
119]
     nsMacMessagePump::DispatchEvent()                 [nsMacMessagePump.cpp, 
line 421]
     nsMacMessagePump::DoMessagePump()                 [nsMacMessagePump.cpp, 
line 250]
     nsAppShell::Run()                                 [nsAppShell.cpp, line 
110]
     nsAppShellService::Run()                          [nsAppShellService.cpp, 
line 406]
     Netscape 6 + 0x443c (0x1ef6c9ac)
     Netscape 6 + 0x4f28 (0x1ef6d498)
     Netscape 6 + 0x1a5ec (0x1ef82b5c)

Updated

18 years ago
QA Contact: esther → fenella

Comment 1

18 years ago
Mac (2000-09-22-12 M18) is the most current build that I can use. And I see the
problem too. My Mac is OS 8.6

Comment 2

18 years ago
My build is from Thursday.. which works.  I am building with todays tree to 
check again.  Also from the Stack Trace this does not seem to be a printing 
problem.. the call stack never gets there.  Seems more a problem in Mail/News.
I am giving to mscott.. I hope you know the right person to give this to.
Assignee: dcone → mscott

Comment 3

18 years ago
*spam*

adding crash keyword...
Keywords: crash

Comment 4

18 years ago
Mac (2000-09-25-12 M18)
This problem is still there in today's build.

Updated

18 years ago
Keywords: nsbeta3, rtm

Comment 5

18 years ago
What is the impact?  Is this every message or just a specific message?  Need to 
know so we can decide +/-.
Whiteboard: [b3 need info]

Comment 6

18 years ago
I would recommend it to be nsbeta3+ because it crashes on every mail message
(Reporter)

Comment 7

18 years ago
*** Bug 54182 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 8

18 years ago
*** Bug 54182 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 9

18 years ago
I got a crash on win32 using my local debug build (the branch), the same call 
stack as Macintosh. Before it crashes, there were many assersions at 
nsFontMetricsWin::FindSubstituteFont(), I don't know if that's related to the 
crasher. I will attch the call stack for the assersion.
(Reporter)

Comment 10

18 years ago
Created attachment 15522 [details]
call stack of the assersion

Comment 11

18 years ago
rtm+ assuming this means you can't ever print at all on Mac.
Whiteboard: [b3 need info] → [rtm+]

Comment 12

18 years ago
Adding Don Cone to Cc list.

I don't know why the DC is NULL at that point. It seems like somebody is trying
to layout the document before the DC has been created. Don, any ideas?

Comment 13

18 years ago
Just to confirm: Peter Mock, Fenella and I all see this crash printing any
message.  added relnote3 keyword.
Keywords: relnote3

Updated

18 years ago
Severity: normal → critical

Comment 14

18 years ago
Using today mac branch build 2000-092911-mn6, I crash immediate when I click on 
the print button.  This occurs on a migrated and new profile.  The message that 
I was trying to print was a very short plain text message. I do not get far 
enough in the print process to see the print dialog.  :(  Nothing gets printed 
to the printer.

Comment 15

18 years ago
changing to [rtm need info]. We want to rtm+ this but need a patch and code
reviews. When those exist, please change back to [rtm+].
Whiteboard: [rtm+] → [rtm need info]

Comment 16

18 years ago
This may be the same bug as 53969, its hard to tell, but it sounds very 
suspicious.  I will keep track of both.. as soon as Waterson has a fix I will 
check this one.

Comment 17

18 years ago
reassigning to sspitzer. Seth, can you look at this and see if this is something
you help fix or if we can find the right person to work on this.
Assignee: mscott → sspitzer
Priority: P3 → P2
I'll investigate.  accepting.
Status: NEW → ASSIGNED
I see a similar stack:

  00000000    PPC  0F495E28
  104BD440    PPC  0F47BB14  main+001AC
  104BD3E0    PPC  0F4794A0  main1(int, char**, nsISupports*)+00870
  104BD170    PPC  107BDD9C  nsAppShellService::Run()+00054
  104BD120    PPC  0F1E8B34  nsAppShell::Run()+0004C
  104BD0E0    PPC  0F1E9418  nsMacMessagePump::DoMessagePump()+00044
  104BD090    PPC  0F1E9C54  nsMacMessagePump::DispatchEvent(int,
EventRecord*)+001B0
  104BD040    PPC  0F20D114  Repeater::DoRepeaters(const EventRecord&)+0003C
  104BCFF0    PPC  0F1B5C8C  nsMacNSPREventQueueHandler::RepeatAction(const
EventRecord&)+000
14
  104BCFB0    PPC  0F1B5F38  nsMacNSPREventQueueHandler::ProcessPLEventQueue()+00244
  104BCF10    PPC  1084D414  nsEventQueueImpl::ProcessPendingEvents()+00068
  104BCEA0    PPC  108CEC4C  PL_ProcessPendingEvents+00090
  104BCE50    PPC  108CEEA0  PL_HandleEvent+00054
  104BCE10    PPC  0E9E0EC4  HandlePLEvent(ReflowEvent*)+000D4
  104BCDB0    PPC  0E9E1D94  PresShell::ProcessReflowCommands(int)+005A4
  104BCCA0    PPC  0E9DDFE4  PresShell::HandlePostedDOMEvents()+00064
  104BCC50    PPC  0EBA5258  nsHTMLHtmlElement::HandleDOMEvent(nsIPresContext*,
nsEvent*, nsI
DOMEvent**, unsigned int, nsEventStatus*)+00040
  104BCC10    PPC  0ED36DB0  nsGenericElement::HandleDOMEvent(nsIPresContext*,
nsEvent*, nsIDOMEvent**, unsigned int, nsEventStatus*)+00874
  104BC9D0    PPC  0E9A82EC  nsDocument::HandleDOMEvent(nsIPresContext*,
nsEvent*, nsIDOMEvent**, unsigned int, nsEventStatus*)+000B8

I had to use macsbug to get the stack trace, the debugger kept giving me "access
fault exception"

cc'ing dougt in case this is related to the event queue fix he is working on.

note, I also see this on the tip and the branch.

off to debug some more.
(Assignee)

Comment 20

18 years ago
I checked in a fix to plevent ProcessPendingEvents today to the BRANCH and
TRUNK.  updating plevent.c and see if you can reproduce.
I am not able to reproduce this today.

I'm going to assume that dougt's patch fixed it.

re-assign to dougt, so he gets the credit.

Assignee: sspitzer → dougt
Status: ASSIGNED → NEW
marking fixed for dougt.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 23

18 years ago
Mac (2000-10-09-09 M18)
Mac (2000-10-09-10 MN6)
The printing is working now both in Trunk and Branch builds.
Status: RESOLVED → VERIFIED
Product: MailNews → Core

Updated

14 years ago
OS: Mac System 9.x
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.