In China, set default browser does not work

RESOLVED FIXED

Status

()

Firefox
Shell Integration
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: Lingfeng.Guan, Assigned: rstrong)

Tracking

3.5 Branch
x86
Windows XP
Points:
---
Bug Flags:
in-testsuite -
in-litmus -

Firefox Tracking Flags

(blocking2.0 final+, blocking1.9.2 needed, status1.9.2 .9-fixed, status1.9.1 .12-fixed)

Details

Attachments

(6 attachments, 1 obsolete attachment)

(Reporter)

Description

8 years ago
Other main browsers in China (360 browser , sogou browser, both IE clones), whom together have more than 20% market share, they used a very tricky way of setting default browser.
After they did that, even if the users click set firefox as default browser. All links from other programs are opened by those IE clones.
Do you have details on what this "tricky way" is? I am assuming they are not using the default Windows system for setting the default browser.
Component: File Handling → Shell Integration
QA Contact: file.handling → shell.integration
(Reporter)

Comment 2

8 years ago
Take http as an example.

We change the command,ddexec,Application,topic, etc... under HKEY_CLASSES_ROOT\HTTP\shell\open\ and HKCU\Software\classes\HTTP\shell\open when we change the default browser.

And they do this too. But they also did something else. They add another directory to HKEY_CLASSES_ROOT\HTTP\shell and HKCU\Software\Classes\http\shell containing the following keys

[HKEY_CURRENT_USER\Software\Classes\http\shell\SogouExplorer]
@="browse using &SogouExplorer"

[HKEY_CURRENT_USER\Software\Classes\http\shell\SogouExplorer\Command]
@="\"C:\\Program Files\\SogouExplorer\\SogouExplorer.exe\" \"%1\""

and they set 
[HKEY_CURRENT_USER\Software\Classes\http\shell]
@="SogouExplorer"

and 

[HKEY_CLASSES_ROOT\http\shell]
@="SogouExplorer"

By doing this, it was like tell windows, there was another way to open a file called "browse using &SogouExplorer" except open, and tell windows to use "browse using &SogouExplorer" by default. By doing this, no matter what we change the content inside "open" directory, it will not work, because windows will not use "open" by default.

They did this to all kinds of URL, and all kinds of files which a browser could open.

And that is what we got by now, and I will post a list of what they did to the registry later. And test whether they did anything else
(Reporter)

Comment 3

8 years ago
Created attachment 422322 [details]
A diff file of my registry before install SogouBrowser and after install SogouBrowser
(Reporter)

Comment 4

8 years ago
Created attachment 422325 [details]
Since the reg file is so large, I modified the patch file to include the context for every change, and removed all unrelated changes
Can I get a download of this browser so I can verify a fix for this locally?
(Reporter)

Comment 6

8 years ago
http://down.360safe.com/se/360se_3.1.exe  This is for 360 browser, whose number is going up very fast, market share more than 15% now.

http://download.ie.sogou.com/sogou_explorer_1.4b.exe  This is sogou browser
(Reporter)

Comment 7

8 years ago
Btw: I don't think they have a english version...

So take 360 browser for example
the set as default will be triggered on first install. And everytime the browser startup there will be a Confirm Box, choose yes to set it to default.

And after that, if you want to set it to defaut manually, You can do it by select the second menu from right side , click the last but one menuitem from top.
The preference is on the first pref page, it's a checkbox at the last but two of that page from top.(you have to scroll to get to the end of the page)

Comment 8

8 years ago
Created attachment 422505 [details]
360 browser registry log

Comment 9

8 years ago
search with the key "C:\Program Files\360\360se3\360SE.exe" in the file attached above,
we can find them at line 32 and 34. Look at line 30, it is "HKCU\Software\Classes\http\shell\(Default)	SUCCESS	"360SE.exe"" .The default value is set to "360SE.exe" but original is empty, then at line 31 we see, it creates a new subkey of shell ,its name is 360SE.exe which contains subkey "command",and its value is "C:\Program Files\360\360se3\360SE.exe" "%1""
Line 35 "HKCU\Software\Classes\https\shell"
Line 42 "HKCR\file\shell\(Default)	SUCCESS	"360SE.exe""
Line 44 "HKCR\file\shell\open\command\(Default)	SUCCESS	""C:\Program Files\360\360se3\360SE.exe" "%1"""
They do it the same way.
Maybe we can change it back, the problem would be solved.
blocking1.9.2: --- → ?
Rob, I see you nominated for blocking, do you believe that this is something we can fix when we install/run Firefox?
I'm quite sure we can. We can check for these values and clean up the entries so we set as default properly.
(Reporter)

Comment 12

8 years ago
Thank you very much:) That will be a great help.
You know the worst thing of this is that sometimes when users cannot set Firefox back to their default browser, they do not think 360 browser or sogou browser is doing something tricky, instead they think our technic is not as good.
blocking1.9.2: ? → needed
blocking2.0: --- → ?
status1.9.2: --- → wanted

Updated

8 years ago
blocking2.0: ? → beta1+

Comment 13

8 years ago
that's great
(Reporter)

Comment 14

8 years ago
Thank you very much to everyone, and I'm Sorry that I told Robert that I want to help, but I've been exhausted during the last 4 months, and didn't have time to do that. I feel really sorry.
We should fix this, I agree, but I don't think we need to block the very first beta on it. Marking blocking:final+
blocking2.0: beta1+ → final+
(Reporter)

Comment 16

8 years ago
Created attachment 458041 [details]
This is the minimal change set we need to add to the current change set.

This is the minimal change set we need to add to the current change set. (Btw:SogouExplorer also apply the changes in HKCU to the corresponding keys in HKEY_USERS, which I didn't add to this minimal change set, please check the sogou diff set)
We don't support .mht or .mhtml and we don't take over xmlfile though there is a bug to consider taking it (there has been no requests to do so).

What are the old values for
file\shell\(Default)
InternetShortcut\shell(Default)
StartMenuInternet\(Default)

Are you sure file\shell\ is a required change?

Does Firefox retain the defaults after the system is restarted?
btw: I'm going to try to get most if not all of this written over the weekend and any info regarding the questions in comment #17 would be appreciated if you have the time. Thanks!
One other thing... what version of windows did you check this on? I ask because the default for htmlfile\shell is opennew on win7 and we might want to do a bit more cleanup than just changing it to new on some versions of windows.
(Reporter)

Comment 20

8 years ago
(In reply to comment #17)
> We don't support .mht or .mhtml and we don't take over xmlfile though there is
> a bug to consider taking it (there has been no requests to do so).
> 
> What are the old values for
> file\shell\(Default)

this does not exist by default (on Win7)

> InternetShortcut\shell(Default)

the default value of this is not set

> StartMenuInternet\(Default)

    Sorry, the default value of this in HKLM is IEXPLORE.EXE, and is not "open"
    and in HKCU is FIREFOX.EXE, 
> 
> Are you sure file\shell\ is a required change?

    I'm not very sure, the shell key does not exist before install those two IE clones, but SogouExplorer and 360Explorer both tried to created the shell kay and changed this value to themselves, I think maybe we should delete the shell key recursively.
> 
> Does Firefox retain the defaults after the system is restarted?

I didn't understand what does this mean...
(Reporter)

Comment 21

8 years ago
(In reply to comment #19)
> One other thing... what version of windows did you check this on? I ask because
> the default for htmlfile\shell is opennew on win7 and we might want to do a bit
> more cleanup than just changing it to new on some versions of windows.

I'm on Windows7, and I think I made a mistake on that one and others maybe, I got the minimal change set from the 360 diff file and my tests, but I made assumptions on some keys' default value, but it seems their default values are not what I guessed...

I'll update the minimal change list ASAP
Thanks for the answers. We *might* be able to accomplish when this condition exists in a cleaner fashion by first setting IE as the default then setting us as the default. I'll investigate.

(In reply to comment #20)
> (In reply to comment #17)
>...
> > Does Firefox retain the defaults after the system is restarted?
> 
> I didn't understand what does this mean...
I wanted to make sure the changes don't get reverted after restarting. Also, do these browsers take them back without user confirmation if they are relaunched? I ask because if they could be launched in a non obvious fashion then they would revert what we just fixed.

(In reply to comment #21)
>...
> I'm on Windows7, and I think I made a mistake on that one and others maybe, I
> got the minimal change set from the 360 diff file and my tests, but I made
> assumptions on some keys' default value, but it seems their default values are
> not what I guessed...
> 
> I'll update the minimal change list ASAP
I don't think that will be necessary but it might come in handy.
note to self: the following provides an example of what SogouExplorer does to the registry... pretty scary how heavily they modify things that don't need to be and shouldn't be modified / deleted.

http://www.threatexpert.com/report.aspx?md5=1dd66913bd36274e098f59688668c06d
(Reporter)

Comment 24

8 years ago
Created attachment 458052 [details]
This is the modified minimal change set
Attachment #458041 - Attachment is obsolete: true
How are you setting Firefox as the default browser? Is it by using the Firefox set as default browser prompt or the Windows Set Default Programs UI?
(Reporter)

Comment 26

8 years ago
Using the Firefox set as default browser prompt
The following are already set when Firefox is set as default
SetValue  HKCU\Software\Classes\.htm\(Default)    "FirefoxHTML"
SetValue  HKCU\Software\Classes\.html\(Default)   "FirefoxHTML"
SetValue  HKCU\Software\Classes\.shtml\(Default)  "FirefoxHTML"

These we should remove or set to open
DeleteValue  HKCU\Software\Classes\http\shell\(Default)
DeleteValue  HKCU\Software\Classes\https\shell\(Default)

Were your initial tests done with Windows XP and have you reproduced with Windows 7? If you have reproduced with Windows 7 can you give me specific steps to reproduce (e.g. from the Start Menu can you reproduce, from Thunderbird, etc. on Windows 7). I've install / set as default Sogou Explorer on Windows 7, verified that I had all of the minimal keys set of registry settings from the attachment set to Sogou Explorer or other non default settings, and after setting 3.6.5 to default all urls from Thunderbird, internet shortcuts, and from the Start Menu search box launched Firefox.
I've also tested with and without Firefox running and it works for me.
(In reply to comment #27)
>...
> These we should remove or set to open
> DeleteValue  HKCU\Software\Classes\http\shell\(Default)
> DeleteValue  HKCU\Software\Classes\https\shell\(Default)
btw: these would break opening urls from other programs on XP and below and from programs that don't use the api's provided for opening urls on all version of Windows.
(Reporter)

Comment 30

8 years ago
(In reply to comment #29)
> btw: these would break opening urls from other programs on XP and below and
> from programs that don't use the api's provided for opening urls on all version
> of Windows.

I don't understand, these values used to be (value not set) before I install sogouExplorer
(In reply to comment #30)
> (In reply to comment #29)
> > btw: these would break opening urls from other programs on XP and below and
> > from programs that don't use the api's provided for opening urls on all version
> > of Windows.
> 
> I don't understand, these values used to be (value not set) before I install
> sogouExplorer
What I am saying is that Firefox not deleting or setting those values to open "would break opening urls from other programs on XP and below and from programs that don't use the api's provided for opening urls on all version of Windows."

I've got a patch that fixes that one issue. That along with answers to the questions in comment #27 could be all that is needed.
(Reporter)

Comment 32

8 years ago
cool! got it.
What about these shell values? Maybe some program are using these to open url?
SetValue     HKLM\SOFTWARE\Classes\htmlfile\shell\(Default)     "opennew"
DeleteValue  HKLM\SOFTWARE\Classes\file\shell(Default)
DeleteKey    HKLM\SOFTWARE\Classes\file\shell
DeleteValue  HKLM\SOFTWARE\Classes\InternetShortcut\shell(Default)  

I'll answer the #27 questions right now:)
(Reporter)

Comment 33

8 years ago
(In reply to comment #27)
> The following are already set when Firefox is set as default
> SetValue  HKCU\Software\Classes\.htm\(Default)    "FirefoxHTML"
> SetValue  HKCU\Software\Classes\.html\(Default)   "FirefoxHTML"
> SetValue  HKCU\Software\Classes\.shtml\(Default)  "FirefoxHTML"
> 
> These we should remove or set to open
> DeleteValue  HKCU\Software\Classes\http\shell\(Default)
> DeleteValue  HKCU\Software\Classes\https\shell\(Default)
> 
> Were your initial tests done with Windows XP and have you reproduced with
> Windows 7? If you have reproduced with Windows 7 can you give me specific steps
   Yes, my initial tests were done on Windows XP. And I justed tested on Win7, seems it's ok in many programs that used to have problems in Windows XP.
   I'm still testing other programs
> to reproduce (e.g. from the Start Menu can you reproduce, from Thunderbird,
> etc. on Windows 7). I've install / set as default Sogou Explorer on Windows 7,
> verified that I had all of the minimal keys set of registry settings from the
> attachment set to Sogou Explorer or other non default settings, and after
> setting 3.6.5 to default all urls from Thunderbird, internet shortcuts, and
> from the Start Menu search box launched Firefox.
(In reply to comment #32)
> cool! got it.
> What about these shell values? Maybe some program are using these to open url?
> SetValue     HKLM\SOFTWARE\Classes\htmlfile\shell\(Default)     "opennew"
Taking over .htm, .html, etc. should suffice without changing this.

> DeleteValue  HKLM\SOFTWARE\Classes\file\shell(Default)
> DeleteKey    HKLM\SOFTWARE\Classes\file\shell
This is for the file protocol when used outside of Firefox which is extremely rare... I'm not positive if it would be a problem when it is used due to the CLSID. I'll try to test this out in the next couple of days.
> DeleteValue  HKLM\SOFTWARE\Classes\InternetShortcut\shell(Default)  
Shouldn't be a problem.

Could you try setting as default on XP, delete the default values under, and test to see if there are any problems?
HKLM\Software\Classes\https\shell\
HKCU\Software\Classes\http\shell\
(Reporter)

Comment 35

8 years ago
Sure, but my XP is in the office, and I'm afraid I have to wait until this time tomorrow to test it.
No problem. I've submitted a patch to the try server and will post a link to the installer in this bug when it has finished building so you can test with the changes.
(Reporter)

Comment 37

8 years ago
Awesome!:)
The Windows build will show up in
http://ftp.mozilla.org/pub/mozilla.org/firefox/tryserver-builds/rstrong@mozilla.com-bc7fbd947b18/

after it is completed. Posting now in case I'm not around when it is finished... if I am around, I'll post a link to the installer itself.
The Windows try opt build failed without a reason (shakes fist at the try server) so I resubmitted. They will likely show up here
http://ftp.mozilla.org/pub/mozilla.org/firefox/tryserver-build/rstrong@mozilla.com-672b3d594d00/
I take the without a reason back and insert without a reason I care about... there was a timeout trasnfering firefox-4.0b2pre.en-US.win32.crashreporter-symbols-full.zip. meh
Try failed again...  I'll wait until it is successful until posting the link.
(Reporter)

Comment 42

8 years ago
It's already 2:00AM now, you should seriously get some rest, I'll post the link out when it's done. It's better if I can easily rebuild that for you. Or maybe I can just download the win32 debug version and test.
It failed again with a timeout transferring
firefox-4.0b2pre.en-US.win32.crashreporter-symbols-full.zip. :(
Created attachment 458207 [details] [diff] [review]
patch

This patch contains some whitespace cleanup and the addition of the following to the AddDDEHandlerValues macro. I went with adding the value instead of deleting it since the value could already be in HKLM while we are adding it to HKCU and we need to override the HKLM value as read from HKCU.
WriteRegStr SHCTX "$R0\$R2\shell" "" "open"

At the very least we should take this change so I am going to ask for review before the changes have been verified to fix the issue when SogouExplorer is also installed. If there are more issues that need to be resolved they will be in a separate patch.
Assignee: nobody → robert.bugzilla
Status: NEW → ASSIGNED
Attachment #458207 - Flags: review?(jmathies)
(Reporter)

Comment 46

8 years ago
I tested on Windows XP, some case fixed, and some not.
One of the cases that's not working seems related to this change that SogouExplorer has made, it changed the COM object for IE to itself, so that when some program call IE by call IE's COM object, it invoked SogouExplorer, this is something that's not easy for us to do
11381c11394
< [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{0002DF01-0000-0000-C000-000000000046}\LocalServer32]
< @="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\""
---
> [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{0002DF01-0000-0000-C000-000000000046}\LocalServer32]
> @="C:\\Program Files\\SogouExplorer\\SogouExplorer.exe"
(Reporter)

Comment 47

8 years ago
I did more tests on Windows XP. Right now, all the cases I found that's not fixed are related to the CLSID key I talked about.
The cases include:
   Tencent QQ (The most popular IM in China)
   Skype
I'll keep on testing other situations.
(Reporter)

Comment 48

8 years ago
All file extensions we want to associate is now open with Firefox, I tested .html .htm .shtml .xhtml
(In reply to comment #46)
> I tested on Windows XP, some case fixed, and some not.
> One of the cases that's not working seems related to this change that
> SogouExplorer has made, it changed the COM object for IE to itself, so that
> when some program call IE by call IE's COM object, it invoked SogouExplorer,
> this is something that's not easy for us to do
> 11381c11394
> <
> [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{0002DF01-0000-0000-C000-000000000046}\LocalServer32]
> < @="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\""
> ---
> > [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{0002DF01-0000-0000-C000-000000000046}\LocalServer32]
> > @="C:\\Program Files\\SogouExplorer\\SogouExplorer.exe"
Can you provide steps to reproduce without using Skype or Tencent QQ?
(Reporter)

Comment 50

8 years ago
(In reply to comment #49)
> Can you provide steps to reproduce without using Skype or Tencent QQ?
 I don't think I can :(
Btw: I don't think we can fix this one easily. They changed the COM for IE, and they can provide the same interface that IE provides, it's because they are IE clones. For us, implement that interface could be much harder, I guess.
You are correct about it being harder for us to implement and we really shouldn't have to but we might be able to reset it back to IE. When you put the registry setting back does everything work properly as in Firefox is opened or is IE then opened? From your testing is it only broken with Skype or Tencent QQ so far?
(Reporter)

Comment 52

8 years ago
(In reply to comment #51)
> You are correct about it being harder for us to implement and we really
> shouldn't have to but we might be able to reset it back to IE. When you put the
> registry setting back does everything work properly as in Firefox is opened or
> is IE then opened? From your testing is it only broken with Skype or Tencent QQ
> so far?
1. IE is opened instead of Firefox..
2. Yes, so far I only found Skype and Tencent QQ, but unfortunately, Tencent QQ has 104,356,089 users online right now, and it's register user is more than the total number of China internet users. In other words, every Chinese internet user has one or more than one QQ.
(Reporter)

Comment 53

8 years ago
On Windows7, both skype and QQ works fine, they open firefox on link click if you set firefox as default browser.
Does it work fine on a WinXP system that has only the default IE and Firefox installed with Firefox set as the default. If you don't have a system in this state handy you might be able to check by uninstalling Sogou Explorer, setting IE as the default using Set program access and defaults, and then setting Firefox as default. If it does work fine, then there are likely more keys that need to be fixed.
Also, some IM clients have been notorious for reading registry keys directly to open browsers. If it is being read from HKLM vs. HKCU this could happen and you could try setting Firefox as default in Set program access and defaults as well as for the user.
(Reporter)

Comment 56

8 years ago
(In reply to comment #54)
> Does it work fine on a WinXP system that has only the default IE and Firefox
> installed with Firefox set as the default. If you don't have a system in this
> state handy you might be able to check by uninstalling Sogou Explorer, setting
> IE as the default using Set program access and defaults, and then setting
> Firefox as default. If it does work fine, then there are likely more keys that
> need to be fixed.
No, QQ will not open Firefox in any case in Windows XP with IE 7, but I tested on another WIndows XP that installed IE8, the problem fixed automatically.

My guess is, they use a Control (maybe WebBrowser Control) to build their Mini News application, and that control opens all outside link by create an out of process COM object, which should be IE. But the IE clones in China changed that COM to themselves.

Somehow, that Control has been updated in IE8(included in Win7), and in the new version, the outside links are opened by the user's default browser
(Reporter)

Comment 57

8 years ago
And btw, according to my test on another machine, delete http/shell/ and https/shell/ does change the open behavior of other links back except for the ones in the Control...
I'll get a WinXP VM running next weekend to see if I can find a workaround.
I just tried QQ International with XP with all security updates except the one to IE8 so it is running IE 6, without Sogou Explorer, and with Firefox 3.6.6 set as the default browser and advertisements opened in Firefox.

Can you provide the steps to reproduce this? If there is a link for a different Tencent QQ could you provide it and if there isn't an english version I might need some help getting it working. Thanks
(Reporter)

Comment 60

8 years ago
Created attachment 458537 [details]
The QQ everyday news window
(Reporter)

Comment 61

8 years ago
There may be two reasons caused that.
1. Are you clicking the links from its everyday news window? I attached a screen shot of it, because due to my test, only the links in that window will have this kind of problems
2. I'm using IE7 on my XP, maybe it's a behavior of the WebBrowser Control provide with IE7.
There is a similar window in QQ International and links worked from there. I haven't tried with IE7 yet and will try it out after I find a place to download it from. btw: I recall that there was a problem with the registration of the activex control for IE7 on WinXP which might be the cause *crosses fingers*. First I would like to verify that I can reproduce so I can verify the fix.
(Reporter)

Comment 63

8 years ago
I just tested on Windows XP with IE6. And the behavior of the WebBrowser
control is not controlled by
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{0002DF01-0000-0000-C000-000000000046}\LocalServer32].
after I set http\shell and https\shell back to Firefox, everything works just
fine.
So, it seems to be a WebBrowser control IE 7 version only problem
Thanks! Downloading it now and I'll see if I can figure out what is causing this probably tomorrow.
I wasn't able to reproduce with QQ International so I suspect it might only occur with the other version. Can you provide a link to one you have reproduced with?
(Reporter)

Comment 66

8 years ago
I downloaded the latest version of QQ, and it seems it's not affact by the CLSID key already.
So, first, I need to revert the test result about IE6. I didn't check the QQ version in that test.
I'll tests again.
My version of QQ is QQ2008, and it's download link is http://dlc2.pconline.com.cn/filedown.jsp?dlid=50074&linkid=6561850
I'll try it out. I just tried QQ 2009 and was unable to reproduce. Could you check if it works for you as well?
I can reproduce with QQ 2008.
(Reporter)

Comment 69

8 years ago
It's also working fine with QQ 2009, I'll test QQ 2008 on Win7 and WinXP with IE6 and IE8.
(Reporter)

Comment 70

8 years ago
I've tested QQ 2008 on Win7 and WinXP with IE6 and IE8, the result is not good. All open with IE...
I'm fairly certain that the remaining issues are due to QQ 2008 which has been fixed in newer versions of QQ. There were somewhat similar problems with other major IM clients doing similar things in the past. I'm checking with process monitor to see if they are just accessing registry keys to get the path to IE.
(Reporter)

Comment 72

8 years ago
Skype has a Chinese version developed with TOM.com has the same problem.
It looks like QQ 2008 likely uses an IE Web browser control which launches iexplore.exe -Embedding. Regretfully there isn't anything I know of we can do to fix this and definitely nothing the installer can do.

Do you have a link to skype that also has this problem?
(Reporter)

Comment 74

8 years ago
http://download.skype.tom.com/Tom-SkypeSetup.exe

I think it's the same problem as QQ 2008. And I agree that we cannot fix that in the installer. Besides, by change http/shell and https/shell, we already made it better in 80% of the situation. I think that's already a big step.

Updated

8 years ago
Attachment #458207 - Flags: review?(jmathies) → review+
(Reporter)

Comment 75

8 years ago
Hi, Robert
    Is it possible to put this patch in 3.6.8? I think this will help alot on the numbers in China.
Not likely, it will need to bake on trunk for a while and 3.6.8 has already been tagged.
(Reporter)

Comment 77

8 years ago
Got it:) Thanks~
Pushed to mozilla-central
http://hg.mozilla.org/mozilla-central/rev/5b12b792b8a7
Flags: in-testsuite-
Flags: in-litmus-
Comment on attachment 458207 [details] [diff] [review]
patch

Drivers, as far as patches go they don't get much simpler than this and as noted this fix is important to China. The patch adds the open verb (which it is already typically) to the shell integration and there are a couple of browsers in China that change this from open. Thanks for your consideration
Attachment #458207 - Flags: approval1.9.2.9?
Attachment #458207 - Flags: approval1.9.1.12?
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 80

8 years ago
Thanks Robert, I really don't know how could I thank you enough. I owe you one!

Comment 81

8 years ago
Comment on attachment 458207 [details] [diff] [review]
patch

a=LegNeato for 1.9.2.9 and 1.9.1.12.
Attachment #458207 - Flags: approval1.9.2.9?
Attachment #458207 - Flags: approval1.9.2.9+
Attachment #458207 - Flags: approval1.9.1.12?
Attachment #458207 - Flags: approval1.9.1.12+
Pushed to mozilla-1.9.2 for Firefox 3.6.9
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/04193f2b9f27

Pushed to mozilla-1.9.1 for Firefox 3.5.12
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/86f2d8629e56
status1.9.1: --- → .12-fixed
status1.9.2: wanted → .9-fixed
(In reply to comment #80)
> Thanks Robert, I really don't know how could I thank you enough. I owe you one!
It was a pleasure and thanks for tracking down the registry changes made by the other browsers. It made fixing this much easier.

Updated

5 years ago
Depends on: 842228
You need to log in before you can comment on or make changes to this bug.