Closed Bug 54059 Opened 22 years ago Closed 21 years ago

unable to edit the MIME type textfield

Categories

(SeaMonkey :: UI Design, defect, P2)

Tracking

(Not tracked)

VERIFIED FIXED
mozilla0.8

People

(Reporter: bugzilla, Assigned: bugs)

References

(Blocks 1 open bug)

Details

(Keywords: helpwanted, Whiteboard: relnote-user)

found this while trying to narrow down bug 53870... imo, this is unique from bug
51395, where the *extension* isn't at all editable. here you can at least type
within the MIME type textfield.

found this using 2000.09.25.08 opt comm bits on linux (modern skin) and the
mozilla bits of the same build id (classic skin). occurs in both new and
existing profiles (at least on the commercial side).

1. go to the Helper Apps panel in the Prefs dialog.
2. create a new mimetype (click the New Type button to bring up New Type
dialog). for example:
        Description: Feh
        File extension: feh
        MIME type: application/feh
        Application to use: [blank]
3. click OK. new type should appear in the File types list.
4. select that new type and click Edit...
5. go to the MIME type textfield and change it --eg, i changed it to
application/fehblahblah.
6. click the OK button to save and dismiss the Edit Type dialog.

*observe*: the File type list still displays it as application/feh

bring up the Edit Type dialog again, and observe that the MIME Type is still
application/feh --in fact, it remains unchange whether or not you save/dismiss
the preference dialog, or even btwn browser sessions.
kind of futile having a textfield whose changes won't "take" --nominating
pessimistically for beta3...mebbe fixed in rtm? (adding that "just in case". ;)
Keywords: correctness, nsbeta3, rtm
QA Contact: sairuh → shrir
nav triage team:
since a user can add and delete mime types, there is a reasonable work around.

Sarah, please verify this work around.  NEED INFO if this work around works to
make rtm determination.
Whiteboard: [nsbeta3-][NEED INFO]
Change to "RTM NEED INFO".
Priority: P3 → P2
Whiteboard: [nsbeta3-][NEED INFO] → [nsbeta3-][RTM NEED INFO]
 johng, yes, the workaround is ok. User will have to delete current entry and 
reenter everything to change the mime type. And this is not very good...
If that is the reasonable workaround then shouldn't I take
that form out so they will not try to edit it?

i'd really rather have the ablity to edit mime types fixed, rather than removed.
if you don't have enough time (understandable :), is there someone else (in
netscape, or not), who could fix this?
Keywords: helpwanted
I agree...
Minus.  We don't have a patch of this yet and it won't hold RTM.
Whiteboard: [nsbeta3-][RTM NEED INFO] → [nsbeta3-][rtm-]
relnote for RTM, unless someone out there has a fix.
Keywords: relnoteRTM
*** Bug 55360 has been marked as a duplicate of this bug. ***
Whiteboard: [nsbeta3-][rtm-] → [nsbeta3-][rtm-] relnote-user
I know this one has something to do with bug 57624 
and bug 58811, but I can't figure it the relationships.

Scott, can you help sort these out?
The workaround listed for this bug dosn't work because of Bug 57624.
Deleting helper aplications onlt half delete them.

Given that flaky and broken helper app controls were one of the most prominent  
complaints of 6.0, beta1 really shouldn't ship without this.
Keywords: nsbeta3, rtmnsbeta1
OS: Linux → All
Hardware: PC → All
Whiteboard: [nsbeta3-][rtm-] relnote-user → relnote-user
nav triage team:

Yes, we should fix for beta1.
Target Milestone: --- → mozilla0.8
*** Bug 58781 has been marked as a duplicate of this bug. ***
This gets set.
It shows up in the mimetypes file but never shows up in the text field.
I think it's a backend problem.
Giving to ben for more comment
Assignee: matt → ben
using the mozilla 0.7 release (built from the tarball) editing any part
of an existing mime type causes the browser to loose all information about
that mime type.  The only way I've been able to add mime type definitions
is to delete an entry (if it already exists) and add a new one (with ALL
fields filled in).  The mimeTypes.rdf file appears to retain the mime info
in question after an edit - but this file format is so bloated with duplicated
information in so many places it is very difficult to tell which XML fields
are important and which are not.  It sure would be nice to be able to hand
edit mimeTypes.rdf...
That problem's covered in bug 68105.
Depends on: 68105
pchen, should this go to you?
hey, this seems to be working now(today's trunk on all platforms). I can 
actually edit the mime type field and save it. Did someone fix this somewhere? I 
am marking RESOLVED/FIXED. Sairuh, would you want to verify this one ? Thx!
Status: NEW → RESOLVED
Closed: 21 years ago
QA Contact: shrir → sairuh
Resolution: --- → FIXED
This still does _not_ work for me on Linux with build 2001021309 and a new
profile (or with the old profile).
The MIME types field is still just a lable and, even if I could edit it, I
wouldn't be able to save the changes because of bug 68105.
Never mind. I was thinking that this was bug 51395. This bug indeed does look
like it's been fixed.
vrfy fixed using 2001.04.18.0x opt comm bits.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.