Closed Bug 540604 Opened 10 years ago Closed 10 years ago

[OOPP]Silverlight 3 does not play. User asked to upgrade/install

Categories

(Core :: Plug-ins, defect)

All
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: alice0775, Assigned: benjamin)

References

()

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2pre) Gecko/20100119 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20100119 Minefield/3.7a1pre ID:20100119045341

If dom.ipc.plugins.enabled is true,
Silverlight 3 is not play. 
It is promoted so that the player installs it.


Reproducible: Always

Steps to Reproduce:
1.Install Silverlight 3
2.Set dom.ipc.plugins.enabled to true and restart Minefield.
3.GO URL (  http://silverlight.net/learn/videos/all/how-do-i-improve-graphics-performance-using-cachemode/ )

Actual Results:  
Silverlight 3 is not play. It is promoted so that the player installs it.

Expected Results:  
Silverlight 3 should be play.
I just ran into this, setting to New.

today's m-c trunk build
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20100123 Minefield/3.7a1pre
Blocks: OOPP
Status: UNCONFIRMED → NEW
Ever confirmed: true
I wasn't sure what that description meant until I tested it too.  Basically, Silverlight works fine with ipc.enabled = false.  But following the STR, instead of the silverlight plugin playing the video, it actually shows "promotes" UI that wants the user to install silverlight, rather than playing as expected if silverlight is already installed.
Clarifying summary
Summary: [OOPP]Silverlight 3 is not play. It is promoted so that the player installs it. → [OOPP]Silverlight 3 does not play. User asked to upgrade/install
Could someone grab and attach a plugin log of this? https://developer.mozilla.org/en/Plugins/Logging
Attached file log
Attachment #423364 - Attachment mime type: application/octet-stream → text/plain
Assignee: nobody → benjamin
Status: NEW → ASSIGNED
Attachment #423535 - Flags: review?(jones.chris.g)
Attachment #423535 - Flags: review?(jones.chris.g) → review+
We might need to update the summary to include the new Silverlight 4 Beta.

Visit http://www.silverlight.net/content/samples/apps/facebookclient/ to download the Silverlight 4 Beta. Install it. Copy the np*.dll files from the Silverlight directory to the Minefield plugins directory. Restart the browser.

Go back to http://www.silverlight.net/content/samples/apps/facebookclient/ and it still wants you to install Silverlight and won't let you download the Facebook client.
Hardware: x86 → All
Version: unspecified → Trunk
http://hg.mozilla.org/mozilla-central/rev/d46a66a8c917
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
I have the latest nightly. I also have Silverlight 4 installed, according to about:plugins and the URL reported in this bug still says "Click to Install" Silverlight. Also, in my comment #7, that URL still says I need to install Silverlight 4 to get the Facebook client. Any and every site that needs Silverlight to function, has a "Click to Install" box on it somewhere. So I am re-opening this bug.

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20100128 Firefox/3.7a1pre
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Can you file a new bug about silverlight 4? This bug definitely fixed Silverlight 3 due to a specific cause, and I don't want to get the fixes confused when we start backporting for Lorentz.

Make it block bug "OOPP".
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Agreed as bug 542887 might even be about Silverlight 4* beta being incompatible and doesn't recognized Minefield or visa versa.

Verified the fix works using hourly built from cset:
http://hg.mozilla.org/mozilla-central/rev/035ca5e3ea54
You need to log in before you can comment on or make changes to this bug.