Last Comment Bug 541182 - Custom CSS cursor not working
: Custom CSS cursor not working
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Widget: Win32 (show other bugs)
: Trunk
: x86 Windows Vista
: -- normal (vote)
: mozilla1.9.3a2
Assigned To: Rob Arnold [:robarnold]
:
Mentors:
: 543691 555498 (view as bug list)
Depends on:
Blocks: 502710
  Show dependency treegraph
 
Reported: 2010-01-21 12:21 PST by Boris Zbarsky [:bz]
Modified: 2011-06-27 08:43 PDT (History)
14 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.7+
.7-fixed


Attachments
Testcase (2.45 KB, text/html)
2010-01-21 12:22 PST, Boris Zbarsky [:bz]
no flags Details
Remove GetSystemMetric check [Checkin: Comment 7] (1.71 KB, patch)
2010-02-16 15:03 PST, Rob Arnold [:robarnold]
jmathies: review+
dveditz: approval1.9.2.7+
Details | Diff | Review

Description Boris Zbarsky [:bz] 2010-01-21 12:21:52 PST
It looks like between 3.5 and 3.6 at least some uses of custom cursors broke.  Testcase is attached.  This is only a problem on Windows: on Mac they never worked and on Linux they seem to still be working.

Martijn, Ria, could one of you maybe hunt down the regression range for this?  Hovering over the little orange arrow should show a cursor that has a hand and the text "view gallery" in it.
Comment 1 Boris Zbarsky [:bz] 2010-01-21 12:22:56 PST
Created attachment 422813 [details]
Testcase
Comment 2 mdinger.bugzilla@gmail.com 2010-01-27 20:27:55 PST
I get this regression range:

works:
2009-07-28-04-mozilla-central
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2a1pre) Gecko/20090728 Minefield/3.6a1pre

broken:
2009-07-29-04-mozilla-central
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2a1pre) Gecko/20090729 Minefield/3.6a1pre
Comment 3 Boris Zbarsky [:bz] 2010-01-27 20:58:05 PST
Bug 502710 in that range looks pretty suspicious.  Rob, can you take a look at this, please?
Comment 4 Rob Arnold [:robarnold] 2010-01-27 21:13:05 PST
Rather suspicious, but it should have been just code movement and a smidge of refactoring. I will probably get to this next week - I don't think it would be tricky to find out why but I've been wrong about that before :)
Comment 5 Rob Arnold [:robarnold] 2010-02-16 15:03:17 PST
Created attachment 427222 [details] [diff] [review]
Remove GetSystemMetric check
[Checkin: Comment 7]

It seems that I added a sanity check that the given cursor size should not exceed the system icon size. The system cursor size is 32x32 so even that is not big enough. There is a check for the size along the existing codepath for setting cursors however there is other code using this helper function that does not have similar checks (the tab preview code iirc). However, I think that will fail gracefully so it should be ok just to go ahead and remove the check from the helper function.
Comment 6 Boris Zbarsky [:bz] 2010-02-17 09:08:16 PST
*** Bug 543691 has been marked as a duplicate of this bug. ***
Comment 7 Serge Gautherie (:sgautherie) 2010-02-23 20:46:01 PST
Comment on attachment 427222 [details] [diff] [review]
Remove GetSystemMetric check
[Checkin: Comment 7]


http://hg.mozilla.org/mozilla-central/rev/f59d3c5a7ac7
Comment 8 Mike Beltzner [:beltzner, not reading bugmail] 2010-03-17 13:05:39 PDT
Comment on attachment 427222 [details] [diff] [review]
Remove GetSystemMetric check
[Checkin: Comment 7]

I guess there's no way to automate that testcase?
Comment 9 Rob Arnold [:robarnold] 2010-03-27 19:31:39 PDT
*** Bug 555498 has been marked as a duplicate of this bug. ***
Comment 10 Elomir 2010-03-30 08:08:21 PDT
Broke again

While it worked indeed in a nightly build, it is broken again in 
rv:1.9.2.2 Gecko/20100316 Firefox/3.6.2
Just check the test case from the older comment.
Please check and resolve again! Thank you!
Comment 11 Rob Arnold [:robarnold] 2010-03-30 08:31:19 PDT
(In reply to comment #10)
> Broke again
> 
> While it worked indeed in a nightly build, it is broken again in 
> rv:1.9.2.2 Gecko/20100316 Firefox/3.6.2
> Just check the test case from the older comment.
> Please check and resolve again! Thank you!

The patch is still waiting approval to land on the 3.6 branch. Once it gets approval, it can land and you'll see it in the next Firefox 3.6 release.
Comment 12 j.j. 2010-05-07 18:20:23 PDT
Any reason why this gets no 1.9.2 approval?

If this will not land in 1.9.2, let me know. I'll have to update the MDC docs then.
Comment 13 Boris Zbarsky [:bz] 2010-05-07 19:18:55 PDT
Requesting blocking for this web functionality regression.
Comment 14 christian 2010-05-13 15:12:50 PDT
Comment on attachment 427222 [details] [diff] [review]
Remove GetSystemMetric check
[Checkin: Comment 7]

a=LegNeato for 1.9.2.5. Please ONLY land this on mozilla-1.9.2 default, as we
are still working on 1.9.2.4 on the relbranch
Comment 15 Marco Bonardo [::mak] 2010-06-24 12:24:02 PDT
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/d64dce8fb27c
Comment 16 Elomir 2010-07-08 07:09:51 PDT
1. "Platform: x86 Windows Vista", but also x86 Windows XP
2. "status1.9.2: .7-fixed" means, that version 1.9.2.7 will be fixed? That would be great, because (rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6 is not fixed yet.
3. Allowing bigger cursors (again) increases the importance (well, if one would call it importance at all) of resolving 
Bug 248718  - Tooltip generated by title attribute appears unappropriately compared to current cursor.  
as well as
Bug 296191  - Custom CSS cursors [cursor: url(...);] sometimes overlay the link tooltips [title="..."] ...

Thanks for your great work!
(And if this bug will be fixed in 1.9.2.7: Thanks for fixing!)
Comment 17 Boris Zbarsky [:bz] 2010-07-08 08:16:59 PDT
> 2. "status1.9.2: .7-fixed" means, that version 1.9.2.7 will be fixed?

Yes, unless there's another unscheduled firedrill release.

Note You need to log in before you can comment on or make changes to this bug.