The default bug view has changed. See this FAQ.

newsgroup filter from "create filter from message" is not created

RESOLVED FIXED in Thunderbird 3.1b2

Status

MailNews Core
Filters
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: rkent, Assigned: rkent)

Tracking

Trunk
Thunderbird 3.1b2
x86
Windows XP

Thunderbird Tracking Flags

(thunderbird3.0 .5-fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

7 years ago
From m.s.Thunderbird:
===
I have been running Thunderbird 2.0.23 and
I just installed Thunderbird 3.0.1 and I find
that message filters are not working.
Here are the steps which were taken.

while viewing any message from mozilla.support.thunderbird
Select Message > Create Filter From Message...
the "Filter Rules" window appears
Enter a (unique) name in the top window
select "Match any..."
Select From
Select Contains
leave 3rd window as is or enter as desired
Under "Perform these actions:"
from the drop down menu Select "Delete Message"
Click OK
"Filter Rules" windows dissolves and
"Message Filters" window appears
        (the new "unique" filter is not evident)
Click X to close Message Filters window
Click Tools > Message Filters...
and observe that the filter is not there.

Under Tb 2.0.23, the new created filter would appear
in the Tools > Message Filters... window
Thank you,
Charles
===

I (rkent) was able to reproduce this.
(Assignee)

Comment 1

7 years ago
The filter I believe is being created, but in the newsgroup not the server.
(Assignee)

Updated

7 years ago
Target Milestone: --- → Thunderbird 3.1b2
(Assignee)

Updated

7 years ago
Duplicate of this bug: 540890
(Assignee)

Comment 3

7 years ago
Created attachment 436024 [details] [diff] [review]
restore nntp case in FilterListDialog.js
Attachment #436024 - Flags: review?(dmose)
(Assignee)

Comment 4

7 years ago
Comment on attachment 436024 [details] [diff] [review]
restore nntp case in FilterListDialog.js

I was writing a long explanation of why I did was changing the root folder here, and the realized that that change is not necessary because the fixes in bug 537012 are upstream of this, and therefore I do not need them here. So I will redo this patch with just the change to nntp.
Attachment #436024 - Flags: review?(dmose)
(Assignee)

Comment 5

7 years ago
Created attachment 436066 [details] [diff] [review]
without changing the root server
Attachment #436024 - Attachment is obsolete: true
Attachment #436066 - Flags: review?(dmose)
(Assignee)

Comment 6

7 years ago
In bug 435804 (part of the de-RDF effort) the function getSelectedServerForFilters() was changed to return a server rather than a folder - and in the process just blew away the check that special-cases nntp to have filters be folder-specific. I reverted that decision so that it returns a folder again (and renamed it to reduce confusion), then restored that to its previous behavior with this line:

return (server.type == "nntp") ? msgFolder : rootFolder;

The rest of this patch is just renaming for clarity, plus some cleanup.

There is no existing test code for the filter list editor (though it would have been great if some was available prior to bug 435804, as I have already fixed many regressions from that and still have more to do). I don't think it is practical to implement it for this small bug.
Whiteboard: [needs review dmose]
Comment on attachment 436066 [details] [diff] [review]
without changing the root server

jminta is clearly the best reviewer for this change, since it's reverting what he did.  Happily, I was able to catch up with him, and he's graciously agreed to do it, so handing off.  Thanks, Joey!
Attachment #436066 - Flags: review?(dmose) → review?(jminta)

Updated

7 years ago
Whiteboard: [needs review dmose] → [needs review jminta]

Comment 8

7 years ago
Comment on attachment 436066 [details] [diff] [review]
without changing the root server

I think I've made my position clear on functions with only one caller, but that's a battle for another day.  Thanks for the catch, r=jminta
Attachment #436066 - Flags: review?(jminta) → review+

Updated

7 years ago
Whiteboard: [needs review jminta] → [needs landing]
(Assignee)

Comment 9

7 years ago
Comment on attachment 436066 [details] [diff] [review]
without changing the root server

Checked-in http://hg.mozilla.org/comm-central/rev/b7dedc7a90ae
Attachment #436066 - Flags: approval-thunderbird3.0.5?
(Assignee)

Updated

7 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Whiteboard: [needs landing] → [needs approval 3.05]
Attachment #436066 - Flags: approval-thunderbird3.0.5? → approval-thunderbird3.0.5+
(Assignee)

Comment 10

7 years ago
Comment on attachment 436066 [details] [diff] [review]
without changing the root server

http://hg.mozilla.org/releases/comm-1.9.1/rev/26c5f18d5713
(Assignee)

Updated

7 years ago
status-thunderbird3.0: --- → .5-fixed
Whiteboard: [needs approval 3.05]
You need to log in before you can comment on or make changes to this bug.