Form POST seems to randomly fail

RESOLVED FIXED

Status

()

--
major
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: walt, Unassigned)

Tracking

1.9.2 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

Using the "Submit" button on web pages seems to randomly fail with an error that looks like the form data did not get posted.  Hitting the back button and then pressing "Submit" a second time seems to always work.

This is a new issue, since the 3.6 upgrade a few days ago.

Reproducible: Sometimes

Steps to Reproduce:
1.Fill out a web form
2.Press the Submit button
3.
Actual Results:  
Server returns HTTP error suggesting no data was posted in the form

Expected Results:  
To continue on with the submission.
Does this also happen with an automatic login stored in a cookie?
Version: unspecified → 3.6 Branch
(Reporter)

Comment 2

9 years ago
No, it seems to happen only on new forms like when you are shopping online etc.  I have Firefox set to not memorize any forms data like addresses etc.

It also seems to happen more frequently when I hit the "Enter" key on the keyboard, vs clicking on the "Submit" button, which should perform the same action...
Component: General → HTML: Form Submission
Product: Firefox → Core
QA Contact: general → form-submission
Version: 3.6 Branch → 1.9.2 Branch
(Reporter)

Comment 3

9 years ago
This is starting to get annoying.  I am ready to go back to a prior version.

Almost every-other form I try to submit now, I have to do it twice.

Is there a debug mode I can turn on to capture what's going on?

-Walt
(Reporter)

Comment 4

9 years ago
Reverting back to 3.5.7 fixes this issue.

It's a bug in 3.6

-Walt

Comment 5

9 years ago
It usually fails on the first visiting of the web page. For example, I visited web A then post on the form, it failed. I reposted again, it worked. Then I closed browser, wait for a moment. After that for 2 hours, I could reproduced the same behavior on the same web A.
(Reporter)

Comment 6

9 years ago
Additional Info:

Bug does not seems to exist in the non-Intel version of the code?
3.6 running on my G4 (under Leopard) works fine.

So it might be the Intel code, or something to do with Snow Leopard.

-Walt
Do you mean bug 547239 ?
Please provide a Gecko HTTP log if not
(Reporter)

Comment 8

9 years ago
Yes, this does look like it could be the same bug.

-Walt
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 547239
If you're not seeing a dialog when the POST succeeds, then it's NOT the same as bug 547239.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Bug 547525 has some similarities.
(Reporter)

Comment 12

9 years ago
Agreed. I am not seeing any re-direct or extra dialog after a failed POST, but the behavior (not getting the POST data to the server) seems to be the same.

I am not running any debug mode or anything like that...

-Walt
Walt, are you using Firebug or some other extensions, by any chance?
Walt, one more question.  Is your Firefox profile or OS possibly set up to
use a proxy, or proxy autoconfig or anything like that?
(Reporter)

Comment 15

9 years ago
No proxy.  Only (2) plugins, but I've tested it with them removed and disabled as well. The 2 plugins are NoScript and Ad Block Plus.

At one time I did use Glimmer Blocker, but tested it without that as well.

-Walt
OK.

In terms of a debug mode to help capture what's going on, there is, in fact.  https://bugzilla.mozilla.org/show_bug.cgi?id=547396#c8 has some directions on capturing an HTTP log on Mac OS X.
I suspect the patch for bug 547239 will fix this.

To test that, can you go into Preferences > Advanced > Network, click the "Settings..." button in the Connection section, and select "No proxy"?  If you do that, does it help?  Or is it already selected?
Depends on: 547239

Comment 18

9 years ago
I'm getting the same thing. Randomly when posting to sites with forms in, it acts as though the page has been refreshed instead without posting anything. No error messages, or popups folliwng successful posts. The page simply refreshes. Back button and resubmit seems to work.

One thing I did notice - it happens more often on pages left open for more than 5 minutes. However, that may just be a coincidence in the pages I was looking at.
Walt, are you still seeing this with Firefox 3.6.2 or later?
(Reporter)

Comment 21

9 years ago
No, seems to be fixed now in version 3.6.3

-Walt
Great, thank you for checking!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.