Saving draft while connection is down causes message to be incorrectly copied to Sent folder

RESOLVED DUPLICATE of bug 257735

Status

Thunderbird
Message Compose Window
--
major
RESOLVED DUPLICATE of bug 257735
8 years ago
7 years ago

People

(Reporter: abcdzywx, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupme)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Build Identifier: version 2.0.0.23 (20090812)

For an IMAP account, when I save a draft message (such as with Ctrl-S) while the network connection is down (or interrupted in the middle), Thunderbird will report an error with copying the message to the Sent folder.  When it asks to retry, upon restoring the network connection and proceeding, Thunderbird will then save the message to both the Drafts folder and Sent folder, and it will deceptively appear that the message was sent unintentionally.  However, it appears that the message is not actually sent, just incorrectly copied to the Sent folder.

Reproducible: Always

Steps to Reproduce:
1. Compose a test message to a recipient such as yourself (without sending it).
2. Attempt to save a draft of the message either while the network connection down (or alternatively, once it starts saving, immediately cut-off your network connection (i.e. turn off Wi-Fi kill-switch on a laptop)).
3.  Click the "cancel" button on the dialog window if it doesn't change to an error message automatically.  At this point there should be a confirmation dialog saying "There was an error copying the message to the Sent folder.  Retry?"
4.  Restore the network connection, then click "OK".
Actual Results:  
A saved copy of the message will appear in both the Drafts folder and the Sent folder.

Expected Results:  
There should only be a message saved in the Drafts folder, not in the Sent folder.  Thunderbird should not have attempted to save to the "Sent" folder in the first place.

This IMAP account is managed with all folders on the server-side (not locally) including Sent and Drafts.
(Reporter)

Updated

8 years ago
Summary: Connection interruption while saving draft causes message to be incorrectly copied to Sent folder → Saving draft while connection is down causes message to be incorrectly copied to Sent folder

Updated

8 years ago
Whiteboard: dupme
AFAIK, there are already repoted problems around draft save.
- If "retry of save to Draft" fails,
  - message says "send failure", "failed to save in Sent",
  - tries to fall back to Sent,
- If fall back to Sent also fails, "retry or cancel" dialog loop happens
  until succesuful retry of fall back or cancel reply,
- As user can't know which dialog is for which retry, user has to reply
  Retry or OK to all dialog, then multiple copy of draft happens
  if fall back is successuful,
- If fall back is impossible(long IMAP server down and IMAP Sent folder),
  draft can not be saved, because user has to reply cancel,
- If "Send a copy to" is requested at compose window, copy is saved to the
  folder in addition to Drafts upon "Save as draft" or auto-save.
  if the copy-to folder is also IMAP folder, situation becomes worse.
See bug 486947(Sent=Inbox case) for procedure to reproduce above phenomena reliably. 

"Fall back to a local mail folder with asking which folder" is already requested. It's applicable to any of IMAP Drafts/Sent cases(server down, folder full, damaged) and local Drafts/Sent cases(folder full, damaged).

Comment 2

8 years ago
Just in case this helps: I also had this issue when (for some strange reason) the local folders (where the drafts_folder was set to) did not contain a "Drafts" folder.
Depends on: 257735
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 257735
You need to log in before you can comment on or make changes to this bug.