Run query on support-stage to clear livechat_id field

RESOLVED DUPLICATE of bug 541982

Status

mozilla.org Graveyard
Server Operations
--
critical
RESOLVED DUPLICATE of bug 541982
8 years ago
3 years ago

People

(Reporter: zzxc, Assigned: oremj)

Tracking

Details

(Reporter)

Description

8 years ago
After support-stage has been upgraded to head, a query should be run to clear any livechat_id fields from newly registered users before automatic migration starts.

The query to run is: UPDATE users_users SET livechat_id=NULL;

This query will also need to be run on production right before turning on migration, after 1.5.1 ships.
So.. is this bug dependent on 541982 ?
Assignee: server-ops → aravind
(Reporter)

Comment 2

8 years ago
This query should be run before the automatic migration is done.  (Running it after would undo the automatic migration)
So do you want it run right now, or should it wait until just before the migration?
Please re-open this if there is some pending action on our side.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Resolution: FIXED → INCOMPLETE
Matthew, please see comment 3.
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
(Reporter)

Comment 6

8 years ago
This query resets the login migration, so it needs to run before the migration script is executed on support-stage.

The same query will need to be executed on production before the migration happens there, but this will be a new bug.
(Assignee)

Updated

8 years ago
Assignee: aravind → jeremy.orem+bugs
(Assignee)

Comment 7

8 years ago
mysql> UPDATE users_users SET livechat_id=NULL;


Query OK, 149200 rows affected (11.86 sec)
Rows matched: 149739  Changed: 149200  Warnings: 0
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 541982
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.