Mouse Scrolling does not work after upgrading to Firefox 3.6

RESOLVED WORKSFORME

Status

()

Core
Widget: Win32
RESOLVED WORKSFORME
8 years ago
a year ago

People

(Reporter: Cww, Unassigned)

Tracking

(Blocks: 1 bug, {common-issue+})

1.9.2 Branch
All
Windows XP
common-issue+
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Scrolling (mouse/touchpad scrolling) doesn't work for a lot of people (mostly windows, a few unspecified).  The only constant is that downgrading to 3.5.7 seems to universally help.  The following also seems to help specific users but there are reports it doesn't help others:

1) Downloading fresh drivers/mouse software.  Namely a new Dell mouse driver software worked for at least one user.
2) Not trying to scroll on pages with flash/silverlight content.
3) added following line to "tp4table.dat ",*,firefox.exe,*,*,MozillaWindowClass,WheelVkey,0," (this seems related to broken touchpad scrolling)
4) Scrolling with external mouse doesn't work but touchpad does work (at least 3 people reported this)

As for constants: Mouse models are all over the map, a few microsoft ones, a few Dell ones at least one Logitech.  OSes are XP, Vista, Win7.

Some people are very specifically talking about autoscrolling which could be a different issue.

https://support.mozilla.com/en-US/forum/1/560811
https://support.mozilla.com/en-US/forum/1/561220
https://support.mozilla.com/en-US/forum/1/561601
https://support.mozilla.com/en-US/forum/1/561988
https://support.mozilla.com/en-US/forum/1/562070
https://support.mozilla.com/en-US/forum/1/562473
https://support.mozilla.com/en-US/forum/1/564238 

CCing people who worked on https://wiki.mozilla.org/Firefox/Projects/AcceleratedScrolling
(Reporter)

Updated

8 years ago
Keywords: common-issue+
The strictly way is going to be landed by bug 483136 which will be fixed only on trunk.
The regression of bug 487245 is going to be landed by bug 531341 which can be fixed 1.9.2 branch too.
Er, did you mean they cannot scroll on normal contents, i.e., there are no plug-ins?
The many comments don't have the information of their mice and their drivers.

We've changed our window class name by Widget Removal.

So, if mouse drivers are checking window class name, they could fail to scroll with Fx3.6. However, we're processing Windows' standard scrolling messages WM_MOUSESCROLL and WM_MOUSEHSCROLL. So, if mouse drivers send them to us, they don't have any problems.

Only for ThinkPad series, Kyle landed a hack. But looks like it's not enough for Lenovo mouse users (bug 507222 and bug 541836).

We hope all mouse drivers send the standard mouse scrolling messages :-(
For Trackpoint users, they can change ui.trackpoint_hack.enabled to 1 and that ought to get them working.  Lenovo may be working on a fix, they weren't very clear.

As for the rest of them, idk what we can do.  The problems stem from native widget reorganization and bad drivers that make now-incorrect assumptions about what our widget hierarchy looks like.
(Reporter)

Comment 5

8 years ago
Ok, can't scroll on plugins is bug 483136 -- so this bug should focus on not scrolling outside plugins.

Looks like it's a whole mess of issues -- I'll go through and work up a draft set of recommendations for users who can't scroll tomorrow.
For at least one user on Live Chat, a scrolling problem was caused by an old version (v11) of the Synaptics touchpad driver for Windows.  In that case, touchpad scrolling worked while the scrollwheel of an attached mouse had no effect.

This user upgraded the synaptics driver to v14, and hasn't replied back since.  (I assume this solution worked, but I have no confirmation)
See also Bug 541558.
Blocks: 541558
Masayuki: any way you can determine if the old (v11) Synaptics driver is checking the window class name? Is that something older drivers are likely to do?

cc'ing Jimm and Rob Arnold.
(In reply to comment #8)
> Masayuki: any way you can determine if the old (v11) Synaptics driver is
> checking the window class name? Is that something older drivers are likely to
> do?
> cc'ing Jimm and Rob Arnold.

It's extremely likely, as it's what the Trackpoint driver does, and it's written by synaptics.  See Bug 507222.

Comment 10

8 years ago
We have a Silverlight application, www.FreeStockCharts.com, that lets you zoom in and out on the chart using the mouse scroll wheel.  This stopped working when Firefox 3.6 was installed.  I've got confirmed reports from dozens of our customers having the same issue.  Scrolling works fine in 3.5.8 so we've been telling our customers to go back to that version if they want to use Firefox (our app also runs in IE and Safari).
This will likely be fixed by bug 531341.
Blocks: 20618

Comment 12

8 years ago
(In reply to comment #11)
> This will likely be fixed by bug 531341.

Masatoshi are you referring comment 10 only, or this bug?
Mouse scroll works for me on latest Nightly 50.0a1, 20160720030208
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.