outdent and indent doesn't work properly.

VERIFIED FIXED in mozilla0.9.2

Status

()

Core
Editor
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Nasiruddin M.S, Assigned: Joe Francis)

Tracking

Trunk
mozilla0.9.2
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [behavior]suntrak-n6 [QAHP] fix in hand, a=asa, URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Build id :2000090720
platform  : solaris2.8(intel)

(1) open composer in netscape communicator.
(2) type some text, move it to right using 'indent' icon. The text moves to the
right.
(3) press enter. type some text. Now try to move the text (only last line
text)to the left using outdent. The text doesn't move to the left.

This bug is simillar to Bug id 8436 and 38253. Though those bugs are fixed, it
is not working on the platform specified above.

Comment 1

18 years ago
setting to future.

anthonyd
Target Milestone: --- → Future

Comment 2

18 years ago
asked Sujay to please test on solaris to see the extent of the issue. reassign
to cmanske
Assignee: beppe → cmanske
Keywords: correctness

Comment 3

17 years ago
worksforme on windows....I don't ahve a Solaris build.

Comment 4

17 years ago
Akkana - can you test on Solaris?
Assignee: cmanske → akkana

Comment 5

17 years ago
No, I don't have a solaris build.  I've tried to get one, but we no longer seem
to have a machine capable of building mozilla.
Assignee: akkana → cmanske

Comment 6

17 years ago
I have another testcase which also demonstrates a bug with indent and outdent.

Select a paragraph.
Press the indent button twice.
Now try to return the paragrph to the original indentation - press the outdent
button twice

You can't, because after you press the outdent button once, it grays itself out.

In other words, you can only outdent a paragraph once.
(Reporter)

Updated

17 years ago
Whiteboard: suntrak-n6

Comment 7

17 years ago
The problem occurs when testing if we can outdent, in
nsHTMLEditRules::GetIndentState().
The test nsHTMLEditUtils::IsBlockquote(curNode) returns false, probably because
of the <br>. The HTML described in the bug test is:
<blockquote> Some text on the first line, then press enter<br>
so this text is on a second line.
</blockquote>
The second line is a text child of the <br>, not <blockquote>, so it thinks
we can't outdent.
Joe: Should these tests climb up the parent chain to find list and blockquote
tags?
Assignee: cmanske → jfrancis
(Assignee)

Comment 8

17 years ago
moz 0.9
Status: NEW → ASSIGNED
Target Milestone: Future → mozilla0.9
(Assignee)

Comment 9

17 years ago
moving a bunch of 0.9 bugs to 0.9.1
Target Milestone: mozilla0.9 → mozilla0.9.1

Comment 10

17 years ago
*** Bug 61270 has been marked as a duplicate of this bug. ***

Comment 11

17 years ago
*** Bug 68280 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Whiteboard: suntrak-n6 → suntrak-n6 [QAHP]

Comment 12

17 years ago
Looks like the indent feature is grayed out on win NT platform. I tried this out
on mozilla nightly build: 2001041704. Updating the bug platform/OS category to
win NT
OS: Solaris → Windows NT
Hardware: Sun → PC
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.1 → mozilla0.9.2

Comment 13

17 years ago
*** Bug 57715 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Whiteboard: suntrak-n6 [QAHP] → [behavior]suntrak-n6 [QAHP]
(Assignee)

Comment 14

17 years ago
attaching patch which will enable outdent correctly.  Note that outdent behavior
is still a bit odd, but at least you can get it to outdent in cases like the one
above.
Whiteboard: [behavior]suntrak-n6 [QAHP] → [behavior]suntrak-n6 [QAHP] partial fix in hand
(Assignee)

Comment 15

17 years ago
Created attachment 36299 [details] [diff] [review]
patch for editor/base/nsHRMLEditRules.cpp

Comment 16

17 years ago
Typo:
+    // of selection endpoints.  We might have a bolckquote or list item 
r/sr=sfraser

Updated

17 years ago
Whiteboard: [behavior]suntrak-n6 [QAHP] partial fix in hand → [behavior]suntrak-n6 [QAHP] partial fix in hand, need a=

Comment 17

17 years ago
r=kin@netscape.com

Comment 18

17 years ago
a= asa@mozilla.org for checkin to the trunk.
(on behalf of drivers).  Can we keep this bug open or file another one for the
remaining issues. Thanks.

Updated

17 years ago
Blocks: 83989

Updated

17 years ago
Whiteboard: [behavior]suntrak-n6 [QAHP] partial fix in hand, need a= → [behavior]suntrak-n6 [QAHP] fix in hand, a=asa

Comment 19

17 years ago
Asa, I'm not sure we should keep this bug open.  It might be easier to track 
remaining issues in new/separate bugs so it'll be easier to verify.
(Assignee)

Comment 20

17 years ago
fix checked in.  i will open new bug for remaining issues.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 21

17 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 22

17 years ago
this is fixed, however we have another problem...see bug 17994
You need to log in before you can comment on or make changes to this bug.