Closed Bug 542325 Opened 12 years ago Closed 11 years ago

Click on a input element in a form submits it opening a new browser tab

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 533545

People

(Reporter: willyaranda, Unassigned)

References

()

Details

(Keywords: testcase, Whiteboard: [gs])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; es-ES; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; es-ES; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

When I click on a input form that it is in an email, the form submits all values and open the webpage that it's the action on the <form> tag:

<form name="f" action="http://www.feriayecla.com/enviarinvitacion.php"
 method="post" enctype="multipart/form-data">



Reproducible: Always

Steps to Reproduce:
1. Open an HTML mail with a form in it
2. Click on any input element to write something
3.
Actual Results:  
A new page is opened in the default browser sending all elements of the form.

Expected Results:  
Should not submit the form until I click on the "Submit" Button

Reporting it because I have received some complains in Mozilla Hispano forums.
Confirming with:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a1pre) Gecko/20100126 Shredder/3.2a1pre
Component: General → Toolbars and Tabs
QA Contact: general → toolbars-tabs
Post or get are affected this issue should be the post one.
Status: UNCONFIRMED → NEW
Ever confirmed: true
See Also: → 533545
Hi,

We have also identified this issue.  Any form items submits an empty form to the form address (No data sent with the form).
Duplicate of this bug: 540583
Component: Toolbars and Tabs → Mail Window Front End
Keywords: testcase
QA Contact: toolbars-tabs → front-end
The apparent fix: line 115 of /mail/base/content/contentAreaClick.js 
====
  let href = hRefForClickEvent(aEvent);
====
change it to
====
  let href = hRefForClickEvent(aEvent, true);
====

Hard to tell whether this behavior was intentional or overlooked.
Tyomich want to submit a patch ?
This is actually a duplicate of bug 533545 and we're discussing a possible patch over there.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 533545
You need to log in before you can comment on or make changes to this bug.