Problems accessing ftp server using War FTP Server v1.65

VERIFIED DUPLICATE of bug 54626

Status

()

P3
normal
VERIFIED DUPLICATE of bug 54626
18 years ago
17 years ago

People

(Reporter: law, Assigned: mozilla)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood+], URL)

(Reporter)

Description

18 years ago
I can't use Mozilla to access my WinNT box via ftp.  That machine is using
the War FTP freeware ftp server.

I can view a directory listing, e.g., entering in the location bar
"ftp://law.mcom.com".  Double clicking a file in that listing (e.g., "big.xxx")
produces the "Unknown File Type" dialog.  I choose "Save file..." on that dialog
and pick a destination file.  Then I get an alert with "Unknown error [ 1
80004005]".  The crappy alert text is my fault, but the cause is due to bogus
response from the ftp channel.  It is giving me an error on a call to
OnStopRequest (I believe).  This text is spit out to the console: "Error loading
URL ftp://law.mcom.com/d/dropbox/big.xxx: 804b0002".  Things crash at that point
(due to bug in buffered streams, see bug 35161).

I can do this with no problem using Communicator or IE so it might not be the
FTP server.
(Reporter)

Comment 1

18 years ago
Marking this dogfood because I really need to access my WinNT machine to
transfer files between my various machine.
Keywords: dogfood
(Reporter)

Comment 2

18 years ago
I noticed that the "Error loading URL...804b0002" message is coming at the point
I double-click on the file in the directory listing (i.e., as it is attempting
to load in the browser).

Comment 3

18 years ago
->rjc
Assignee: gagan → rjc

Comment 4

18 years ago
I'll mark this as dogfood to facilate your work... but if your ftp server seems
to be non-standard and the source of the problem, we need to get this off the
dogfood radar (and get you a new ftp server!).
Whiteboard: [dogfood+]
(Assignee)

Comment 5

18 years ago
This is really a DUP of 54626... which I just attached a proposed fix to.  Bill, 
feel free to apply the fix and try it out.


*** This bug has been marked as a duplicate of 54626 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
verif DUP
Status: RESOLVED → VERIFIED

Updated

17 years ago
Component: Networking → Networking: FTP
You need to log in before you can comment on or make changes to this bug.