Choosing "Save Page As" to a read-only destination crashes

VERIFIED FIXED in mozilla0.8

Status

Core Graveyard
File Handling
P2
normal
VERIFIED FIXED
18 years ago
2 years ago

People

(Reporter: Miguel Covarrubias, Assigned: Bill Law)

Tracking

Trunk
mozilla0.8
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-][PDTP2][rtm-]Fix in hand, reviewed and approved)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.5-15 i586; en-US; m14)
BuildID:    2000040616

Trying to save a file to a directory where I don't have permissions
produces a succession of Alert boxes saying "Unknown error".  After
about three of these Alerts, Mozilla crashes.


Reproducible: Always
Steps to Reproduce:
1.Try to download a file to a directory without write permissions
2.
3.

Actual Results:  Three uninformative Alerts went up and Mozilla crashed.


Expected Results:  Put up an informative Alert and put up the file chooser
dialog again for the user to select a writable place to put the file.

Comment 1

18 years ago
this is a variant of bug 27609 but the crash is new. (27609 was a leftover from
bug 23821 where mozilla actually was hanging. Marked fixed 2000-02-10)

Comment 2

18 years ago
-> networking
Assignee: asadotzler → gagan
Status: UNCONFIRMED → NEW
Component: Browser-General → Networking
Ever confirmed: true
QA Contact: jelwell → tever

Comment 3

18 years ago
->law
Assignee: gagan → law

Comment 4

18 years ago
*** Bug 36534 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
Adding crash keyword.
Keywords: crash

Updated

18 years ago
Target Milestone: --- → M18

Comment 6

18 years ago
Move to M21 target milestone.
Target Milestone: M18 → M21
(Assignee)

Comment 7

18 years ago
Upping to M18; this is bad and should be relatively easy to remedy.
Status: NEW → ASSIGNED
Target Milestone: M21 → M18

Comment 8

18 years ago
*** Bug 45629 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
*** Bug 47751 has been marked as a duplicate of this bug. ***

Comment 10

18 years ago
*** Bug 47071 has been marked as a duplicate of this bug. ***

Comment 11

18 years ago
Nav triage team: Changing summary to something we understand; [nsbeta3+]
Summary: fdirectory permissions on save causing crash → Choosing "Save Page As" to a read-only destination crashes
Whiteboard: [nsbeta3+]
(Assignee)

Comment 12

18 years ago
Marking P1.
Priority: P3 → P1

Comment 13

18 years ago
PDT downgrading to P2 and putting [PDTP2] in status whiteboard
Priority: P1 → P2
Whiteboard: [nsbeta3+] → [nsbeta3+][PDTP2]
(Assignee)

Updated

18 years ago
Blocks: 50326
(Assignee)

Comment 14

18 years ago
I have two minor patches which avoid the crash.  Waiting for Warren to OK the 
buffered streams one.

Index: nsStreamXferOp.cpp
===================================================================
RCS file: /cvsroot/mozilla/xpfe/components/xfer/src/nsStreamXferOp.cpp,v
retrieving revision 1.32
diff -w -r1.32 nsStreamXferOp.cpp
330a331
>                     break;
333a335
>                 break;

Index: base/src/nsBufferedStreams.cpp
> ===================================================================
> RCS file: /cvsroot/mozilla/netwerk/base/src/nsBufferedStreams.cpp,v
> retrieving revision 1.8
> diff -r1.8 nsBufferedStreams.cpp
> 335a336,339
> >     if (!mStream) {
> >         // Stream already cancelled/flushed; probably because of error.
> >         return NS_OK;
> >     }

Comment 15

18 years ago
*** Bug 49919 has been marked as a duplicate of this bug. ***

Comment 16

18 years ago
Move to RTM.
Keywords: rtm
Whiteboard: [nsbeta3+][PDTP2] → [nsbeta3-][PDTP2][rtm+]

Comment 17

18 years ago
Adding patch keyword.
Keywords: patch

Comment 18

18 years ago
PDT marking [rtm need info] since no code reviews are listed.
Whiteboard: [nsbeta3-][PDTP2][rtm+] → [nsbeta3-][PDTP2][rtm need info]
(Assignee)

Comment 19

18 years ago
Created attachment 16135 [details] [diff] [review]
Comprehensive patch for this bug and also 48620, 50697, and 42173)

Comment 20

18 years ago
Fix in hand.
Whiteboard: [nsbeta3-][PDTP2][rtm need info] → [nsbeta3-][PDTP2][rtm need info]Fix in hand
(Assignee)

Comment 21

18 years ago
*** Bug 50697 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 22

18 years ago
r=mcafee

I'm deeming myself module owner for the xfer stuff, and I approve it.

Going to mscott for super-review (he knows this stuff).
(Assignee)

Comment 23

18 years ago
*** Bug 48620 has been marked as a duplicate of this bug. ***

Comment 24

18 years ago
Hey Bill, your patch looks great to me. I assume the changes to getString that
you made fix the exception errors that get thrown every now and then?

Also, I take it you have approval from I10N for the localization changes?
Assuming that's cool...
sr=mscott
(Assignee)

Comment 25

18 years ago
Yes, getString was barfing when fetching "unknownTime" and I fixed that as well.

You are right about the l10n clearance on the new strings.  We're working on it.

Thanks.

Comment 26

18 years ago
Adding cc to L10n folks ...

Comment 27

18 years ago
You can assume now that it's cool with L10n :-) Approved.

Comment 28

18 years ago
Adding myself to cc: list.

Comment 29

18 years ago
r=mcafee and sr=mscott

PDT, please approve.
Whiteboard: [nsbeta3-][PDTP2][rtm need info]Fix in hand → [nsbeta3-][PDTP2][rtm+]Fix in hand, reviewed and approved

Comment 30

18 years ago
rtm-, this is much bigger than a breadbasket.  Is there a very very small fix
that makes the crash go away?
Whiteboard: [nsbeta3-][PDTP2][rtm+]Fix in hand, reviewed and approved → [nsbeta3-][PDTP2][rtm-]Fix in hand, reviewed and approved
(Assignee)

Comment 31

18 years ago
Yes.  The simple patch to nsBufferedStream.cpp (posted to description a long
time ago) will stop the crash 99.9% of the time.  The additional "break"
statements to nsStreamXferOp.cpp will stop the crash in the other .1% of the time.

The message box would still suck, though.

Comment 32

18 years ago
on my linux debug branch build of today when I try to save a file to
/junk.hmtl it pops up a dialog saying "Unknown error [3 80004005]".

I note the "Saving File" dialog shows the saving "To:" as "//unk.html"
which is missing the leading "j".

(Assignee)

Comment 33

17 years ago
Gotta fix this one.  I have the patch but it doesn't work any more :-(.  Should
be relatively easy to get it back in gear.
Keywords: crash, patch, rtm → nsbeta1
(Assignee)

Updated

17 years ago
Target Milestone: M18 → mozilla0.8
(Assignee)

Comment 34

17 years ago
Setting target milestone.

Comment 35

17 years ago
*** Bug 64924 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 36

17 years ago
Created attachment 22691 [details]
test
(Assignee)

Comment 37

17 years ago
This has been fixed.  There is still a problem handling this error in many 
cases, though; see bug 67216.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Updated

15 years ago
QA Contact: tever → benc

Updated

15 years ago
Component: Networking → File Handling
QA Contact: benc → petersen

Comment 38

15 years ago
Verified on the linux 2003-01-23-05 trunk.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.