"Sending of message failed. There was an error attaching .[sic] Please check if you have access to the file." caused by ReFwdFormatter add-on

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
--
major
RESOLVED INVALID
8 years ago
3 years ago

People

(Reporter: Buford T. Justice, Unassigned)

Tracking

All
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [add-on])

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.7) Gecko/20100111 Lightning/1.0b2pre Thunderbird/3.0.1

Also still present in 2.0.0.23 (and previous versions).

When an e-mail is received with an inline attachment to where the image is
displayed within the e-mail, hitting REPLY will cause the reply message to not
display the image and give the error...

"Sending of message failed.  There was an error attaching .[sic]  Please check
if you have access to the file."

Using FORWARD instead of REPLY displays the inline image properly and allows
the e-mail to be sent.

This need to be fixed both in 2.0 and 3.0.

Also there is a grammar error in the error message quoted above.  There is an
extra space before the period of the second sentence.

Reproducible: Always

Steps to Reproduce:
1. Click REPLY to an e-mail that has an inline attachment.
2. You will see the inline image is not shown though the border for the image is shown.
3. Click SEND.
4. The error message will appear.
Actual Results:  
The message with the inline image(s) will not be sent using REPLY.

Expected Results:  
The message with inline images should be sent using REPLY.

When using FORWARD instead of REPLY, the message will be sent fine.  This is the behavior expected when using REPLY.
The grammar error likely has to do with the inability of Thunderbird to find the right image to include, e.g. "There was an error attaching ''.", where '' is an empty path.

I'm unable to reproduce, though, with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20100111 Lightning/1.0b1 Thunderbird/3.0.1 ThunderBrowse/3.2.8.1 ID:20100111101938 (Windows Vista x86), using IMAP. Are you perhaps using POP3?

It might also be good if you could attach the problem message, suitably redacted, to this bug. (Save the message as .eml, edit in some way, probably with Thunderbird, to remove anything you don't want seen, then attach.)
Version: unspecified → 3.0
(Reporter)

Comment 2

8 years ago
Yes I am using POP3.

An example e-mail is attached.
Version: 3.0 → unspecified
(Reporter)

Comment 3

8 years ago
Created attachment 424146 [details]
Example Inline Picture Message
(Reporter)

Comment 4

8 years ago
The example allows a reply or forward to be sent, but the pictures are not shown in either.

A better way to reproduce this problem would be to compose a new message.  Click INSERT > IMAGE and select a couple of pictures.  I don't use alternative text.  Send the e-mail to an e-mail account you can access to in Thunderbird.  Once you receive the e-mail, hit REPLY and you will see what I have been saying.

Comment 5

8 years ago
Buford,
Your sample eml does not have a Content-Disposition set on the image parts.

Was it composed in your Thunderbird 3.0.1
Could you try in safe-mode. (http://kb.mozillazine.org/Safe_mode)
Lastly, in configEdit key in "disposition" in the filter pane (no quotes)
mail.content_disposition_type should be set to 1
JoeS, I can't reproduce this with either setting of mail.content_disposition_type -- Content-Disposition is set either way.

Comment 7

8 years ago
My reference to the pref was to see if the OP had incorrectly set the pref
since the testcase has no Content-Disposition.(some illegal value)

I haven't actually tried various values. Most likely the testcase was originally
composed with some other mail program other than TB/SeaMonkey.
(Reporter)

Comment 8

8 years ago
mail.content_disposition_type is set to the default of 1.

The message was composed in TB 3.0.1.

I tried it in safe mode and got the same result as the message already attached here.

The best way to reproduce this problem is to compose a new message. 
Click INSERT > IMAGE and select a couple of pictures.  I don't use alternative
text.  Send the e-mail to an e-mail account you can access to in Thunderbird. 
Once you receive the e-mail, hit REPLY and you will see what I have been
saying.  I can reproduce this problem every time using this method.
Buford,
The problem we're having, though, is that neither I nor (apparently) JoeS are able to reproduce this at all, with any of the settings or tweaks or steps-to-reproduce suggested.

What type of accounts do you have -- IMAP or POP3? What are your compose settings like (e.g. Send Options under Composition)? Can you take screenshots of every step, just before moving to the next step (i.e. take a screenshot of the Insert Image window just before clicking OK)?
Version: unspecified → 3.0
(Reporter)

Comment 10

8 years ago
Here is an example video of what the error is...

http://www.youtube.com/watch?v=8DcbApsS3FA

Comment 11

8 years ago
Nice Demo
The problem is definitely the lack of a Content-Disposition on the image parts.
I don't have a windows 7 system handy at the moment, but the file picker looks
very different from Winxp.(no thumbnails, just a file list)
If there is a view option to display as list, rather than icons, you might try
that. 
Also, to prove that it is the file picker causing the problem, compose another
message, but don't send it, instead use File>>Send Later. Then open it from the
Outbox and then View>>Message source.

Incorrect:
--------------040904020502020401020402
Content-Type: image/jpeg
Content-Transfer-Encoding: base64
Content-ID: <part1.01090909.00040607@gmx.net>

Should look something like this:
Content-Type: image/gif;
 name="2cool.gif"
Content-Transfer-Encoding: base64
Content-ID: <part1.06030808.06090403@bellatlantic.net>
Content-Disposition: inline;
 filename="2cool.gif"
(Reporter)

Comment 12

8 years ago
There is an option to view as list in the file picker.  Using the list option, here is what comes up in Message Source...

--------------080209080700030409080708
Content-Type: image/jpeg;
 name="3DFXFLAG.jpg"
Content-Transfer-Encoding: base64
Content-ID: <part1.06070102.00050301@gmx.net>
Content-Disposition: attachment;
 filename="3DFXFLAG.jpg"

--------------080209080700030409080708
Content-Type: image/jpeg;
 name="nvidia_on.jpg"
Content-Transfer-Encoding: base64
Content-ID: <part2.01040905.02060001@gmx.net>
Content-Disposition: attachment;
 filename="nvidia_on.jpg"

So I have Content-Disposition, but mine are as attachment instead of inline.
(Reporter)

Comment 13

8 years ago
The view options in the file picker don't seem to make a difference.  Using what I used in the video...

--------------050500020606060207000408
Content-Type: image/jpeg;
 name="3DFXFLAG.jpg"
Content-Transfer-Encoding: base64
Content-ID: <part1.08040204.01050504@gmx.net>
Content-Disposition: attachment;
 filename="3DFXFLAG.jpg"

--------------050500020606060207000408
Content-Type: image/jpeg;
 name="nvidia_on.jpg"
Content-Transfer-Encoding: base64
Content-ID: <part2.06090608.03090808@gmx.net>
Content-Disposition: attachment;
 filename="nvidia_on.jpg"
(Reporter)

Comment 14

8 years ago
If I change mail.content_disposition_type to 2, it becomes Content-Disposition: inline; but replying still gives the same error as shown in the video.

Comment 15

8 years ago
To summarize:
The content-disposition of inline vs. attachment is irrelevant to this bug
 (that was changed in a later TB3 build)
 
Content-disposition of some state (attachment/inline) is required in reply      (demonstrated in your testcase and tested here in winxp)

Please provide an eml testcase with your view prefs in windows7 using list.
If that works for me, that points to a specific issue in Windows7, as the
content would now be the same winxp vs windows7, yet the behavior different.
That is, in the case of a reply.

Thanks for following through with the bug analysis.
(Reporter)

Comment 16

8 years ago
What is the best way to save a message as a .eml file in TB 3.0.1?  It seems like mine wants to save messages as .html files.
(Reporter)

Comment 17

8 years ago
Created attachment 424441 [details]
Example Inline Picture Message 2
(Reporter)

Comment 18

8 years ago
I am not sure if the new attachment will work as it displays a different behavior in that it will not show the images when forwarding.

Comment 19

8 years ago
Created attachment 424447 [details]
composed in winxp

Ok this example works fine in a reply
I can't see the difference from the original demo eml
All I did was just save, then re-insert the images, now reply works fine.

I'll take a look tomorrow, seems I'm missing something here.
(Reporter)

Comment 20

8 years ago
I think the basic problem is why doesn't it work in replying but works fine in forwarding?
Keywords: testcase

Comment 21

8 years ago
Buford, I took the liberty of sending you a private email to test.
Seems that starting with an eml might be causing other problems.
Keywords: testcase

Comment 22

8 years ago
OK the message I sent to Buford (with the correct Content-Disposition)
Did not solve his problem (same symptoms)
Wayne, If you have access to a Windows7 system, could you check this.
(Reporter)

Comment 23

8 years ago
I figured out what was causing this issue.  I have to go into detail to explain it.

I hate the quote bars when replying to messages, so I used this fix to correct it...

http://kb.mozillazine.org/Quote_bars

In TB 2.0, I had to use the extension "ReFwdFormatter" to get rid of other annoyances such as the [ ] used in the subject line when forwarding.

In TB 3.0, I had to use the same extension for a different reason.  [ ] is no longer used in forward subjects in TB 3.0 (thank God), but using the "Quote Bars" fix above doesn't completely eliminate quote issues as it does in TB 2.0.  The "Quote Bars" fix used in TB 3.0 causes a very slight indent of the quoted message whereas this indent doesn't happen in TB 2.0.

So anyway back to the "ReFwdFormatter" extension.  ONE OPTION in this extension caused the error.  Going to the extension's options and unchecking "Remove the '|' prefix from quote in html mail." corrected this issue.

I would almost bet other bugs related to this are caused by an extension in some way.  The extensions are what make Thunderbird shine, but they can also turn it to ****, lol.

Thank you all for your help with this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 24

8 years ago
No problem, I should have suggested safe mode from the git go
WFM rather than fixed.
Resolution: FIXED → WORKSFORME

Comment 25

8 years ago
based on comment 23 we want resolution INVALID.
WORKSFORME implies something changed in thunderbird such that you can't reproduce, which is not the case.
Resolution: WORKSFORME → INVALID
Summary: "Sending of message failed. There was an error attaching .[sic] Please check if you have access to the file." → "Sending of message failed. There was an error attaching .[sic] Please check if you have access to the file." caused by ReFwdFormatter add-on
Whiteboard: [add-on]

Comment 26

6 years ago
This is 2012 and this bug is still very much alive. This has been a huge problem in Thunderbird (Mac) for years and I can't solve it. I have had to forgo many very important business or personal emails because they simply wouldn't send with the attachments or photos. Isn't this a basic service that all email programs should provide? I can't change email providers because so many thousands of email in TB. Please help Thunderbird, in layperson's language. Is there a solution? Thank you for help. I am in MAC if that makes any difference, Imac OS 10.6.8

Comment 27

4 years ago
It's 2014 and I'm now getting this bug on Windows 7 x64 and Thunderbird 24.4.0.  Both of my mail accounts are IMAP if that helps.  I was also resuming drafts in the morning.  I've attached the exact same type of PDF's hundreds of times as I've billed clients from Thunderbird.  They're spreadsheets exported from Excel 2007.

Comment 28

4 years ago
I converted my email format to plain text and it sent no problem, but this is still an annoying bug.

Comment 29

3 years ago
For the less techy peeps out there.
I have found a work around for this problem.
I had copied phone numbers  into my email message. The page then called for the skype png file to send (with skype click to call tags presumably). I should think this applies to any invisibly embedded links not readily identified.
The work around is to cut the entire message out of the email message pane. Paste into MS Notebook and then cut and paste back into Thunderbird into a new mail message. 
A bit crude but it works. It appears to purge any hyperlinks or associations.
I think Thunderbird lacks some type property dialogue and this might be where the community could improve usability.
I would assume the same workaround might be good on Apple iOS as well.

Comment 30

3 years ago
Same problem on debian wheezy thunderbird 31.2.0

When paste as quote does nothing, soon cut and paste on geany and paste as quote on Thunderbird and does correctly.

Comment 31

3 years ago
Same problem with Win 7 and TB 31.7.0 ... Needs resolution, Thunderbird people...
You need to log in before you can comment on or make changes to this bug.