Closed Bug 542897 Opened 10 years ago Closed 10 years ago

[OOPP] Random sized black boxes randomly appear/disappear in silverlight content areas

Categories

(Core :: Plug-ins, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED

People

(Reporter: u88484, Assigned: jimm)

References

()

Details

Attachments

(1 file)

On http://silverlight.net/, random sized black boxes randomly appear/disappear in the silverlight content area.  No content is actually shown though.

STR:
1) Install silverlight 3 or 4 beta
2) Go to http://silverlight.net/
3) Watch the black boxes randomly appear/disappear
Summary: [OOPP] Random sized black boxes bounce randomly appear/disappear silverlight content area → [OOPP] Random sized black boxes bounce randomly appear/disappear in silverlight content areas
Summary: [OOPP] Random sized black boxes bounce randomly appear/disappear in silverlight content areas → [OOPP] Random sized black boxes randomly appear/disappear in silverlight content areas
Assignee: nobody → jmathies
I can reproduce this in the latest 3.7 nightly. I'm also on Windows 7 x64. I'm using Silverlight Version: 3.0.50106.0, if that matters.
I can't reproduce this anymore, can anyone else?
It no longer is a bunch of random black boxes for me in the latest nightly.

The Silverlight Showcase still doesn't ever actually load. (It's perpetually stuck on the "Loading Showcase" screen.)

Also, on the front page of Silverlight.net, it does not detect that I have Silverlight installed (offers me a download).

Disabling OOPP lets both of those things work properly.
(In reply to comment #3)
> Also, on the front page of Silverlight.net, it does not detect that I have
> Silverlight installed (offers me a download).

Bug 542887
I'm now back to random black boxes on the latest nightly.
This is windowless silverlight.
Comment on attachment 425827 [details] [diff] [review]
ignore return value

Silverlight returns false even if it paints, just copy the result over regardless.
Attachment #425827 - Flags: review?(bent.mozilla)
Attachment #425827 - Flags: review?(bent.mozilla) → review+
http://hg.mozilla.org/mozilla-central/rev/ce81afdf4e40
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Verifying fixed using today's nightly:
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.