slow Thunderbird when opening an email on windows while npOGPPlugin.dll extension from ogplanet.com is installed (Game Launcher)

RESOLVED INVALID

Status

Thunderbird
General
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: René Schümann, Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2) Gecko/20100115 Firefox/3.6 GTBDFff GTB7.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1 ThunderBrowse/3.2.8.1

When the game launcher from ogplanet.com is installed (regkey HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins\@ogplanet.com/npOGPPlugin exists) Thunderbird is very slow by opening emails. the entire program hangs for some seconds (eg. 2)
The only fix is to delete the regkey before Thunderbird is started or while it is started. (in Firefox the plugin needs to enabled or disabled before)
Just disable it in Thunderbird via Add-ons->Plugins don't work. So this is a Thunderbird bug to because it is loaded even if it is disabled.

Reproducible: Always

Steps to Reproduce:
1. install the game launcher from ogplanet.com
2. open any email in Thunderbird.
Actual Results:  
thunderbird hangs for a while (eg. 2 seconds)


Im not sure but this problem maybe only exists on Windows 7 or Vista

Updated

8 years ago
Keywords: hang

Comment 1

8 years ago
René, do you see this problem if you uninstall v3, delete the program directory in c:\program files\ and reinstall v3?

(this is minor if only 2 seconds)
Severity: critical → minor
Keywords: hang
(Reporter)

Comment 2

8 years ago
with v3 you mean Thunderbird 3?
sry.. but that was one of the things i tried first^^
I've used a fresh install of TB and the problem still exists.

Did you tried to reproduce my problem?
You can find the game Launcher here:
http://static.ogplanet.com/static/Launcher/ogpinst_us.exe
without the need of installing or playing any game on ogplanet. Currently my Problem is fixed because I've uninstalled the plug-in for Firefox and now use Coral IE Tab to launch the game :P

Comment 3

8 years ago
Is the correct spelling of the DLL/plugin npOGPPlugin or npOGAPPlugin?
Keywords: perf
(Reporter)

Comment 4

8 years ago
C:\Windows\system32\npOGPPlugin.dll it the complete path.

Comment 5

8 years ago
René, thanks for the information.  I'm inclined to close this INVALID because I don't think there's anything Thunderbird can do to resolve this. And the issue of "disable it in Thunderbird via Add-ons->Plugins don't work" would be a different bug - perhaps again not even Thunderbird's fault that the "plugin" doesn't disable.

What does the vendor say about why this is happening?
Severity: minor → normal
Summary: slow Thunderbird when opening an email while npOGPPlugin extension from ogplanet.com is installed (Game Launcher) → slow Thunderbird when opening an email on windows while npOGPPlugin.dll extension from ogplanet.com is installed (Game Launcher)

Comment 6

8 years ago
no response. so => invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 7

8 years ago
y no response from ogplanet, so i can't answer your last question yet.
„What does the vendor say about why this is happening?“

it seems like my ticked does not even exist^^ I will now resend it.

The last ticked i did was on 01/24 2010 and their answer was:
---------
Hello,

Thank you for contacting our help desk.  Please be aware that the plugin was only designed for Internet Explorer, Firefox, Chrome, Safari, and Opera.  If you are using a web browser aside from those using the plugin; we will be unable to offer support for any errors or bugs that happen while running the plugin.

If you have any other questions or concerns, feel free to contact our help desk.
---------
so they didn't even noticed that Thunderbird uses the same plug-ins as Firefox does and it's an e-mail client^^
You need to log in before you can comment on or make changes to this bug.