Hg Account Request - Mark Yen <mook.moz@gmail.com>

VERIFIED FIXED

Status

VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: Mook, Assigned: phong)

Tracking

Details

(Whiteboard: ssh-key, form, voucher1, voucher2, sr)

Attachments

(1 attachment, 1 obsolete attachment)

721 bytes, text/plain
Details
(Reporter)

Description

9 years ago
Created attachment 424377 [details]
SSH pubkey (rsa 4096 for the heck of it)

I'd like a mozilla.org mercurial account; mostly to be able to send stuff to the try servers, though committing to m-c would be nice too.  This means I don't yet know if I'll want an sr voucher.

I have read http://www.mozilla.org/hacking/committer/ ; http://www.mozilla.org/hacking/regression-policy.html ; and have previously had patches checked in (thanks to others who have done so for me).

I have been around Mozilla for something over 6 years - my bugmail archive only goes back to 2004 due to an address change.  Signed up in MozillaZine in late 2002, apparently, so bugzilla account probably started in 2003.  Been building things occasionally, wrote an extension or two, currently employed at Songbird (POTI) though this request is independent of employment.  Frequents various places in IRC, including aop in #extdev, #xul, #js.

Will go fill out the contributor agreement form if this gains traction, next week at the earliest due to the lack of a printer.
Sadly, I can't vouch unless you start patching Tbird, but at least I can troll up vouchers from a couple of modules where you've done plenty to deserve vouching.

Comment 2

9 years ago
i'll vouch

Updated

9 years ago
Whiteboard: ssh-key, voucher1
I vouch.
Whiteboard: ssh-key, voucher1 → ssh-key, voucher1, voucher2
sr=Standard8
(Reporter)

Comment 5

9 years ago
Created attachment 425429 [details]
same pubkey, openssh format

Oops, need to use the OpenSSH format for the pubkey.
Still needs the form (will mail tomorrow).
Attachment #424377 - Attachment is obsolete: true

Comment 6

9 years ago
I have received Mark's (Mook) Committer's Agreement.
Over to server-ops for account access to mozilla central.
Assignee: marcia → server-ops

Comment 8

9 years ago
What's the first and last name?
(In reply to comment #8)
> What's the first and last name?

Mark Yen
Summary: Hg Account Request - Mook <mook.moz@gmail.com> → Hg Account Request - Mark Yen <mook.moz@gmail.com>
Note that this request is both for hg_mozilla and hg_mozsrc.
Whiteboard: ssh-key, voucher1, voucher2 → ssh-key, form, voucher1, voucher2, sr
(Assignee)

Comment 11

9 years ago
account created and password emailed out.
Assignee: server-ops → phong
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

9 years ago
Sorry for the delay (was on vacation with intermittent internet access) - LDAP works fine and the password has been changed, but ssh access to hg.m.o doesn't seem to work.  The output is "Permission denied (publickey,gssapi-with-mic)."; adding the relevant pubkey to my local authroized_keys2 works fine, though.
(Assignee)

Comment 13

9 years ago
added your key to you ldap account.
(Reporter)

Comment 14

9 years ago
Thanks! successfully pushed to try server, the only other test left is to push to m-c but the tree's closed :)
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: Account Request: Hg → Repository Account Requests
QA Contact: hg-acct-req → repo-acct-req
You need to log in before you can comment on or make changes to this bug.