Turning Encryption On and Off is no longer an option, remove it from Help

RESOLVED FIXED in seamonkey2.1a1

Status

SeaMonkey
Help Documentation
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: InvisibleSmiley, Assigned: InvisibleSmiley)

Tracking

({fixed-seamonkey2.0.4})

Trunk
seamonkey2.1a1
fixed-seamonkey2.0.4

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

7 years ago
Created attachment 424498 [details] [diff] [review]
patch

Turning Encryption On and Off has been removed from preferences so it needs to be removed from Help, too.
(Assignee)

Updated

7 years ago
Assignee: nobody → jh
Status: NEW → ASSIGNED
(Assignee)

Updated

7 years ago
Attachment #424498 - Attachment is patch: true
Attachment #424498 - Attachment mime type: application/octet-stream → text/plain
Attachment #424498 - Flags: review?(stefanh)

Comment 1

7 years ago
In suite/locales/en-US/chrome/common/help/passwords_help.xhtml, there's a section called "Encryption Versus Obscuring" that contains references to the checkbox. While you're there, can you also please remove the Form manager references (I found 3 or 4)?
(Assignee)

Comment 2

7 years ago
Created attachment 424654 [details] [diff] [review]
patch v2 [Checkin: comments 3 + 6]

(In reply to comment #1)
> In suite/locales/en-US/chrome/common/help/passwords_help.xhtml, there's a
> section called "Encryption Versus Obscuring" that contains references to the
> checkbox. While you're there, can you also please remove the Form manager
> references (I found 3 or 4)?

Done. I also took the liberty to add a "the" in front of "Password Manager dialog box" ("the" goes with "dialog box"; I'd even say it requires it) and capitalize "Manager" in the one reference to the Tools menu entry.
Attachment #424498 - Attachment is obsolete: true
Attachment #424654 - Flags: review?(stefanh)
Attachment #424498 - Flags: review?(stefanh)

Updated

7 years ago
Attachment #424654 - Flags: review?(stefanh) → review+
(Assignee)

Comment 3

7 years ago
Comment on attachment 424654 [details] [diff] [review]
patch v2 [Checkin: comments 3 + 6]

http://hg.mozilla.org/comm-central/rev/fd830d0de206
Attachment #424654 - Attachment description: patch v2 → patch v2 [Checkin: comment 3]
(Assignee)

Updated

7 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.1a1
Duplicate of this bug: 416235
(Assignee)

Comment 5

7 years ago
Comment on attachment 424654 [details] [diff] [review]
patch v2 [Checkin: comments 3 + 6]

Requesting branch approval.

[KaiRo]	InvisibleSmiley: help changes are allowed, as long as the list of the help files stays the same
Attachment #424654 - Flags: approval-seamonkey2.0.4?
(Assignee)

Updated

7 years ago
Blocks: 423281

Updated

7 years ago
Attachment #424654 - Flags: approval-seamonkey2.0.4? → approval-seamonkey2.0.4+
(Assignee)

Comment 6

7 years ago
Comment on attachment 424654 [details] [diff] [review]
patch v2 [Checkin: comments 3 + 6]

http://hg.mozilla.org/releases/comm-1.9.1/rev/b864dc431c06
Attachment #424654 - Attachment description: patch v2 [Checkin: comment 3] → patch v2 [Checkin: comments 3 + 6]
(Assignee)

Updated

7 years ago
Keywords: fixed-seamonkey2.0.4

Comment 7

7 years ago
This isn't quite true. The passwords file is still encrypted, but you need the password to extract the encryption key from key3.db to decrypt the passwords.
You need to log in before you can comment on or make changes to this bug.