accept / decline buttons are missing in event invitation letters

RESOLVED WORKSFORME

Status

Calendar
E-mail based Scheduling (iTIP/iMIP)
--
major
RESOLVED WORKSFORME
8 years ago
2 years ago

People

(Reporter: Circum, Unassigned)

Tracking

Lightning 1.0b1

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.7) Gecko/20100106 Ubuntu/9.10 (karmic) Firefox/3.5.7
Build Identifier: Lightning/1.0b2pre, Thunderbird/3.0.1 (also tested with Lightning/1.0b1

Although thunderbird recognizes the event (invitation is showed in nifty blue-titled box), no accept / tentative / decline buttons appear in the header, so I cannot accept the invitations. I can manually drag the letter to today pane, and in this case I can add it to my calendar.

Event letters are 1) created with outlook 2003, and also tried out with a simpler format mail, both are attached.

Reproducible: Always

Steps to Reproduce:
1. receive an event invitation from outlook
2. open the mail

Actual Results:  
accept / tentative / decline buttons are not shown

Expected Results:  
buttons should be shown

Vanilla Ubuntu 9.10 x86 install, downloaded and installed packages:

thunderbird-3.0.1.tar.bz2
lightning-1.0b1-tb+sm-linux.xpi
also tried with 2010-02-01 nightly build of lightning

I highly suspect that there is some problem with my configuration, as an error with severity cannot be undetected...
(Reporter)

Comment 1

8 years ago
Created attachment 424597 [details]
example letter 1; created with outlook

the accept / decline buttons are not shown when viewing this mail
(Reporter)

Comment 2

8 years ago
Created attachment 424598 [details]
example letter 2; another format

the accept / decline buttons are not shown when viewing this mail. I found this mail on the net, and I fed it manually to the smtp server, just to check whether the problem depends on the multipart/alternative format what mail1 has. Unfortunately it seems not.

Updated

8 years ago
Component: General → E-mail based Scheduling (iTIP/iMIP)
QA Contact: general → email-scheduling
Version: unspecified → Lightning 1.0b1

Comment 3

7 years ago
I have the very same bug on my x86_64 machine :

Linux 2.6.31.12-0.2-desktop x86_64
Thunderbird 3.0.4
Lightning 1.0b1

Comment 4

7 years ago
Hello,

Just a first idea. Did you check the requirement for installing Lightning?

Does this happen in safe mode?

Kind Regards

Comment 5

7 years ago
I checked the requirements at http://www.mozilla.org/projects/calendar/lightning/system-requirements.html and I think its is compatible with the requirements :

glibc 2.10
X.org 7.4
gtk 2.18.6
fontconfig 2.7.0
libstdc++.so.5

Extensions are disabled in safe mode ; is there a way to enable them ?

Comment 6

7 years ago
I just compiled from http://hg.mozilla.org/releases/comm-1.9.2 and tested : the bug is not there any more.

Comment 7

7 years ago
I can confirm that I've had this same problem under the following:
Thunderbird 3.0 / Lightning 1.0b1 (Fedora 13, x86-64, likely 64-bit build)
Thunderbird 3.1 / Lightning 1.0b2 (Ubuntu 8.10, x86-64, self-installed 32-bit build)
And actually, now that I think about it, just about every Thunderbird/Lightning combination I've ever tried on Linux.

Meanwhile, don't think I've ever had this problem on Windows (including the above versions and older ones).

Updated

6 years ago
Flags: wanted-calendar1.0?

Comment 8

6 years ago
I have this same issue on Windows Vista/7 (32/64 bits), TB 5.0 + Lightning + Gdata provider, against Google Calendar.

Comment 9

6 years ago
I'm now experiencing this where it was working in the past...

Thunderbird 5.0, Lightning 1.0b5, Windows XP PRo sp3 32bit fully patched...
Confirmed, an possibly reason found:

Do you have only one calendar, or only such that doesn't allow accepting events? In this case there should be an error in the error console "itipItem.targetCalendar is null".

The Problem is that if there are no such calendars, we missed error handling and an exception is thrown, this should be fixed to notify that there is no calendar that can accept the invitation.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 11

6 years ago
(In reply to Philipp Kewisch [:Fallen] from comment #10)
> Confirmed, an possibly reason found:
> 
> Do you have only one calendar, or only such that doesn't allow accepting
> events? In this case there should be an error in the error console
> "itipItem.targetCalendar is null".

Nope - we use Google Calendars, one for the user (which is fully writable) and one share Company Calendar (which is read only).

So, one Calendar is fully writable.

> The Problem is that if there are no such calendars, we missed error handling
> and an exception is thrown, this should be fixed to notify that there is no
> calendar that can accept the invitation.

Like I said, this isn't the problem...

This is getting to be a real problem.
Do you have the possibility to select an email address in the Google Calendar's properties dialog (in Lightning)? If not, then this calendar cannot accept invitations (which is known, but a Server Side issue, see the Provider FAQ) and it doesn't count.

Comment 13

6 years ago
I got the buttons to work once today and now they don't show up again. I've deleted all but one calendar and still have the problem.

Comment 14

6 years ago
Another user is now complaining about this... that makes about 20 in all.

I now have one that someone forwarded me, and I get the following error in the console (once for each time I click on the message after clicking on a different message):

Error: itipItem.targetCalendar is null
Source File: resource://calendar/modules/calItipUtils.jsm
Line: 511

Comment 15

6 years ago
Hi, after reading Philippìs comment #12, I tried looking into the Google Calendar properties dialog and found that, while I *could* select an email address, I had not yet done so.

So I chose one of the several addresses I use and bingo! buttons started to show on the blue bar.

So it seems the problem is really that the provider should at least trap this and warn of the configuration problem.

Which brings me however to another problem: I had not chosen an address because I use multiple addresses and many times I'd like to make sure which one is used to send out replies, and to whom.

Is there a way to do so?

Comment 16

6 years ago
Well ... I'll ... be ... damned ...

How could I have missed Phillips comment?

But yes, I agree, instead of 'none', the default should be 'prompt', and if that is how it is set up, it should prompt you for which address you want to associate with this event (and send replies/invites as from that address)...

But I guess that would be a 'Feature Request' for the Provider addon...

Thanks Mauro for pointing out this blatantly obvious solution!

Comment 17

6 years ago
Can someone please change "Platform" to "All", since this bug is clearly not platform-dependent?

Also, how can I put in a feature request to make the component behave as described in Comment #16 ?
Better UI would be nice, I agree.
OS: Linux → All
Hardware: x86 → All

Comment 19

6 years ago
(In reply to Philipp Kewisch [:Fallen] from comment #18)
> Better UI would be nice, I agree.

So what can we do? Are you the only one that will be able to work on this?

I greatly miss the ability to choose which address to respond with (and possibly to edit the response that's sent - but maybe there's already a feature request for this).
(In reply to Mauro Cicognini from comment #19)
> (In reply to Philipp Kewisch [:Fallen] from comment #18)
> > Better UI would be nice, I agree.
> 
> So what can we do? Are you the only one that will be able to work on this?
I'm sure there are others out there that are able to do so, but this is currently not a priority of the Calendar Team. While I agree its annoying, there are other areas that require fixing more importantly.

If you, or someone you know, is willing to look into this bug I would greatly appreciate. In that case the next step would be a UI mockup of how the proposed changes should look like.


> I greatly miss the ability to choose which address to respond with (and
> possibly to edit the response that's sent - but maybe there's already a
> feature request for this).
bug 664975

Comment 21

6 years ago
Workaround that worked for me:

I don't use google calendar but I have the same issue. It started for me when I added a new shared calendar in the 'calendar' view. The buttons reappear if my calender is highlighted and is the only one checked.

As for fixing the bug: 
The priority should be that this doesn't fail silently. That's bug #1. Bug #2 can be a new UI where a username can be selected etc, etc.
Duplicate of this bug: 558984

Comment 23

6 years ago
The Google Calendar plugin is a different, related issue. Since it returns null when requesting the "itip.transport" property, the function isSchedulingCalendar returns false and initItemFromMsgData does not initialize itipItem.targetCalendar.

As James said the silent error is the real bug, and I'm not too familiar with the calendar codebase, so I don't know where the best spot for the patch would be, but perhaps imip-bar-overlay.xul could be modified to show an error message if there are no valid schedulingCalanders (After checking for tar check in setupOptions() of imip-bar.js)?

Comment 24

6 years ago
Related google-calendar bug: https://bugzilla.mozilla.org/show_bug.cgi?id=407961

Comment 25

5 years ago
Any progress on this issues?  Lightening has now become completely useless because of this issue.

thunderbird-10.0 (Fedora 16 x86_64 build)
lightning 1.2.1 (Fedora 16 x86_64 build)

I am using a SINGLE calendar connected to Chandler Hub.  And everything worked fine until the upgrade to 1.2.1..

Comment 26

5 years ago
Works/been working fine for me, although I haven't updated to 10 yest (a few extension stragglers)...

Edward - did you try selecting an email address per comment 12 and comment 15? This worked for me and Mauro, although I agree with  the others that there is still a problem that should be fixed.
The Google Calendar bug may be a different core problem. I've heard issues with 1.2.1 and invitations, so lets investigate:

Could you make sure you have the email selected as Charles mentioned
* Enable calendar.debug.log and calendar.debug.log.verbose as mentioned below
* Restart Thunderbird, wait for things to load.
* Make sure invitation email is _not_ selected
* Tools > Error Console > Clear
* Click on the invitation email
* Observe the error console and look for relevant messages

Enabling the debug options: Options > Advanced > Config Editor, then search for them.

Copying more than one message out of the error console: Use the Console^2 Extension from addons.mozilla.org.

Comment 28

5 years ago
(In reply to Charles from comment #26)
> Edward - did you try selecting an email address per comment 12 and comment
> 15? This worked for me and Mauro, although I agree with  the others that
> there is still a problem that should be fixed.

I had already had an email address selected (I've always had those setup). About the only thing left I have to do is start from scratch "again".

Comment 29

5 years ago
I can reproduce this on Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20130105 Thunderbird/17.0.2 with Lightning 1.9 using the attachments in Comment 1 and Comment 2.

Comment 30

5 years ago
I can reproduce with TB 17.0.2, Lightning 1.9, MacOS 10.7.4 with calendar invites emailed to me as well as attachments in Comment 1 and Comment 2.

I'm trying to "sync" said invites/meetings with Google Calendar.  "Provider for Google Calendar 0.18" is also installed.  My "calendar" sync with google calendar account otherwise seems to be working.

Comment 31

4 years ago
Having the same problem - no accept/decline for event invitation emails.
Followed the suggestions above about logs, and this log shows up when I select the email with the invitation:

Timestamp: 8/03/13 2:56:49 PM
Error: [Exception... "'TypeError: this.mItipItem.targetCalendar is null' when calling method: [nsIObserver::observe]"  nsresult: "0x8057001c (NS_ERROR_XPC_JS_THREW_JS_OBJECT)"  location: "JS frame :: file:///Users/ME/Library/Thunderbird/Profiles/6s3w3awx.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/lightningTextCalendarConverter.js :: lmcCTH :: line 264"  data: no]
Source File: file:///Users/ME/Library/Thunderbird/Profiles/6s3w3awx.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/lightningTextCalendarConverter.js
Line: 264

(In reply to Philipp Kewisch [:Fallen] from comment #27)
> The Google Calendar bug may be a different core problem. I've heard issues
> with 1.2.1 and invitations, so lets investigate:
> 
> Could you make sure you have the email selected as Charles mentioned
> * Enable calendar.debug.log and calendar.debug.log.verbose as mentioned below
> * Restart Thunderbird, wait for things to load.
> * Make sure invitation email is _not_ selected
> * Tools > Error Console > Clear
> * Click on the invitation email
> * Observe the error console and look for relevant messages
> 
> Enabling the debug options: Options > Advanced > Config Editor, then search
> for them.
> 
> Copying more than one message out of the error console: Use the Console^2
> Extension from addons.mozilla.org.

Comment 32

4 years ago
Please ensure that you configured an email account that should be used for invitation handling in the calendars properties dialog.

Comment 33

4 years ago
Where exactly is this setting? I couldn't find it in preferences or in the actual calendar properties. I'm running on Mac, latest Thunderbird and Lightning (auto updates turned on).

Comment 34

4 years ago
Go to the calendar tab.
Right click on the calendar name (e.g. 'work') in the calendar list (you may need to expand this) and select "Properties".
Change the E-Mail setting (pulldown). (Mine somehow was reset to "None".)
Click OK.

Rather than just not display the buttons, it should put up some message about no calendar associated with this email address and a hint as to where to set it.

Comment 35

4 years ago
Same problem in Thunderbird 17.0.7 + Lightning 1.9.1 on WinXP Pro. I received a mail containing an event invitation, and a cyan bar appeared notifying me of that, but giving me no options. 

I followed Comment 34's instructions (thank ardbug) and then the cyan bar showed me buttons to act on the invitation.

In the Error Console, I guess the interesting error is this one:

Error: [Exception... "'TypeError: this.mItipItem.targetCalendar is null' when calling method: [nsIObserver::observe]"  nsresult: "0x8057001c (NS_ERROR_XPC_JS_THREW_JS_OBJECT)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/Mija/Application%20Data/Thunderbird/Profiles/myv5jv9n.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/lightningTextCalendarConverter.js :: lmcCTH :: line 273"  data: no]
Source File: file:///C:/Documents%20and%20Settings/Mija/Application%20Data/Thunderbird/Profiles/myv5jv9n.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/lightningTextCalendarConverter.js
Line: 273

Comment 36

4 years ago
After applying the fix from Comment 34 I am still seeing this problem sporadically.  Some new invitations I get still don't show the Accept/Decline/Tentative buttons in the cyan bar.  However, if I restart Thunderbird and view the invitation again, the buttons appear.

Comment 37

4 years ago
I upgraded my Thunderbird v24.1.0 to Thunderbird v24.1.1. My Lightening v2.6.1 was automatically upgraded to v2.6.3. Earlier I was able to see the ‘Accept’ and ‘Decline’ buttons when I received invitations on my local Thunderbird as well as my synchronized Google calendar. After the upgrade I stopped getting these buttons in the invitations.

I resolved this by following these steps:

1. Uninstall Lightening v2.6.3
2. Again install Lightening v2.6.3 from addons.mozilla.org
3. Restart Thunderbird
4. Check the calendar properties - Go to settings - Select the email id that you want to be associated with your calendar

End Result – ‘Accept’ and ‘Decline’ buttons are now visible

To me it seems that automatic upgrade of Lightening causes the problem. Manually installing the same upgraded version causes Lightening to be properly synchronized with Thunderbird

Comment 38

4 years ago
MacOSx, Thunderbird 24.1.1, Lightning 2.6.3, no buttons.  Console log shows:

[JavaScript Error: "[Exception... "'[JavaScript Error: "foundAttendee is null" {file: "resource://calendar/modules/calItipUtils.jsm" line: 1214}]' when calling method: [calIOperationListener::onOperationComplete]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///Users/kevinm/Library/Thunderbird/Profiles/mei6xc0x.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js :: calCompositeGetListenerHelper.prototype.onOperationComplete :: line 520"  data: yes]"]

Comment 39

4 years ago
BTW, I tried the steps in Comment 37, additionally restarting between removing and reinstalling Lightning 2.6.3, with no success.

Comment 40

4 years ago
Kevin, please see Bug 927346.

Comment 41

4 years ago
I am having the same issue. I have tried Comments 12, 34, and 37. None have resolved the issue for me. Thunderbird v24.2.0, Lighning v2.6.4

Comment 42

4 years ago
Roy,

I've spend also some time searching for solution. Have you tried this:
Open Edit->Preferences->Advanced->General->Config Editor 
and find 
calendar.google.enableEmailInvitations property.
If set to 'false' then toggle it into 'true'. 

For some reason for me it was false, so I have even no option to set any email before setting this one to true. I've found some discussion here also:
http://forums.mozillazine.org/viewtopic.php?f=46&t=1113165

Comment 43

3 years ago
I've now completely lost my invite buttons with the patch applied.  Thunderbird 24.3.  The invite now just shows up as a winmail.dat mail attachment that, of course, can't be opened.

Comment 44

3 years ago
it does appear that thunderbird beta 27.0 with lightening 2.9b1 works (at least for invites; I need to test cancellations).

Comment 45

3 years ago
 I had the same problem and solved it as described in comment 34 but it doesn't work with Provider for Google calendar, since you cannot associate any email account with it.
See similar post here:
https://superuser.com/questions/489189/accept-and-decline-button-missing-in-thunderbird-when-receiving-an-invitation/775959#775959
http://forums.mozillazine.org/viewtopic.php?f=46&t=2501003
Flags: wanted-calendar1.0?

Comment 46

2 years ago
WFM in 3.3 and later. There have been various issues reported in this bug over time - as this currently is working, if anybody here suffers a not working button, please file a new bug for this.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME

Comment 47

2 years ago
4.0.0.1 with B 38.0.1 (on OSX Yosemite latest) is doing this again where buttons for invitations are not showing up anywhere.

Comment 48

2 years ago
(In reply to Jim from comment #47)
> 4.0.0.1 with B 38.0.1 (on OSX Yosemite latest) is doing this again where
> buttons for invitations are not showing up anywhere.

B == TB
Jim, are you still experiencing this issue with Thunderbird 38.3.0 and Lightning 4.0.3?
Flags: needinfo?(snafuxnj)
Flags: needinfo?(snafuxnj)

Comment 50

2 years ago
(In reply to Martin Schröder [:mschroeder] from comment #49)
> Jim, are you still experiencing this issue with Thunderbird 38.3.0 and
> Lightning 4.0.3?

I'm good. Once I started using the right tool (iirc) the problem was resolved. Thank you.
You need to log in before you can comment on or make changes to this bug.