TB 3.0.1: New Mail Alert Window Message count is incorrect on Windows

RESOLVED DUPLICATE of bug 540554

Status

RESOLVED DUPLICATE of bug 540554
9 years ago
9 years ago

People

(Reporter: mad.engineer, Unassigned)

Tracking

({qawanted})

x86
Windows XP
qawanted

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

I've seen this several times. Setup as follows:
1. Fresh install of TB 3.0.1 on Win XP Pro SP2
2. IMAP setup, with no message sync turned on, not using local folders
3. Have set the folder view to "All Folders". Not using "Smart folder" view
4. The new mail alert pop-up window shows the message count incorrect. Even though I just have one new mail in my InBox, it says that I have 5 instead. This is very annoying.



Reproducible: Always

Steps to Reproduce:
See above


Expected Results:  
New mail alert pop-up should show the actual count of the new messages.
(Reporter)

Updated

9 years ago
Flags: blocking-thunderbird3.1?
Version: unspecified → 3.0
What do you mean by new messages exactly?
* "new messages that just arrived and were not present the last time Thunderbird checked for new messages"
* "new messages this session that have never been marked read"
* "unread messages"

In my experience, Thunderbird seems to take the second interpretation, which can indeed sometimes be annoying.
Component: General → Mail Window Front End
QA Contact: general → front-end
(Reporter)

Comment 2

9 years ago
By New Mail, this is what I mean:

Earlier, I had just one new/unread message show up in my IMAP InBox. The New Mail alert pop-up/notification window that showed up, immediately after this one mail said that I have 5 new messages. I went back and checked every IMAP folder that I m subscribed to, no such mail anywhere.

On a similar note, the New Mail notification window due to the said reason is unreliable and cannot be customized for it's contents, other than what you can do from the Options->General window.

One of the mozilla forums message mentioned to delete all the .MSF files in my Profile folder and re-start TB which should fix this temp. But I'm not sure if this will correct and and what the real root cause is. Therefore, I did not try that suggestion.
I strongly suggest trying that suggestion, and closing this bug as WFM if the problem goes away. MSF files can get corrupted in a number of poorly-understood ways, and are reasonably cheap and essentially harmless to reconstruct, so if you're having a problem and someone suggests deleting them, try it. It can't hurt, and it will often help. (In this case, finding the root cause may be impossible; it could be any number of different things, and while Thunderbird's MSF handling could undoubtedly be made somewhat more reliable, this is not an easy task and is likely being tracked by other bugs.)
(Reporter)

Comment 4

9 years ago
Problem is that the suppose work around related to deleting .MSF is not documented anywhere as far as I know in any Mozilla KB that I searched earlier. And if this breaks some thing else in my profile, that I loose valuable time going back and fixing TB. If you can point me to some Mozilla KB article that lists these steps, I'd be more than happy to try it. Secondly, this supposedly workaround may result in this issue come back again. The overall New Mail Notification itself is buggy, sorry to say. There are several bugs that I've seen related to mail biff not working properly.
Well yes, it is quite possibly buggy. Could you report each of those issues you've noticed?

Regarding deleting .MSF files and similar: http://kb.mozillazine.org/Compacting_folders#What_happens_if_you_do_not_compact_folders.3F notes that your symptom can often happen if folders need compacting, and notes also that deleting the .MSF file for a given folder is a fast way to repair this. Deleting .MSF files will not break other parts of your profile.
Since the conditions for corruption of .MSF files are not fully known, if compacting your folders or deleting the .MSF files fixes your problem, then do it. If the problem shows up again, then it'll be that much easier to debug: non-reproducible problems are not friendly.
(Reporter)

Comment 6

9 years ago
I compact my folders very regulars since I use IMAP, I understand the ramification of not compacting the folders. So, I don't believe that in my case, the issue is with not compacting the folders.

As for the other Mail Notification issues, there are several bugs already filed on mail biff if you do a search. I filed 531002 a while back on this as well.
(Reporter)

Comment 7

9 years ago
I just tested on my TB 3.0.1 by deleting all .MSF files in my Profile folder and as suspected, all this did was change my message view window layout back to default. The customization that I did like column display order, enabling/hiding columns that I don't want etc went back to the default. Nothing else got changed and it did not fix the Notification window message count issue either. Something is broken bad in TB for sure IMHO.
Hmm... I'm unable to reproduce this or find any other angles to try (using Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20100111 Lightning/1.0b2pre Thunderbird/3.0.1 ThunderBrowse/3.2.8.1 ID:20100111101938). If someone else can figure out what's going on, I'll be happy to help.
Keywords: qawanted
(Reporter)

Comment 9

9 years ago
See that attached screen shot of the issue. The new mail icon in the task bar at the lower right-hand side show that I have "5" new messages. But when I look at all my IMAP folders including InBox, I only see "1" New message as seen in the attached screen shot.
(Reporter)

Comment 10

9 years ago
Created attachment 425314 [details]
Screen capture showing that new mail icon indicates that I have 5 new messages, whereas I only have 1
Hmm... that doesn't look like the default theme. Just to make sure... is this reproducible in Safe Mode (http://kb.mozillazine.org/Safe_Mode)?
(Reporter)

Comment 12

9 years ago
I've attached a screen shot with TB running in Safe mode. As you can see. New Mail icon shows 1 new message, whereas the InBox have actually 4.
(Reporter)

Comment 13

9 years ago
Created attachment 425352 [details]
TB runnint in Safe Mode showing the same issue

Comment 14

9 years ago
Is this happening with 3.02 pre builds? Did it start in 3.01 and not 3.0? If so, this is likely a dup of the condstore bug, and I'm going to mark it as a dup of one of those - bug 540554. Please re-open if you see this in 3.02 pre builds.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 540554
Flags: blocking-thunderbird3.1?
You need to log in before you can comment on or make changes to this bug.