[PP]Mac HTML buttons don't display Unicode correctly

VERIFIED FIXED in M7

Status

SeaMonkey
UI Design
P3
blocker
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Fergus Sullivan, Assigned: tague)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DEPEND - Intl - I18n QA BLOCKER - ok for M6, URL)

(Reporter)

Description

18 years ago
Take navigator.xul and change a couple of strings to Japanese or to European
extended characters (using Unicode).  Go to a page that has HTML buttons, like
Netcenter's Japanese home page.  On Win, all on-screen widgets look good,
on Mac the text labels of the HTML buttons are corrupted.

It looks like MacFE still expects either Shift-JIS or MacRoman, as appropriate.
It should be looking for and displaying Unicode characters.

Updated

18 years ago
Assignee: don → trudelle
QA Contact: 3849 → 4838

Comment 1

18 years ago
see comments for 5402

Updated

18 years ago
Assignee: trudelle → evaughan
Target Milestone: M5

Comment 2

18 years ago
reassigning to evaughan as p3 for m5. Eric, this is blocking an I18N M5 task.
Please enlist any Mac debugging assistance you need.

Updated

18 years ago
Assignee: evaughan → kmcclusk

Comment 3

18 years ago
This looks like a dup of the bug I just sent you. Draw string does not look like
its doing the right thing underneath.

Updated

18 years ago
Target Milestone: M5 → M6

Comment 4

18 years ago
Moving to M6.

Updated

18 years ago
Whiteboard: QA BLOCKER

Comment 5

18 years ago
Adding to QA Blocker radar.

Updated

18 years ago
Whiteboard: QA BLOCKER → QA BLOCKER - ok for M6

Updated

18 years ago
Assignee: kmcclusk → pierre
Pierre, I think this is in the Mac platform specific code so I am reassigning it
to you.

Updated

18 years ago
Severity: major → blocker

Comment 7

18 years ago
Fergus: could you give more details in order to reproduce the bug? Like what
strings to modify in navigator.xul, what strings to use instead, what URL to
connect to....
Thanks.

Updated

18 years ago

Comment 8

18 years ago
Read the history on bugs 5402 and 5439. Similar problem in different mac
widgets. May want to contact Chris Saari and/or Tague Griffith as they're
working on 5402.  Test file at
http://rocknroll/users/msanz/publish/navigator.zip

Updated

18 years ago
Whiteboard: QA BLOCKER - ok for M6 → I18n QA BLOCKER - ok for M6

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M6 → M7

Comment 9

18 years ago
Fergus: how did you manage to display HTML buttons in AppRunner? I can only
display native controls.

Anyhow this won't be fixed for M6: pushing to M7.

Comment 10

18 years ago
*** Bug 6599 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Whiteboard: I18n QA BLOCKER - ok for M6 → DEPEND - Intl - I18n QA BLOCKER - ok for M6
(Reporter)

Comment 11

18 years ago
Pierre, this can be repro'd by just going to http://home.jp.netscape.com/ja/
The buttons I'm talking about are the default Excite search button etc.

Updated

18 years ago
Blocks: 7228

Updated

18 years ago
Summary: Mac HTML buttons don't display Unicode correctly → [PP]Mac HTML buttons don't display Unicode correctly

Updated

18 years ago
Target Milestone: M7 → M9

Comment 12

18 years ago
Puhing my Mac-specific bugs to M9 before reassigning them to someone else.

Comment 13

18 years ago
Related to bug #4681?
(Assignee)

Comment 14

18 years ago
I can't guarantee this, but if the button code is similar to the menu code,
the problem is most likely that the button label string is getting extracted as
a C-string and not a Unicode string.
(Assignee)

Comment 15

18 years ago
The problem is in nsMacControl::StringToStr255.  It takes the nsString label of
the button and does a ToCString on the label to create a Pascal string (Str255)
to set as the Mac control label.
(Assignee)

Updated

18 years ago
Assignee: pierre → tague
Status: ASSIGNED → NEW
Target Milestone: M9 → M7
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 16

18 years ago
checked in a general fix for macintosh controls.  should be in m7
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 17

18 years ago
Verifyied against June 18 build.
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.