sent message not copied to sent folder

RESOLVED WORKSFORME

Status

Thunderbird
Folder and Message Lists
RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: Paul Cox, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

sometimes the message is sent successfully but not copied to the sent folder

This is what happens:

1 I click on send
2 A dialog appears "copying message to sent folder" which loops indefinitely
3. I click on cancel and the error/retry dialog box appears
4. I click on cancel and TB3 informs me the message was sent bot could not copy to the sent folder
5. I return to the compose window
6. I have to restart TB3 3.0.1 to resume normal function of the program

An image of the dialog boxes is available on request

Reproducible: Sometimes

Actual Results:  
I cannot reproduce the problem.



Expected Results:  
message sent the sent folder

The account is an IMAP account. I have used the "send copy to other folder" option to send the copies to a local folder, but this has not solved the problem.
(Q1) Do you enable auto-save? If yes, what folder is set as "folder to save draft"?
Set "folder to save draft" to "Drafts of Local Folders" via "other:" as you did for Sent. (you need to create Drafts manually before it)
Save is successful?
(Q2) Can you create Drafts and Sent folder of the IMAP account manually?
     If yes, can you copy mail to the Drafts and Sent IMAP folder?
(Reporter)

Comment 2

8 years ago
Q1
Auto-save is set to 5 mins.
I have now manually set drafts to save at "Local drafts" using the "other" option
I will now see if this makes a difference

Q2
The drafts and sent folders on the IMAP account exist, but at the moment the drafts are set to go to "Local Folders/Local drafts" and sent messages are set to 
go to "Local Folders/Sent 2010"
(Reporter)

Comment 3

8 years ago
I have tested during the last 6 days.
The problem is still there.

Is there anything else I can do to remove the problem?
Does you problem occur on any new mail, reply mail, forwarded mail?
"Reply" at Inbox only? Mail of big attachment only? Only when long composing time? Or only when short composing time(less than 5 mini)? Or only when compsition time is around 5 min?
Or "sometimes" is "randomly"?

Change next settings.
1. Disable auto-save (Tools/Options/Composition)
2. Enable next option of Copies&Folders.
> [x] Show confirmation dialog when messages are saved
3. Disable next options of Copies&Folders.
> [ ] Place replies in the folders of the message being replied to
4. Disable auto-compact
> [ ] Compact folders when it will save over ... (Tools/Option/Advanced/Network&Disk Space)
And check next.
- Compose a mail with attachment, with To:==your mail address. 
- "Save" (as draft)
- "Send Later"
- "Send Unsent Messages" at Outbox of "Local Folders"
(Reporter)

Comment 5

8 years ago
I have carried out the measures you recommend.

The problem happens randomly.
The problem only happens sometimes with new emails I write.
The problem can happen with or without an attachment.
The composing time is usually short.

Up to now I cannot see a way to reproduce the problem.
I will now wait again and collect more information.
(Reporter)

Comment 6

8 years ago
Case closed
-----------

Thank you for your help up to now
Unfortunately the problem has persisted and so I have reinstalled TB2
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 7

8 years ago
This should be re-opened, the bug has been there for a long time, and happens occasionally and unpredicatably. I just had it happen twice in the last few days, both times having to quit TB (as reported) to get it back to normal behavior.
(Reporter)

Comment 8

8 years ago
(In reply to comment #7)
> This should be re-opened, the bug has been there for a long time, and happens
> occasionally and unpredicatably. I just had it happen twice in the last few
> days, both times having to quit TB (as reported) to get it back to normal
> behavior.

Thank you for your comment, the situation at my end is as follows:

- I still use TB3
- The problem is still there despite following the tips given to me
- The problem is unpredictable and only relates to new messages sent, where TB3 fails to copy the message sent to the SENT box
- The only way to recover my message sent is to copy the text, re-start TB, make a draft message, insert the text from the clipboard, and save to the SENT box.
- If I am sending an important email with an attachment I always close and re-start TB3 before sending. Then the message is copied to the SENT box.

This problem also re-occurred after a new Windows installation and on another XP computer as well so I have no idea what the cause is.

In addition, I have noticed that when I start TB3 it is not possible to move IMAP files around on the server. So I always start TB3 twice at the beginning and then the functions seem to be there. But perhaps this is a different issue.

Comment 9

8 years ago
This bug should be reopened. It may be a duplicate of bug 406929. I have the same problem with Thunderbird 3.1.2 and Windows XP+SP3, or Windows 7
/X86. The problem seems to be worse with Windows 7. In my case, I have seven
IMAP accounts in Thunderbird, with most of the servers running the qmail MTA.
One of the IMAP accounts is with gmail, and another with Yahoo mail. The
problem is very hard to reproduce consistently, but seems to be related to an
IMAP timeout or temporary network congestion on DSL accounts. The only way to
recover is to restart Thunderbird, and then the sent mail is lost. If there is
anything I can provide or do to help to get this problem fixed, please let me
know.

Comment 10

8 years ago
If its a duplicate then its the other way around - as Bug 406929 is specific to Imap and this bug happens (at least for me) with POP.
(Reporter)

Comment 11

8 years ago
A few days ago I installed the add-on EXPUNGE.
I have used the timer to tell EXPUNGE to compact and clean up the folders every 60 minutes. I will test and report back later.
(Reporter)

Comment 12

8 years ago
So far the problem has not repeated. Expunge is set by timer to
- Empty trash folder
- Compact folders

Comment 13

6 years ago
I'm not sure how this bug got marked Resolved, it occurs fairly frequently for me.

It seems to be one of those bugs triggered by poor internet connectivity.

This is similar - maybe a duplicate - of others including Bug #406929.
You need to log in before you can comment on or make changes to this bug.