Last Comment Bug 545194 - Account Settings-->Server username and buttons "Advanced" and "Browse" are cut off
: Account Settings-->Server username and buttons "Advanced" and "Browse" are cu...
Status: RESOLVED FIXED
: polish
Product: MailNews Core
Classification: Components
Component: Account Manager (show other bugs)
: Trunk
: All All
-- minor (vote)
: Thunderbird 18.0
Assigned To: :aceman
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-09 12:04 PST by [:Aureliano Buendía]
Modified: 2012-10-02 16:00 PDT (History)
8 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
screenshot (219.43 KB, image/jpeg)
2010-02-09 12:04 PST, [:Aureliano Buendía]
no flags Details
screenshot of proposal from comment 5 (11.00 KB, image/png)
2012-09-18 02:38 PDT, :aceman
euryalus.0: feedback+
Details
patch (2.91 KB, patch)
2012-09-18 14:25 PDT, :aceman
iann_bugzilla: review+
bwinton: ui‑review+
Details | Diff | Splinter Review
patch v2 (2.96 KB, patch)
2012-09-24 14:29 PDT, :aceman
mconley: review+
Details | Diff | Splinter Review

Description User image [:Aureliano Buendía] 2010-02-09 12:04:19 PST
Created attachment 426042 [details]
screenshot

This issue is a spin-off of bug #528057.  

DOM element server.realUsername in account settings-->server is cut off when account is large more than 20 letters.
Comment 1 User image :aceman 2011-11-13 10:38:25 PST
And what is the proposal?
Comment 2 User image :aceman 2012-05-24 02:39:53 PDT
I find it much worse that the buttons are cut off there.
The server name can be scrolled.
Comment 3 User image [:Aureliano Buendía] 2012-06-05 00:40:09 PDT
(In reply to :aceman from comment #2)
> I find it much worse that the buttons are cut off there

Yes, it is: changed title according
Comment 4 User image [:Aureliano Buendía] 2012-06-05 00:40:42 PDT
*** Bug 760454 has been marked as a duplicate of this bug. ***
Comment 5 User image :aceman 2012-09-18 02:20:34 PDT
Aureliano, do you still see the problem? In current TB, the account settings pane has a horizontal scrollbar if the contents do not fit. You can also resize the window if it is small for you. So that should fix the buttons.

But it can be easily done to expand the server name and user name textboxes when the window is resized (like the Local Directory field is done). I can add some flex=1 values where needed. Bwinton, would you accept that?
Comment 6 User image :aceman 2012-09-18 02:38:00 PDT
Created attachment 662080 [details]
screenshot of proposal from comment 5

This is no mockup, I set the needed attributes on the elements via DOM Inspector.
Comment 7 User image :aceman 2012-09-18 14:25:04 PDT
Created attachment 662313 [details] [diff] [review]
patch
Comment 8 User image Blake Winton (:bwinton) (:☕️) 2012-09-24 07:54:22 PDT
Comment on attachment 662313 [details] [diff] [review]
patch

Yeah, that makes sense.  ui-r=me!

Thanks,
Blake.
Comment 9 User image Ian Neal 2012-09-24 14:10:42 PDT
Comment on attachment 662313 [details] [diff] [review]
patch

>+              <textbox wsm_persist="true"
>+                       size="20" flex="1"
This is the only line you've not got one attribute per line!
>+                       id="server.realHostName"
>+                       prefstring="mail.server.%serverkey%.realhostname"
>+                       class="uri-element"/>

>+              <textbox wsm_persist="true"
>+                       size="20" flex="1"
This is the only line you've not got one attribute per line!
>+                       id="server.realUsername"
>                        prefstring="mail.server.%serverkey%.realusername"/>
Comment 10 User image :aceman 2012-09-24 14:29:41 PDT
Created attachment 664218 [details] [diff] [review]
patch v2

Thanks.
Comment 11 User image [:Aureliano Buendía] 2012-09-30 01:28:16 PDT
Comment on attachment 662080 [details]
screenshot of proposal from comment 5

Sorry for the delay: look good for me!
Thanks :aceman
Comment 12 User image Mike Conley (:mconley) 2012-10-02 12:39:31 PDT
Comment on attachment 664218 [details] [diff] [review]
patch v2

Review of attachment 664218 [details] [diff] [review]:
-----------------------------------------------------------------

This looks OK to me. Thanks aceman!
Comment 13 User image Ryan VanderMeulen [:RyanVM] 2012-10-02 16:00:44 PDT
https://hg.mozilla.org/comm-central/rev/9c73c166f56e

Note You need to log in before you can comment on or make changes to this bug.