Closed Bug 545219 Opened 12 years ago Closed 11 years ago

Visiting Silverlight Showcase Page Immediately Brings up Stop Script Pop Up

Categories

(Plugins Graveyard :: Silverlight (Microsoft), defect)

x86
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: arocco222, Unassigned)

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a2pre) Gecko/20100209 Minefield/3.7a2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a2pre) Gecko/20100209 Minefield/3.7a2pre

Script: http://blogs.silverlight.net/showcase/resources/js/main.js?fd=-8589467390013877770:2791

Reproducible: Always

Steps to Reproduce:
1.Visit Showcase
2.Pop up immediately happens
3.
With OOPP enabled I get a slow-script warning and the page will finished loading after clicking 'continue' 
Text in the dialog box:
Script: http://blogs.silverlight.net/ScriptResource.axd?d=tr619hrT79inwpfRIoYT-SAv9806Vglc-WTW1LvXrI0YY_qgZbTOGaQ8_riGnT29y9fWCqWXF3ilUDI9R7ZYL879e2rceyRuu1Hft_05gOk1&t=ffffffff86081ada:5

Turning off OOPP the page loads in about 5-6 secs for me, 15+ with OOPP on due to the script hang.

Setting to New
Blocks: OOPP
Status: UNCONFIRMED → NEW
Component: General → Plug-ins
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: general → plugins
Summary: Visiting Silverlight Showcase Page Immediately Brings up Stop Script Pop Up → [OOPP]Visiting Silverlight Showcase Page Immediately Brings up Stop Script Pop Up
Version: unspecified → Trunk
Should add I'm also using Win7, and its 64 bit..
CPU Athlon Phenom II Quad with 8gig Ram, onboard HD3200 Video 512meg Ram
IPC exacerbates this problem, but it's not specific to it. I can reproduce this easily without oopp enabled.
No longer blocks: OOPP
blocking2.0: --- → ?
Summary: [OOPP]Visiting Silverlight Showcase Page Immediately Brings up Stop Script Pop Up → Visiting Silverlight Showcase Page Immediately Brings up Stop Script Pop Up
Using the lastest hourly build with cset:
http://hg.mozilla.org/mozilla-central/rev/dc3af645f713 
which I think has some OOPP changes...

The 'Showcase' page does not load at all, and no slow-script warning is thrown.
I am seeing in Console2 this:

Error: this._slPlugin.content is undefined
Source file: http://blogs.silverlight.net/showcase/resources/js/main.js?fd=-8589467390013877770
Line: 3626
With the landing of: 
https://bugzilla.mozilla.org/show_bug.cgi?id=542831

This is now WFM, will close as such, but more likely a dupe of 542831
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
blocking2.0: ? → ---
Component: Plug-ins → Silverlight (Microsoft)
Product: Core → Plugins
QA Contact: plugins → microsoft-silverlight
Version: Trunk → unspecified
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.