Last Comment Bug 545366 - Javascript button doesn't react (onclick).
: Javascript button doesn't react (onclick).
Status: VERIFIED FIXED
formfill
:
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: All All
: -- major (vote)
: Firefox 4.0
Assigned To: Nobody; OK to take it and work on it
: maemo-linux
Mentors:
http://address.yahoo.com
Depends on: 460966
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-10 01:35 PST by Jan Pieniadz
Modified: 2011-08-04 08:30 PDT (History)
10 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Jan Pieniadz 2010-02-10 01:35:26 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:1.9.2.2pre) Gecko20100209 Namoroka/3.6.2pre Fennec/1.0pre

Maemo 5
fennec_1.0~20100209013306_armel
xulrunner_1.9.2.2pre-20100209011315_armel


Reproducible: Always

Steps to Reproduce:
1. Navigate to http://address.yahoo.com
2. Sign in (btests/apptest)
3. Try to use Add Contact / Add Category buttons

Actual Results:  
There is no reaction after clicking the button.

Expected Results:  
Add contact form opens.
Comment 1 Jan Pieniadz 2010-02-12 04:49:03 PST
Major functionality missing.
Comment 2 Aakash Desai [:aakashd] 2010-02-15 16:24:24 PST
confirmed on build:
Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:1.9.2.2pre) Gecko20100215
Namoroka/3.6.2pre Fennec/1.1a2pre
Comment 3 Aakash Desai [:aakashd] 2010-03-22 14:02:15 PDT
This might be related to https://bugzilla.mozilla.org/show_bug.cgi?id=539284
Comment 4 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2010-04-04 03:47:06 PDT
(In reply to comment #3)
> This might be related to https://bugzilla.mozilla.org/show_bug.cgi?id=539284

This bug has been resolved and this still happen. Like you I was thinking that it was the same root cause, but apparenlty no.
Comment 5 Matt Brubeck (:mbrubeck) 2010-04-08 06:03:25 PDT
There are some onmouseover handlers on those links. Maybe this is caused by bug 483958 and bug 460966 (like bug 542735).
Comment 6 Matt Brubeck (:mbrubeck) 2010-07-22 22:00:58 PDT
These buttons are also inaccessible to keyboard users in desktop browsers.
Comment 7 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2010-07-23 05:18:45 PDT
I'm adding formfill as a whiteboard tag to keep this in my radar and because it could be related to form assistant.
Comment 8 Mark Finkle (:mfinkle) (use needinfo?) 2010-08-18 12:03:05 PDT
Vivien - Any update on this?
Comment 9 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2010-08-18 17:11:15 PDT
(In reply to comment #8)
> Vivien - Any update on this?

This probably depends on 460966 and will be resolved with it.
Comment 10 Brad Lassey [:blassey] (use needinfo?) 2011-05-13 11:44:08 PDT
marking as 7+ based on the dependency on bug 460966
Comment 11 Matt Brubeck (:mbrubeck) 2011-05-13 11:46:22 PDT
Fixed by bug 623765.
Comment 12 Andreea Pod 2011-08-04 08:30:34 PDT
Verified fixed on build: 
Mozilla /5.0 (Android;Linux armv7l;rv:7.0a2) Gecko/20110804 Firefox/7.0a2 Fennec/7.0a2
Device: LG Opyimus 2X

I verified this bug following the steps from the description.

Note You need to log in before you can comment on or make changes to this bug.