Last Comment Bug 545631 - Bug 521523 regressed libunixproxy.so packaging
: Bug 521523 regressed libunixproxy.so packaging
Status: RESOLVED FIXED
: regression
Product: SeaMonkey
Classification: Client Software
Component: Build Config (show other bugs)
: Trunk
: All Linux
: -- minor (vote)
: seamonkey2.1a2
Assigned To: Serge Gautherie (:sgautherie)
:
Mentors:
http://mxr.mozilla.org/comm-central/s...
Depends on:
Blocks: 521523 564657
  Show dependency treegraph
 
Reported: 2010-02-11 04:53 PST by Serge Gautherie (:sgautherie)
Modified: 2012-01-04 10:32 PST (History)
2 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
(Av1) Fix regression, Group related files [Checkin: See comment 5] (4.91 KB, patch)
2010-05-10 13:18 PDT, Serge Gautherie (:sgautherie)
kairo: review+
Details | Diff | Splinter Review

Description Serge Gautherie (:sgautherie) 2010-02-11 04:53:45 PST
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1265531400.1265537595.19916.gz&fulltext=1
Linux comm-central-trunk nightly on 2010/02/07 00:30:00
{
make package-compare

-bin/components/libunixproxy.so
}

It looks like it lost its '#ifndef MOZ_STATIC_BUILD'.
Comment 1 Serge Gautherie (:sgautherie) 2010-05-10 13:18:44 PDT
Created attachment 444459 [details] [diff] [review]
(Av1) Fix regression, Group related files
[Checkin: See comment 5]
Comment 2 Justin Wood (:Callek) 2010-05-10 23:16:27 PDT
Comment on attachment 444459 [details] [diff] [review]
(Av1) Fix regression, Group related files
[Checkin: See comment 5]

>+  #ifdef XP_WIN

Preprocessor can't interpret with spaces preceding this.

Also, please simply fix the regression here than trying (again!) to reorder stuff.
Comment 3 Serge Gautherie (:sgautherie) 2010-05-11 08:30:52 PDT
(In reply to comment #2)

> Preprocessor can't interpret with spaces preceding this.

Oh? What error do you get?

> Also, please simply fix the regression here than trying (again!) to reorder
> stuff.

Why not group these files as other related ones are?
Comment 4 Robert Kaiser 2010-05-13 14:47:28 PDT
Comment on attachment 444459 [details] [diff] [review]
(Av1) Fix regression, Group related files
[Checkin: See comment 5]

OK, but please don't change the indentation in this patch.
Either we change it everywhere in this file (at once) or nowhere, but please not for some parts and not for the rest.
Comment 5 Serge Gautherie (:sgautherie) 2010-05-13 15:10:23 PDT
Comment on attachment 444459 [details] [diff] [review]
(Av1) Fix regression, Group related files
[Checkin: See comment 5]


http://hg.mozilla.org/comm-central/rev/b71ecabf4d40
Av1, with comment 4 suggestion(s).

Note You need to log in before you can comment on or make changes to this bug.