Open Bug 564654 Opened 12 years ago Updated 4 years ago

(Error and) "Warning: package error or possible missing or unnecessary file: ... (package-manifest, ...)." should be more noticeable

Categories

(Firefox Build System :: General, defect)

defect
Not set
minor

Tracking

(Not tracked)

REOPENED

People

(Reporter: sgautherie, Unassigned)

References

Details

The warnings are reported during |make package|, |make installer|...

It's a pain to have to load the full log and search it.
These warnings are often unnoticed (for quite a while).

Suggestion:
1) At least, report them in the brief log.
2) Maybe turn the build orange too.
   (maybe turn the warning into an error, as needed)

NB: |make package-compare| (output) is unrelated.
http://mxr.mozilla.org/mozilla-central/search?string=Warning%3A+package+error+or+possible+missing+or+unnecessary+file&case=1
{
/xpinstall/packager/Packager.pm
    * line 150 -- print "Warning: package error or possible missing or unnecessary file: $line ($package, $lineno).\n";
}
Blocks: 564656
Blocks: 564657
If this really is an error, it should cause make to return non-zero.  That will turn the build red.

To get them to appear in the brief log, tinderbox's parser needs to be updated to find them, or the warnings need to be modified to match something tinderbox will already highlight.

Neither of these require involvement from build.
Component: Release Engineering → Installer: XPInstall Engine
Product: mozilla.org → Core
QA Contact: release → xpi-engine
Version: other → Trunk
Blocks: 545631
Blocks: 565774
Blocks: 585460
Blocks: 585462
Blocks: 586822
Blocks: 586854
We're just going to make these fatal.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 515374
No longer blocks: 545631
No longer blocks: 550779
No longer blocks: 564606
No longer blocks: 564657
No longer blocks: 585462
No longer blocks: 534664
No longer blocks: 565774
No longer blocks: 585460
No longer blocks: 586822
No longer blocks: 586854
No longer blocks: 564656
V.Duplicate
Status: RESOLVED → VERIFIED
Bug 515374 did address the core issue :-)
But further (brief) log report improvement is still needed.

https://tbpl.mozilla.org/?tree=Try&rev=0f7ff1139bde
https://tbpl.mozilla.org/php/getParsedLog.php?id=8566957&full=1&branch=try
WINNT 5.2 try leak test build on 2012-01-15 09:28:26 PST for push 0f7ff1139bde
{
make[2]: *** [stage-package] Error 9
}
and build is reported busted (in red).

But full log still needs to be "manually" parsed to find out what the actual errors (= file(s) involved) are.

And this is even more needed for applications which are (still) reporting these failures as warnings.


(In reply to Chris AtLee [:catlee] from comment #2)
> To get them to appear in the brief log, tinderbox's parser needs to be
> updated to find them, or the warnings need to be modified to match something
> tinderbox will already highlight.

The latter is hopefully easier, but either way.
Status: VERIFIED → REOPENED
Component: Installer: XPInstall Engine → Build Config
Depends on: 515374
Flags: in-testsuite-
QA Contact: xpi-engine → build-config
Resolution: DUPLICATE → ---
Summary: "Warning: package error or possible missing or unnecessary file: ... (package-manifest, ...)." should be more noticeable → (Error and) "Warning: package error or possible missing or unnecessary file: ... (package-manifest, ...)." should be more noticeable
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.