[Fx] Crashreporter dialog is too narrow for the text

RESOLVED DUPLICATE of bug 528800

Status

Mozilla Localizations
de / German
RESOLVED DUPLICATE of bug 528800
9 years ago
4 years ago

People

(Reporter: atopal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
Created attachment 426826 [details]
Crashreporter dialog is too narrow for the text

The text in the crashreporter dialog is cut, because the dialog doesn't resize and the text doesn't break.
(Reporter)

Updated

9 years ago
Assignee: nobody → a.topal
Status: NEW → ASSIGNED
(Reporter)

Comment 1

9 years ago
Axel, is there a way to resize the crash reporter dialog? The size is okay for windows
(Reporter)

Comment 2

9 years ago
Created attachment 426859 [details]
windows dialog, right size
(Reporter)

Updated

8 years ago
Summary: Crashreporter dialog is too narrow for the text → [Fx] Crashreporter dialog is too narrow for the text
(Reporter)

Comment 3

7 years ago
Hey Ted, can you comment?
We have code that's supposed to handle this, I'm not sure why it's not working:
http://mxr.mozilla.org/mozilla-central/source/toolkit/crashreporter/client/crashreporter_osx.mm#435
(Reporter)

Comment 5

7 years ago
Ted, can I assign this to you? It's assigned to me, but there is not much I can do as a localizer.
I don't think I have time to investigate this at the moment. :-/ Maybe you could rope someone with Win32 knowledge in to look at this?
(Reporter)

Comment 7

7 years ago
Honestly, I wouldn't know whom to talk to. But as it sits here, no one will have a look at this. German is the second biggest locale after English, it's already embarrassing when Firefox crashes, but this broken window is doubly so.

Ted, can you suggest anyone I should ping about this?
Oh, I'm sorry, this is on Mac. I asked on #macdev, but it's pretty sparse. I'm sorry, I don't have any other great ideas. :-(
(Reporter)

Comment 9

7 years ago
Okay, thanks Ted.

Axel, can you comment on what to do here?

Comment 10

7 years ago
So, I don't know either, the original patch is actually by Ted ;-)

I dug a bit in, and found http://stackoverflow.com/questions/6692016/cocoa-animated-frame-in-preference-window, which says 

[window setFrame:windowFrame display:YES animate:YES];

whereas our code says

[mWindow setFrame:windowFrame display: true animate: NO];

Reading cocoa docs, it seems that "YES" is bool, and "true" is not? CCing Josh who probably knows, I'm just stabbing at dust.
As far as I can see, the code hasn't been touched: http://mxr.mozilla.org/mozilla-central/source/toolkit/crashreporter/client/crashreporter_osx.mm#159

Josh, would altering it from
     [mWindow setFrame:frame display: true animate:NO];
to
     [mWindow setFrame:frame display:YES animate:NO];
fix the issue? See comment 10.
Assignee: a.topal → nobody
Status: ASSIGNED → NEW
Flags: needinfo?(joshmoz)
That code is definitely not correct as written:
https://developer.apple.com/library/mac/documentation/cocoa/reference/applicationkit/classes/NSWindow_Class/Reference/Reference.html

I don't know if changing that will fix the bug or not, but it's worth a shot.
I think this is a dupe of bug 528800.

Comment 14

4 years ago
Definitely change the "true" to "YES". As to whether or not that will fix the bug I don't know, but I doubt it.
Flags: needinfo?(joshmoz)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 528800
You need to log in before you can comment on or make changes to this bug.