Last Comment Bug 546255 - Make nsIBrowserHistory.[un]registerOpenPage async
: Make nsIBrowserHistory.[un]registerOpenPage async
Status: RESOLVED WONTFIX
:
Product: Toolkit
Classification: Components
Component: Places (show other bugs)
: unspecified
: All All
: -- normal with 1 vote (vote)
: mozilla2.0b4
Assigned To: Marco Bonardo [::mak]
:
Mentors:
Depends on: 546253
Blocks: switch-to-tab
  Show dependency treegraph
 
Reported: 2010-02-15 00:08 PST by Blair McBride [:Unfocused] (UNAVAILABLE)
Modified: 2010-09-03 03:15 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Blair McBride [:Unfocused] (UNAVAILABLE) 2010-02-15 00:08:25 PST
Followup to bug 480350.

nsIBrowserHistory.registerOpenPage() and nsIBrowserhistory.unregisterOpenPage() use synchoronous DB calls, and are called on each pageload. This kills babies. Make them async.
Comment 1 Marco Bonardo [::mak] 2010-02-16 03:47:58 PST
(In reply to comment #0)
> Make them async.

i must note that joining by uri would solve this without need to make this async, and would also go toward direction of bug 546253
Comment 2 Blair McBride [:Unfocused] (UNAVAILABLE) 2010-02-16 04:02:14 PST
(In reply to comment #1)
> i must note that joining by uri would solve this without need to make this
> async, and would also go toward direction of bug 546253

Hm, hadn't concidered that - thanks! Would also mean the tests won't need to be chsnged to deal with async either.
Comment 3 Marco Bonardo [::mak] 2010-02-16 04:11:11 PST
i think i pointed out this possible solution in my review in bug 480350, sorry if i was unclear.
Comment 4 Marco Bonardo [::mak] 2010-09-03 03:14:37 PDT
Since now we just store in a temp table without touching disk tables, this bug is now useless. Fixed with bug 546253.
Comment 5 Marco Bonardo [::mak] 2010-09-03 03:15:06 PDT
well, better WONTFIX since they are not async.

Note You need to log in before you can comment on or make changes to this bug.