getting 'THIS IS JUST A PLACEHOLDER. YOU SHOULD NEVER SEE THIS STRING' from return receipt error dialog

RESOLVED DUPLICATE of bug 483760

Status

RESOLVED DUPLICATE of bug 483760
9 years ago
7 years ago

People

(Reporter: chris, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10_5_8; en-us) AppleWebKit/531.21.8 (KHTML, like Gecko) Version/4.0.4 Safari/531.21.10
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.2pre) Gecko/20100120 Lanikai/3.1a1 ID:20100120082014

I received 2 emails that requested return-receipt. The same issue happens for both emails (both from same sender). I clicked to send the return-receipt and then got 2 error messages:
- 'An error occurred while sending mail. The mail server responded 5.6.0 lone CR or LF in headers...'
which might not be too big a deal, but then that was immediately followed by this error:
- 'Send Message Error. THIS STRING IS JUST A PLACEHOLDER. YOU SHOULD NEVER SEE THIS STRING'
which definitely seems wrong.

I have actually seen this before recently, but am not sure what caused it then. I don't get too many return-receipt messages.

Reproducible: Sometimes
(Reporter)

Comment 1

9 years ago
Created attachment 426998 [details]
step 1 - the return-receipt dialog
(Reporter)

Comment 2

9 years ago
Created attachment 426999 [details]
step 2 - the smtp error dialog
(Reporter)

Comment 3

9 years ago
Created attachment 427000 [details]
step 3 - the placeholder error message

Comment 5

9 years ago
I think the first error was actually the root cause; it seems like we constructed an invalid return receipt message. The second error sounds like we set the error state to NS_ERROR_BUT_DONT_SHOW_ALERT, but some code went up and put up an alert anyway - http://mxr.mozilla.org/comm-central/search?string=NS_ERROR_BUT_DONT_SHOW_ALERT&case=1&find=&findi=&filter=^[^\0]*%24&hitlimit=&tree=comm-central
(Reporter)

Updated

9 years ago
Blocks: 540055

Comment 6

9 years ago
I am using Thunderbird "Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.9) Gecko/20100423 Thunderbird/3.0.4" and Thunderbird for Windows (3.0.4).

The text "THIS STRING IS JUST A PLACEHOLDER. YOU SHOULD NEVER SEE
THIS STRING" appears on return receipts and when the SMTP server is returning an error (a 4xx error).

Other people on my work are reporting the same.

Comment 7

8 years ago
Duplicate of Bug 483760 ?
(Reporter)

Comment 8

8 years ago
(In reply to comment #7)
> Duplicate of Bug 483760 ?

I'd say yes, but maybe we should dupe that to this one since there's a bit more info here. I can't seem to set dupe on other bugs..?
OS: Mac OS X → All
Hardware: PowerPC → All
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 483760

Comment 10

7 years ago
I got the message THIS IS JUST A PLACEHOLDER.  YOU SHOULD NEVER SEE THIS STRING.

when I tried to send receipt from an email account for which sending was disabled because I got too much spam on the account. 

(They put me on blacklist because they think I was sending spam myself. I dont use the account anymore but I still get emails there.)
You need to log in before you can comment on or make changes to this bug.