Last Comment Bug 546844 - [meta] Need the ability to draw persistent transparent areas of Chrome over Content
: [meta] Need the ability to draw persistent transparent areas of Chrome over C...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout: View Rendering (show other bugs)
: Trunk
: All All
: -- normal with 3 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 130078 532569
Blocks: 546831
  Show dependency treegraph
 
Reported: 2010-02-17 18:56 PST by Alex Faaborg [:faaborg] (Firefox UX)
Modified: 2011-11-20 02:27 PST (History)
16 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Alex Faaborg [:faaborg] (Firefox UX) 2010-02-17 18:56:57 PST
This is a meta bug for tracking platform changes that would enable Firefox to render persistent UI that is transparent and placed directly over the content area.

Hypothetical examples include a transparent find bar that allows the page to partially display beneath it, or an opaque find bar that only covers 1/3 of the way across the bottom of the screen.

(no idea what component this should be in, since it involves combining the chrome and content view frame hierarchies, please feel free to move it to a more appropriate component).
Comment 1 Alex Faaborg [:faaborg] (Firefox UX) 2010-02-17 20:52:42 PST
For a little more context here: intended usage is likely going to be a small set of navigational controls (back/forward/reload) in the upper left hand corner of the otherwise chromeless user created application tabs.

I used the find bar example since it's a UI that more people are familiar with.  I'll try to get some mockups put together of the app tab UI.  Ultimately we will likely end up using this capability for a variety of different interfaces.
Comment 2 Vova Olar 2010-11-26 12:19:20 PST
This can be used to open sidebar for a moment and do not shift page content.

Note You need to log in before you can comment on or make changes to this bug.