Closed Bug 547152 Opened 12 years ago Closed 1 year ago

Stray RealPlayer plugin frame appears after switching to another tab

Categories

(Core :: Widget: Cocoa, defect)

All
macOS
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: alqahira, Unassigned)

References

()

Details

Attachments

(1 file)

Amazingly, it appears that neither bug 277067 nor bug 156583 fixed the RealPlayer case of the "stray plug-in frame" bug (and none of us bothered to test against Real, either :P ).

I actually found some RealPlayer video content today (see URL field; lots of trailers there in case that one goes away), and lo and behold, switching tabs leaves a stray frame until you close the tab with the Real video.

I can reproduce this in Camino 2.0.2, Firefox 3.6 and a 1.9.2-based Camino, and a m-c Firefox that's a little old.

STR:
1) Install RealPlayer, launch the app, and go through the setup procedure (this installs the plug-in alias)
2) Launch browser, visit URL, wait for Real video to start playing
3) Switch tabs
4) Weep
Command-t won't trigger the problem.  But once at least one other tab
is open, using the mouse to switch tabs will do so.

You also see ghosts scrolling the page up and down.

I tested back to FF 2.0.0.20, all on OS X 10.5.8.

On FF 3.0.X and up you also see a ghost on the desktop when you quit.

The problem doesn't happen in Safari.  The switch-tab and desktop
ghosts don't appear in Opera, but the scrolling-up-and-down ghosts do.

Anyone tried this on Windows or Linux?
Attached image screenshot
I've encountered the same issue on:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0) Gecko/20100101 Firefox/11.0 beta 4

This is another test link: http://video.nationalgeographic.com/video/wildcamafrica/
Switching to another tab results in a stray realplayer plugin frame present in the newly opened tab. (see screenshot)
This is happening in 32bit mode and also in 64bit mode.
I forgot to mention the fact that 90% of the time, the video from the link in comment2 starts in a separate pane with realplayer player. When this is happening the issue is not reproducing. 
Only when the video starts in the player embedded in the window the issue is reproducing. Now it's seems that the video starts in the embedded player.

I have Real Player plugin 0.0.1d1
To repeat my question from comment #1, has anyone tried to reproduce this bug on Windows or Linux?  (I don't know if a Real player plugin exists for Linux, though.)
(In reply to Steven Michaud from comment #4)
> To repeat my question from comment #1, has anyone tried to reproduce this
> bug on Windows or Linux?  (I don't know if a Real player plugin exists for
> Linux, though.)

PFS2 finds 2 plugins on Ubuntu 11.10 -- one uses mplayer backend, the other uses xine backend. I'll set up a couple of VMs to test this.
Actually, I was able to track down a Linux Real Player plugin but I couldn't get it working:
http://uk.real.com/realplayer/other-versions

I'm going to try testing this on Windows now.
Unable to test this on Windows due to bug 709029 (Realplayer plugin crashes when switching tabs).
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.